well for now the ipv6 dream is overDear client,
Unfortunately we cannot help you with this request , due to our internal protocols we have to use link-local address.
Kind regards.
I guess the printed error is self-explained.
If you are using the link-local address for a route, you need to specify an interface.
Like,
/ipv6 route
add gateway=fe80::219:d1ff:fe00:3512%ether1
Well, a professional and larger-scale ISP will not put more than one customer in the same broadcast domain.but on the other hand it's a bit scary as anyone can do the same and steal your incoming traffic if the ISP cannot hard-link your /48 to the physical link or MAC or something.
/ipv6 route
add dst-address=::/0 gateway=fe80::1%ether1
/ipv6 address
add address=fe80::2a02:2f0f:1c2/64 interface=ether1
Did they really ask you that the first 48 bits of your /48 were used as the last 48 bits of your WAN IP's link-local address? Or you've chosen the 1234:5678:123 randomly as placeholders?these are the data:
ip wan fe80::1234:5678:123
GW: fe80::1
lan: 1234:5678:123::1/48
Then it's clear (bold = important, italic = not important). In rare case when I decide that I need to remember my router's link-local address, I need it to be fe80::2 and RouterOS should allow me to add it.Because according to RFC, a manually assigned link-local address can be used, but only in rare cases where automatic generation is not practical.
/ipv6 address
add address=2a02:2f0f:1c2:1::1/64 interface=lan1
/ipv6 address
add address=2a02:2f0f:1c2:2::1/64 advertise=no interface=lan2
/ipv6 route
add distance=1 dst-address=2a02:2f0f:1c2::/48 type=unreachable
So the substitution was systematic (2A02:2F0F:1C2 ->1234:5678:123 everywhere) and they really do ask you to manually set the link-local address of your WAN so that its lowest 48 bits match the highest 48 bits of your /48, and refer to RFC which admits this in special cases. Lovely. So if you ping your server's address from outside, /tool sniffer quick interface=ether6 should show you a neighbor discovery packet asking for FE80::2A02:2F0F:1C2. If this is true, you'll have to replace Mikrotik by some linux box capable of configuring link-local addresses manually.the only data the ISP gave me are:
WAN:
IP: FE80 :: 2A02: 2F0F: 1C2
GW: fe80 :: 1
LAN: 2A02: 2F0F: 1C2 :: 1/48
Yes, I suppose they read the RFC in this twisted way beneficial for them. The point is that the RFC allows to the interface owner to choose to set the link-local address manually, it doesn't mandate that it must be possible on all interfaces, to ease the link peer's life.Then it's clear (bold = important, italic = not important). In rare case when I decide that I need to remember my router's link-local address, I need it to be fe80::2 and RouterOS should allow me to add it.Because according to RFC, a manually assigned link-local address can be used, but only in rare cases where automatic generation is not practical.![]()
I wouldn't expect it to. If they have route to /48 with fe80::2a02:2f0f:1c2 as gateway, advertising /48 on WAN won't change anything.I still hope that assinging 2A02:2F0F:1C2::1/48 to WAN and setting advertise=yes for that address should be sufficient.
It is much like not supporting /31@sindy: Well, ISP shouldn't expect that every client device supports this config (and I still wonder what will average home router think about this), that's probably true. On the other hand, it's allowed, Linux can do it, ... is there any reason why RouterOS couldn't support this too? It seems clear that it will happen sooner or later, as the current behaviour seems to be arbitrary decision.
Have you tried to ping "ip6-allnodes"?ok to recap:
in ipv6 address I entered:
2a02: 2f0f: 1c2 :: 1/48 interface bridgeLAN
in the routes:
ok to recap:
in ipv6 address I entered:
2a02: 2f0f: 1c2 :: 1/48 interface bridgeLAN
in the routes:
# DST-ADDRESS GATEWAY DISTANCE
0 A S ::/0 fe80::1%eth6_WAN 1
1 ADC 2a02:2f0f:1c2::/48 bridge_LAN 0
but is unreachable
but nothing can be reached outside the LAN network are reachable
# Note that the RouterOS ipv6 firewall is a bit broken and does not allow multicast through
# Substitute ether1 by your wan interfaces
:ping ff02::1%ether1
:ping fe08::<whatever>%ether1
/ipv6 firewall filter
add action=accept chain=input comment="accept multicast" dst-address=ff00::/8 place-before=[f chain=input comment~"ICMPv6"]