Community discussions

 
sohrabp72
just joined
Topic Author
Posts: 14
Joined: Sun Oct 06, 2019 1:37 pm

Domains won't resolve after VPN is connected

Wed Oct 09, 2019 12:33 am

Hi
Recently I just set up a PPTP client on my RB and made the mangle to mark packets from my LAN and made the default route and changed the distances, etc..
everything works fine, but some domains won't resolve when I want to access them from clients in my private LAN.
All the clients get IP addresses from DHCP server and I set some public DNS on its setup page but nothing happened, enabled primary and secondary DNS on one of clients interface but still same problem.
any idea?
 
Zacharias
Forum Veteran
Forum Veteran
Posts: 747
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Domains won't resolve after VPN is connected

Wed Oct 09, 2019 10:18 pm

Why did you use mangles for?
I guess something in your mangle rules causes the problem...
Otherwise your pptp client has nothing to do with that...
 
sohrabp72
just joined
Topic Author
Posts: 14
Joined: Sun Oct 06, 2019 1:37 pm

Re: Domains won't resolve after VPN is connected

Wed Oct 09, 2019 10:42 pm

I use mangle to mark packets from my private network to just go through PPTP connection.
 
Zacharias
Forum Veteran
Forum Veteran
Posts: 747
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Domains won't resolve after VPN is connected

Wed Oct 09, 2019 11:54 pm

It looks like an MTU issue to me...
 
Beau86
just joined
Posts: 1
Joined: Wed Oct 09, 2019 10:07 am

Re: Domains won't resolve after VPN is connected

Thu Oct 10, 2019 8:35 am

While on the VPN, I can connect to the chat program via ip address, however since most of the users will be connecting through the vpn with previous setups, they'll all have the hostname saved. If I ping the hostname directly, IE domain-chat, it fails Official Site
Last edited by Beau86 on Tue Oct 22, 2019 9:45 am, edited 1 time in total.
 
sohrabp72
just joined
Topic Author
Posts: 14
Joined: Sun Oct 06, 2019 1:37 pm

Re: Domains won't resolve after VPN is connected

Thu Oct 10, 2019 2:10 pm

You made me bro.
Actually, when I was creating the PPTP client I set the MTU and MRU from 1450 to 1500 for both, I knew a lower amount will cause a problem but never knew that a higher amount will do same. Thanks, man.
 
Zacharias
Forum Veteran
Forum Veteran
Posts: 747
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Domains won't resolve after VPN is connected

Thu Oct 10, 2019 4:12 pm

Great... please mark the post as solved...

Who is online

Users browsing this forum: No registered users and 35 guests