Community discussions

MUM Europe 2020
 
mke
just joined
Topic Author
Posts: 8
Joined: Wed Sep 27, 2017 3:37 am

fq_codel or cake in v7

Thu Oct 24, 2019 6:55 am

Hi, just wanted to start another topic for this now that beta is out.

Will there be core or extra packages for modern queuing libraries like fq_codel or cake now that the kernel has been updated?

I've used both the above on an edgerouter x as a soho user with a highly asymmetrical line and they work flawlessly, simply set and forget.

The only way I could get a stable qos set up on routeros with queue trees and sfq was to tune my uploads to well below 50%. With fq_codel / cake close to 95% works no worries.
 
nkourtzis
Member Candidate
Member Candidate
Posts: 206
Joined: Tue Dec 11, 2012 12:56 am
Location: Greece

Re: fq_codel or cake in v7

Thu Oct 24, 2019 11:31 am

+1 for cake. It is more advanced than fq_codel + htb. But it will require more work, to convert the queues from htb to the cake internal shaper.
Passionate about networks
Enthusiastic about Mikrotik
MTCNA | MTCRE | MTCINE

No trees were killed to send this message,
but a large number of electrons were terribly inconvenienced.
 
santyx32
just joined
Posts: 17
Joined: Fri Oct 25, 2019 2:17 am

Re: fq_codel or cake in v7

Fri Oct 25, 2019 5:03 am

+1000 fq_codel/cake/fq_codel_fast needs less reserved bandwidth to deal with bufferbloat
 
mducharme
Trainer
Trainer
Posts: 889
Joined: Tue Jul 19, 2016 6:45 pm

Re: fq_codel or cake in v7

Sat Oct 26, 2019 2:13 am

I agree with this too, but first I want to see their current feature set stabilized. The sooner that happens, the sooner that they can release v7 and people can start using it in production. New features like this can be added easily later. If they try and add all new features that have been requested in the last several years into the first release of v7 it will take forever until it is released. I would rather see v7 stable release in 4 months than wait 7-8 months for v7 stable release with fq_codel or cake.
 
hci
Long time Member
Long time Member
Posts: 604
Joined: Fri May 28, 2004 5:10 pm

Re: fq_codel or cake in v7

Thu Nov 07, 2019 8:42 pm

+1

CoDel etc. are badly needed.

https://en.wikipedia.org/wiki/CoDel
 
brotherdust
Member Candidate
Member Candidate
Posts: 110
Joined: Tue Jun 05, 2007 1:31 am

Re: fq_codel or cake in v7

Mon Nov 18, 2019 9:42 pm

These features are already present in the kernel they chose to use for v7. What needs to be done is to "plumb" it into RouterOS and Winbox. Actually, there's MANY features in newer kernels that overlap with old v6 features that Mikrotik had to implement themselves. Depending on whether they want to keep their custom implementation or not, I imagine much of the work in v7 is removing Mikrotik implementations and using native kernel features. I expect it cake and fq_codel will become available in time. =) Be patient! At least they have STARTED on v7.
 
User avatar
Steveocee
Forum Guru
Forum Guru
Posts: 1115
Joined: Tue Jul 21, 2015 10:09 pm
Location: UK
Contact:

Re: fq_codel or cake in v7

Wed Dec 18, 2019 7:26 pm

+1 for FQ_Codel I really want this feature in RouterOS. It is probably one of the only reasons why I look outside of the MikroTik product range.
Steve "Steveocee" Carter
PC Gamer, Airsofter, MikroTik Nerd
My Website - My MikroTik Tutorials
 
User avatar
skylark
MikroTik Support
MikroTik Support
Posts: 124
Joined: Wed Feb 10, 2016 3:55 pm

Re: fq_codel or cake in v7

Thu Dec 19, 2019 11:15 am

Fq_codel implementation would be a great improvement. Of course we cannot promise anything about new features, but your requests are noted!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8330
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: fq_codel or cake in v7

Fri Dec 20, 2019 5:40 pm

🤞
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
UpRunTech
Member Candidate
Member Candidate
Posts: 108
Joined: Fri Jul 27, 2012 12:11 pm

Re: fq_codel or cake in v7

Sun Dec 22, 2019 1:47 pm

Well, if you use PCQ you have some knobs to twiddle. I have improved ADSL2+ responsiveness with PCQ in simple queues by making the buffers smaller than the default (which otherwise seem to work well with 50+MBit speeds). For example on an ADSL2 annex m line with max-limit=1400k/16500k these queues keep web browsing snappy enough even when the upload (especially) and downloads are busy.

/queue type
add kind=pcq name=pcq-upload-adsl pcq-classifier=src-address,src-port \
pcq-limit=2KiB pcq-total-limit=1000KiB
add kind=pcq name=pcq-download-adsl pcq-classifier=dst-address,dst-port \
pcq-limit=20KiB

From what I can tell fq-codel has some insight (because it's in the kernel) into how quickly data is moving through each tracked connection and can adjust the buffers accordingly to mimimise the time they hang around. With PCQ you can adjust the buffer sizes but I can't think of a way you could even use a script to adjust them dynamically.

The adhoc way to set this up is:
  • Set the queue max-limits to 90-95% of your measured saturated bit rate (using speed test for instance and use the peak values you see in the traffic plots in Winbox not what Speedtest says).
  • Adjust your pcq-limits downwards incrementally until you notice the responsiveness or pings get acceptable when the upload and downloads are saturated.
 
ivicask
Member Candidate
Member Candidate
Posts: 249
Joined: Tue Jul 07, 2015 2:40 pm
Location: Croatia, Zagreb

Re: fq_codel or cake in v7

Sun Dec 22, 2019 3:59 pm

Well, if you use PCQ you have some knobs to twiddle. I have improved ADSL2+ responsiveness with PCQ in simple queues by making the buffers smaller than the default (which otherwise seem to work well with 50+MBit speeds). For example on an ADSL2 annex m line with max-limit=1400k/16500k these queues keep web browsing snappy enough even when the upload (especially) and downloads are busy.

/queue type
add kind=pcq name=pcq-upload-adsl pcq-classifier=src-address,src-port \
pcq-limit=2KiB pcq-total-limit=1000KiB
add kind=pcq name=pcq-download-adsl pcq-classifier=dst-address,dst-port \
pcq-limit=20KiB

From what I can tell fq-codel has some insight (because it's in the kernel) into how quickly data is moving through each tracked connection and can adjust the buffers accordingly to mimimise the time they hang around. With PCQ you can adjust the buffer sizes but I can't think of a way you could even use a script to adjust them dynamically.

The adhoc way to set this up is:
  • Set the queue max-limits to 90-95% of your measured saturated bit rate (using speed test for instance and use the peak values you see in the traffic plots in Winbox not what Speedtest says).
  • Adjust your pcq-limits downwards incrementally until you notice the responsiveness or pings get acceptable when the upload and downloads are saturated.
Sounds good, doesnt work.
 
OutcomeTech
just joined
Posts: 2
Joined: Wed Oct 16, 2019 3:24 am

Re: fq_codel or cake in v7

Sun Dec 29, 2019 2:25 pm

+1 for fq_codel and/or CAKE in ROS v7, as soon as reasonably possible. Thank you for listening!
 
UpRunTech
Member Candidate
Member Candidate
Posts: 108
Joined: Fri Jul 27, 2012 12:11 pm

Re: fq_codel or cake in v7

Sun Jan 12, 2020 1:36 am

Sounds good, doesnt work.
Did you even try it? It the modified PCQ improved my ADSL2 connection when I had it, I am using it still to good effect one some sites stuck with ADSL2 and someone on IRC has just used it with success on a 3M/512K connection.
 
Binser
newbie
Posts: 28
Joined: Fri Dec 28, 2018 7:50 pm

Re: fq_codel or cake in v7

Thu Jan 16, 2020 5:12 pm

+1 for fq_codel/cake
 
Note
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Fri Jun 03, 2016 12:39 pm

Re: fq_codel or cake in v7

Thu Jan 16, 2020 9:05 pm

plus 1000 for all of that stuff that will make our life better. Mikrotik plz stop all other and focus on that........ only.
 
PtDragon
Frequent Visitor
Frequent Visitor
Posts: 78
Joined: Sun Apr 26, 2009 8:52 pm

Re: fq_codel or cake in v7

Thu Jan 23, 2020 12:52 am

I would love to see:
CoDel
FQ_CoDel
Cake
Pie
FQ_Pie
and every other complete implementation of queues.
Those will not take much space but will help a lot with keeping buffers low.
CCR1036-12G-4S +6x100Mbit ^_^
 
santyx32
just joined
Posts: 17
Joined: Fri Oct 25, 2019 2:17 am

Re: fq_codel or cake in v7

Mon Jan 27, 2020 10:37 pm

Well, if you use PCQ you have some knobs to twiddle. I have improved ADSL2+ responsiveness with PCQ in simple queues by making the buffers smaller than the default (which otherwise seem to work well with 50+MBit speeds). For example on an ADSL2 annex m line with max-limit=1400k/16500k these queues keep web browsing snappy enough even when the upload (especially) and downloads are busy.

/queue type
add kind=pcq name=pcq-upload-adsl pcq-classifier=src-address,src-port \
pcq-limit=2KiB pcq-total-limit=1000KiB
add kind=pcq name=pcq-download-adsl pcq-classifier=dst-address,dst-port \
pcq-limit=20KiB

From what I can tell fq-codel has some insight (because it's in the kernel) into how quickly data is moving through each tracked connection and can adjust the buffers accordingly to mimimise the time they hang around. With PCQ you can adjust the buffer sizes but I can't think of a way you could even use a script to adjust them dynamically.

The adhoc way to set this up is:
  • Set the queue max-limits to 90-95% of your measured saturated bit rate (using speed test for instance and use the peak values you see in the traffic plots in Winbox not what Speedtest says).
  • Adjust your pcq-limits downwards incrementally until you notice the responsiveness or pings get acceptable when the upload and downloads are saturated.
Sounds good, doesnt work.
I use a PCQ queue tree to keep my bufferbloat under load between 20-100ms compared to 300-1000ms without it. In the past I used a DD-WRT router with CAKE and it kept the bufferbloat at 30ms losing only 3mbps compared to 8mbps using PCQ.

PD 1: I use queue tree instead of simple queues because I have multiple bridge interfaces for guests and IOT.
PD 2: I have 97/72mbps fiber but my ISP think bufferbloat is an imaginary problem that only exists in my mind and everything is fine on their side :lol: .

Who is online

Users browsing this forum: wispmikrotik and 10 guests