Community discussions

 
dtep
just joined
Topic Author
Posts: 2
Joined: Sat Nov 09, 2019 8:39 pm

Hap AC2. Wifi speed to Internet much lower than to LAN

Sat Nov 09, 2019 8:51 pm

Hello everyone!
I faced a very strange situation and can't find any solution.
I have Hap AC2 connected to 100Mbit Internet provider and Qnap NAS connected to it by 1Gb port. For test purposes I used Macbook Pro 2018 and Samsung Galaxy Note 8.
I set up wireless network on my router and after some tests I got:
LAN 1Gbit -> Mikrotik -> SpeedTest -> 95Mbit up/down. OK
Wifi 5G from my Macbook -> Qnap NAS connected to LAN - > 400Mbit on Mac wifi adapter. About 200 Mbit on Mikrotik wifi interface. Also seems OK.

But! Wifi 5G from my Mac -> Speedtest -> 60Mbit download and 95 upload!
How???
Tests with my NAS shows that wifi was configured correctly. Router also works ok with cable tests.
Why I can't get full download speed from the Internet?

I tried firmwares 6.45.7 (the latest stable for today) and 6.44.6 (long term stable).
I made full reset of the router and configured it from zero. I tried to disable all firewall rules including Fasttrack. The results of Speedtest were the same.

Do you have any ideas why it can be?

There are my settings:
# nov/09/2019 20:47:57 by RouterOS 6.44.6
# software id = P1BB-0WFQ
#
# model = RBD52G-5HacD2HnD

/interface bridge
add admin-mac=74:4D:28:E5:DF:DD auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX distance=indoors frequency=auto installation=indoor mode=ap-bridge ssid=MikroTik-E5DFE1 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40/80mhz-Ceee country=ukraine disabled=no frequency=auto frequency-mode=regulatory-domain hw-protection-mode=rts-cts installation=indoor mode=ap-bridge ssid=MikroTik \
    tx-power-mode=all-rates-fixed
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=12345
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
[*]/ip firewall export 
# nov/09/2019 20:49:24 by RouterOS 6.44.6
# software id = P1BB-0WFQ
#
# model = RBD52G-5HacD2HnD

/ip firewall filter
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface-list=WAN
 
Zacharias
Forum Veteran
Forum Veteran
Posts: 737
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: Hap AC2. Wifi speed to Internet much lower than to LAN

Sun Nov 10, 2019 8:36 pm

You could try some other frequencies and also play a little with the channel width and central frequency...

Other than that since you have a slow download it seems like a transmit problem from the wifi perspective...

Try my suggestion and see how it goes...
 
dtep
just joined
Topic Author
Posts: 2
Joined: Sat Nov 09, 2019 8:39 pm

Re: Hap AC2. Wifi speed to Internet much lower than to LAN

Sun Nov 10, 2019 8:46 pm

You could try some other frequencies and also play a little with the channel width and central frequency...

Other than that since you have a slow download it seems like a transmit problem from the wifi perspective...

Try my suggestion and see how it goes...
The main problem is that I have low download speed only from Internet. When I downloading something via WiFi from my NAS, everything is OK

So, I can't say that there is wifi problem. It something wrong between wifi interface and WAN.

Who is online

Users browsing this forum: No registered users and 35 guests