Community discussions

 
iauvi
just joined
Topic Author
Posts: 4
Joined: Sat Nov 09, 2019 9:44 pm

hAP AC2: 5GHZ is not showing

Sat Nov 09, 2019 10:46 pm

I’m from Bangladesh. I am using hAP AC2 and cAP AC.
I have configured the hAP AC2 as main router and cAP AC as CAP.
The issue I am facing with is 5G band.

As I configured the CAP device, I am getting SSID of 5GHz band of the CAP device in my android devices.
But I’m not getting the 5GHz band SSID in my android devices from hAP AC, getting only 2.4GHz SSID. By the way, I’m getting the 5GHz SSID in my laptop.

Need assistance. I’m attaching my configuration files of Both the hAP ac2 and cAP ac devices.

hAP AC2 config
# nov/10/2019 02:35:43 by RouterOS 6.45.7
#
# model = RBD52G-5HacD2HnD
# serial number = BEEB0A340450
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk disable-pmkid=\
    no eap-methods=passthrough group-ciphers=aes-ccm group-key-update=5m \
    interim-update=0s management-protection=disabled mode=dynamic-keys \
    mschapv2-username="" name=default radius-called-format=mac:ssid \
    radius-eap-accounting=no radius-mac-accounting=no \
    radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-sta-private-algo=none static-transmit-key=key-0 \
    supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm
add authentication-types=wpa-psk,wpa2-psk disable-pmkid=no eap-methods=\
    passthrough group-ciphers=aes-ccm group-key-update=5m interim-update=0s \
    management-protection=disabled mode=dynamic-keys mschapv2-username="" \
    name=profile radius-called-format=mac:ssid radius-eap-accounting=no \
    radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=\
    disabled radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-sta-private-algo=none static-transmit-key=key-0 \
    supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm
add authentication-types=wpa-psk,wpa2-psk disable-pmkid=no eap-methods="" \
    group-ciphers=aes-ccm group-key-update=5m interim-update=0s \
    management-protection=allowed mode=dynamic-keys mschapv2-username="" \
    name=Guest radius-called-format=mac:ssid radius-eap-accounting=no \
    radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=\
    disabled radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-sta-private-algo=none static-transmit-key=key-0 \
    supplicant-identity="" tls-certificate=none tls-mode=no-certificates \
    unicast-ciphers=aes-ccm
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=none allow-sharedkey=\
    no ampdu-priorities=0 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=\
    0 area="" arp=enabled arp-timeout=auto band=2ghz-b/g/n basic-rates-a/g=\
    6Mbps basic-rates-b=1Mbps bridge-mode=enabled channel-width=20mhz \
    compression=no country=no_country_set default-ap-tx-limit=0 \
    default-authentication=yes default-client-tx-limit=0 default-forwarding=\
    yes disable-running-check=no disabled=no disconnect-timeout=3s distance=\
    dynamic frame-lifetime=0 frequency=auto frequency-mode=manual-txpower \
    frequency-offset=0 guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mc\
    s-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,m\
    cs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-2\
    3" hw-fragmentation-threshold=disabled hw-protection-mode=none \
    hw-protection-threshold=0 hw-retries=7 installation=indoor \
    interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 \
    mac-address=74:4D:28:D4:B1:0B max-station-count=2007 mode=ap-bridge mtu=\
    1500 multicast-buffering=enabled multicast-helper=default name=\
    "Imam MTK 2.4G int" nv2-cell-radius=30 nv2-downlink-ratio=50 nv2-mode=\
    dynamic-downlink nv2-qos=default nv2-queue-count=2 nv2-security=disabled \
    nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=both \
    radio-name=744D28D4B10B rate-selection=advanced rate-set=default \
    rx-chains=0,1 scan-list=default secondary-channel="" security-profile=\
    default ssid=ImamMTK2.4 station-bridge-clone-mac=00:00:00:00:00:00 \
    station-roaming=enabled supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
    1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 tx-chains=0,1 \
    tx-power-mode=default update-stats-interval=disabled vlan-id=1 vlan-mode=\
    no-tag wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 \
    wds-ignore-ssid=no wds-mode=disabled wireless-protocol=802.11 \
    wmm-support=disabled wps-mode=push-button
set [ find default-name=wlan2 ] adaptive-noise-immunity=none allow-sharedkey=\
    no ampdu-priorities=0 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=\
    0 area="" arp=enabled arp-timeout=auto band=5ghz-a/n/ac basic-rates-a/g=\
    6Mbps bridge-mode=enabled channel-width=20mhz compression=no country=\
    no_country_set default-ap-tx-limit=0 default-authentication=yes \
    default-client-tx-limit=0 default-forwarding=yes disable-running-check=no \
    disabled=no disconnect-timeout=3s distance=dynamic frame-lifetime=0 \
    frequency=auto frequency-mode=manual-txpower frequency-offset=0 \
    guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mc\
    s-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,m\
    cs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-2\
    3" hw-fragmentation-threshold=disabled hw-protection-mode=none \
    hw-protection-threshold=0 hw-retries=7 installation=indoor \
    interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 \
    mac-address=74:4D:28:D4:B1:0C max-station-count=2007 mode=ap-bridge mtu=\
    1500 multicast-buffering=enabled multicast-helper=default name=\
    "Imam MTK 5G int" nv2-cell-radius=30 nv2-downlink-ratio=50 nv2-mode=\
    dynamic-downlink nv2-qos=default nv2-queue-count=2 nv2-security=disabled \
    nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=both \
    radio-name=744D28D4B10C rate-selection=advanced rate-set=default \
    rx-chains=0,1 scan-list=default secondary-channel="" security-profile=\
    default ssid=ImamMTK5 station-bridge-clone-mac=00:00:00:00:00:00 \
    station-roaming=enabled supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps tdma-period-size=2 \
    tx-chains=0,1 tx-power-mode=default update-stats-interval=disabled \
    vht-basic-mcs=mcs0-7 vht-supported-mcs=mcs0-9,mcs0-9,mcs0-9 vlan-id=1 \
    vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled \
    wireless-protocol=802.11 wmm-support=disabled wps-mode=push-button
add area="" arp=enabled arp-timeout=auto bridge-mode=enabled \
    default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=\
    0 default-forwarding=yes disable-running-check=no disabled=no hide-ssid=\
    no interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 \
    mac-address=76:4D:28:D4:B1:0C master-interface="Imam MTK 5G int" \
    max-station-count=2007 mode=ap-bridge mtu=1500 multicast-buffering=\
    enabled multicast-helper=default name=wlan3 security-profile=Guest ssid=\
    "Imam Guests" station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=\
    enabled update-stats-interval=disabled vlan-id=1 vlan-mode=no-tag \
    wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 \
    wds-ignore-ssid=no wds-mode=disabled wmm-support=disabled wps-mode=\
    push-button
add area="" arp=enabled arp-timeout=auto bridge-mode=enabled \
    default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=\
    0 default-forwarding=yes disable-running-check=no disabled=no hide-ssid=\
    no interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 \
    mac-address=76:4D:28:D4:B1:0B master-interface="Imam MTK 2.4G int" \
    max-station-count=2007 mode=ap-bridge mtu=1500 multicast-buffering=\
    enabled multicast-helper=default name=wlan4 security-profile=Guest ssid=\
    "Imam Guests" station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=\
    enabled update-stats-interval=disabled vlan-id=1 vlan-mode=no-tag \
    wds-cost-range=50-150 wds-default-bridge=none wds-default-cost=100 \
    wds-ignore-ssid=no wds-mode=disabled wmm-support=disabled wps-mode=\
    push-button
/interface wireless manual-tx-power-table
set "Imam MTK 2.4G int" manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:\
    17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54M\
    bps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:\
    17,HT20-7:17,HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,H\
    T40-6:17,HT40-7:17"
set "Imam MTK 5G int" manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17\
    ,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:17,36Mbps:17,48Mbps:17,54Mbp\
    s:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17\
    ,HT20-7:17,HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT4\
    0-6:17,HT40-7:17"
/interface wireless nstreme
set "Imam MTK 2.4G int" disable-csma=no enable-nstreme=no enable-polling=yes \
    framer-limit=3200 framer-policy=none
set "Imam MTK 5G int" disable-csma=no enable-nstreme=no enable-polling=yes \
    framer-limit=3200 framer-policy=none
/interface wireless access-list
add allow-signal-out-of-range=10s ap-tx-limit=3000000 authentication=yes \
    client-tx-limit=0 disabled=no forwarding=yes mac-address=\
    00:00:00:00:00:00 private-algo=none signal-range=-120..120 !time vlan-id=\
    1 vlan-mode=default
add allow-signal-out-of-range=10s ap-tx-limit=3000000 authentication=yes \
    client-tx-limit=0 disabled=no forwarding=yes interface=wlan4 mac-address=\
    00:00:00:00:00:00 private-algo=none signal-range=-120..120 !time vlan-id=\
    1 vlan-mode=default
add allow-signal-out-of-range=10s ap-tx-limit=3000000 authentication=yes \
    client-tx-limit=0 disabled=no forwarding=yes interface=wlan3 mac-address=\
    00:00:00:00:00:00 private-algo=none signal-range=-120..120 !time vlan-id=\
    1 vlan-mode=default
add allow-signal-out-of-range=10s ap-tx-limit=3000000 authentication=yes \
    client-tx-limit=0 disabled=no forwarding=yes mac-address=\
    00:00:00:00:00:00 private-algo=none signal-range=-120..120 !time vlan-id=\
    1 vlan-mode=default
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=\
    00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 frame-size=300 \
    frames-per-second=25 receive-all=no ssid-all=no
/interface wireless cap
set bridge=none caps-man-addresses="" caps-man-certificate-common-names="" \
    caps-man-names="" certificate=none discovery-interfaces="" enabled=no \
    interfaces="" lock-to-caps-man=no static-virtual=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 \
    multiple-channels=no only-headers=no receive-errors=no streaming-enabled=\
    no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
cAP AC config
# nov/10/2019 02:36:39 by RouterOS 6.45.7
# software id = NNSW-YWGW
#
# model = RBD52G-5HacD2HnD
# serial number = BEEB0A340450
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto \
    installation=indoor mode=ap-bridge name="Imam MTK 2.4G int" ssid=\
    ImamMTK2.4 wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac disabled=no frequency=auto \
    installation=indoor mode=ap-bridge name="Imam MTK 5G int" ssid=ImamMTK5 \
    wireless-protocol=802.11
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
    dynamic-keys supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk mode=dynamic-keys name=profile \
    supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=Guest \
    supplicant-identity=""
/interface wireless
add disabled=no mac-address=76:4D:28:D4:B1:0C master-interface=\
    "Imam MTK 5G int" name=wlan3 security-profile=Guest ssid="Imam Guests"
add disabled=no mac-address=76:4D:28:D4:B1:0B master-interface=\
    "Imam MTK 2.4G int" name=wlan4 security-profile=Guest ssid="Imam Guests"
/interface wireless access-list
add ap-tx-limit=3000000
add ap-tx-limit=3000000 interface=wlan4
add ap-tx-limit=3000000 interface=wlan3
add ap-tx-limit=3000000
 
mkx
Forum Guru
Forum Guru
Posts: 3177
Joined: Thu Mar 03, 2016 10:23 pm

Re: hAP AC2: 5GHZ is not showing

Sun Nov 10, 2019 5:04 pm

If you can use 5G wireless with your PC, then generally hAP ac2 is OK. Then you have to verify that your Android devices actually support 5G wireless. If they do, then check country settings on both Android devices and RB devices... some channels are not available in all countries and in that case clients will ignore APs operating on "forbidden" channels..
BR,
Metod
 
iauvi
just joined
Topic Author
Posts: 4
Joined: Sat Nov 09, 2019 9:44 pm

Re: hAP AC2: 5GHZ is not showing

Sun Nov 10, 2019 7:43 pm

My Android devices support 5GHz carrier.
I'm getting the ssid of 5G carrier of my cap device, but not from the hap device.
Suggest me a country that will support
 
mkx
Forum Guru
Forum Guru
Posts: 3177
Joined: Thu Mar 03, 2016 10:23 pm

Re: hAP AC2: 5GHZ is not showing

Sun Nov 10, 2019 8:05 pm

First bet would be to use proper country setting (reflecting your actual country). Likely android devices get that information from mobile networks (if they're mobile phones) ...

Here's my own experience. I live in Europe which means 2.4GHz channel number 13 is legal to use (it is not legal in US). When by better half got new mobile (LG G4), first thing out of box I tried to connect it to home wireless network. And the gadget simply did not detect the SSID (control channel was on channel 13). Next thing was to put in SIM card, after that it happily detected and used SSID still broadcasted on channel 13.
BR,
Metod
 
iauvi
just joined
Topic Author
Posts: 4
Joined: Sat Nov 09, 2019 9:44 pm

Re: hAP AC2: 5GHZ is not showing

Sun Nov 10, 2019 11:45 pm

In hAP i have configured "no_country_set"
in cAp it is disabled or no value
See the image
Image

Can I make the country option leave blank as cap???? Is there any option???
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 648
Joined: Fri Nov 10, 2017 8:19 am

Re: hAP AC2: 5GHZ is not showing

Mon Nov 11, 2019 7:47 am

the gadget simply did not detect the SSID (control channel was on channel 13). Next thing was to put in SIM card, after that it happily detected and used SSID still broadcasted on channel 13.
That is actually interesting finding! thanks for sharing. Sometime I struggle with this and I never realised it might be just a simple software adjustment.
 
iauvi
just joined
Topic Author
Posts: 4
Joined: Sat Nov 09, 2019 9:44 pm

Re: hAP AC2: 5GHZ is not showing

Mon Nov 11, 2019 2:04 pm

Is there any way to disable country setting from wireless? Then I think it will work.
Image

Who is online

Users browsing this forum: MSN [Bot] and 33 guests