Community discussions

MikroTik App
 
Term
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 58
Joined: Thu Jan 11, 2018 11:42 pm

Homeoffice - VPN

Wed Mar 25, 2020 9:17 pm

Hello,
I'm trying to create VPN from my home's mikrotik to work. How can I do that?
I already created VPN connection but my computer still can't access to company's network.
Have more computers at home but want to be able to access company's network from one computer only.

Thank you for your tips.
 
tdw
Member Candidate
Member Candidate
Posts: 279
Joined: Sat May 05, 2018 11:55 am

Re: Homeoffice - VPN

Wed Mar 25, 2020 10:07 pm

If you only wish one computer to access your company network it would be far simpler to set up VPN connections from that one computer.
 
szymonzdziabek
just joined
Posts: 10
Joined: Wed Mar 25, 2020 1:01 pm
Location: Poland

Re: Homeoffice - VPN

Wed Mar 25, 2020 10:09 pm

If you try to connect to the company network, you should create a VPN connection on your PC, not on your router. Or not, if you would like to have site2site link.
 
Term
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 58
Joined: Thu Jan 11, 2018 11:42 pm

Re: Homeoffice - VPN

Wed Mar 25, 2020 10:17 pm

Yes but I don't want to make VPN connection in computer because of another VPN.
 
Sob
Forum Guru
Forum Guru
Posts: 5416
Joined: Mon Apr 20, 2009 9:11 pm

Re: Homeoffice - VPN

Wed Mar 25, 2020 11:22 pm

Likely solution:
/ip firewall nat
add chain=srcnat out-interface=<your VPN interface> action=masquerade
And then to limit access (assuming you have default firewall or other with standard rules to allow established connections):
/ip firewall filter
add chain=forward src-address=<your PC in LAN> out-interface=<your VPN interface> action=accept
add chain=forward out-interface=<your VPN interface> action=reject
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.
 
Term
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 58
Joined: Thu Jan 11, 2018 11:42 pm

Re: Homeoffice - VPN

Thu Mar 26, 2020 8:53 pm

Ok I followed your guide. Doesn't work. Still can't connect to compan without VPN in computer
 
Sob
Forum Guru
Forum Guru
Posts: 5416
Joined: Mon Apr 20, 2009 9:11 pm

Re: Homeoffice - VPN

Thu Mar 26, 2020 9:44 pm

That's the problem with blind guesses, sometimes they succeed and sometimes they don't. But without anything specific, exported config for example, it's difficult to do more.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply. Not intended as incentive for masochists.
 
User avatar
ninja365
newbie
Posts: 27
Joined: Wed Jun 13, 2018 8:29 pm
Location: Norwich
Contact:

Re: Homeoffice - VPN

Sun Mar 29, 2020 12:20 pm

Yes but I don't want to make VPN connection in computer because of another VPN.
You can have multiple VPN connections on a PC so that would be a much simpler solution.

Sent from my moto g(7) plus using Tapatalk

Who is online

Users browsing this forum: MSN [Bot] and 181 guests