Community discussions

MikroTik App
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Random connection dropping vol2

Sat Mar 28, 2020 1:27 pm

Hello,
I’m still having problems with my mikrotik setup 

Previous posts:
viewtopic.php?f=13&t=145719
viewtopic.php?t=153418
Problem is that from time to time the internet connection drops while a device is still connected to the AP. The problem specially affects mobile devices but PCs and Macs are affected as well.
Now the problem occurs for example when browsing the internet watching videos etc and at that precise moment you can’t event connect to the main router (gateway) @ 192.168.88.1. The device itself stays connected to the AP.

The last fix by turning of rstp on the switches helped a lot but there are still issues.

The setup is very simple and i have attached every single devices configuration export as well (except switch, you can find that configuration in the previous thread, that configuration has not changed). Switches have been assigned static ip addresses and on 192.168.88.4 switch i have ticked the box that says Long PoE in cable.

The APs configuration is done by reseting the AP with no default config and the export file that is attached to this post is put in the terminal and executed.

Also i have attached the network topology:
Oru network topology-2.png
Every AC lite box runs 2.4GHz on different channels to make sure they don’t overlap.

Can anyone please tell me what am i doing wrong. I have been searching for a solution for months now and still got problems. This however is the most stable setup i could get. Default configuration with minor tweaks, as putting the router in bridge mode and assigning static ip address, will not work at all.

SXT-LTE is in default configuration only minor changes:
* automatic upgrade enabled
* sim card pin added
* some static ip addresses assigned
* dhcp lease time set to 1 day
* logging and some services (telnet, api, ssh disabled)
You do not have the required permissions to view the files attached to this post.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Mon Mar 30, 2020 1:43 am

The best way to diagnose this problems is checking log's at device.
You you have a downtime problem then you should check if some device not do reboot. Check in AP log-s that mac client have some reconnection or not. check at sxt if insternet that time is active.
In my opinion by checking logs you should found a problem.

This problems are very short in time loke 1-2sek or longer like 30s?

If you can "do/recreate a problem" then this will be perfect. If not then only checking logs will be good.
Setup the netwatch script at every ros device to check other one.
If you can install TheDude inside network then this will be good help for you, just add devices for ping test purpose.

About SXT(R) check this:
Simple watchdog: viewtopic.php?f=7&t=153622&hilit=watchdog#p767767
Advance watchdog: viewtopic.php?f=9&t=151492&hilit=watchdog#p768392
Watch LTE parameters: viewtopic.php?f=7&t=153622&hilit=watchdog#p768105

I hope that way you can found that problem.
Last edited by SiB on Sun Apr 05, 2020 4:37 pm, edited 1 time in total.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Sun Apr 05, 2020 1:33 pm

This problems are very short in time loke 1-2sek or longer like 30s?
20-30s
If you can "do/recreate a problem" then this will be perfect. If not then only checking logs will be good.
Right now i have not been able to recreate that problem
Setup the netwatch script at every ros device to check other one.
Will do that
Fixed the links.
Simple watchdog: viewtopic.php?f=7&t=153622&hilit=watchdog#p767767
Advance watchdog: viewtopic.php?f=9&t=151492&hilit=watchdog#p768392
Watch LTE parameters: viewtopic.php?f=7&t=153622&hilit=watchdog#p768105
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Wed May 06, 2020 10:48 am

Okay i did some further analysis and this packet drop is repeatable. by pinging 8.8.8.8 from a laprop connected to any AP i see packet drop of about 10% now when i ping from the sxt router i have 0 packet loss and with avg ping of 23ms. The laptop is showing rssi levels of -51 and below.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Wed May 06, 2020 11:09 am

Watch LTE parameters - LteLogger should show you a change between BTS Band/Cell and many that behavior like
* after reboot pings are ok
* when I wait ... then can fix itself
* I move device position and it's fix
can be logged to what cell id you are connect and when all works properly you can do:
* cell lock to have connection with one band and his specific "antenna".
* log change of cellid and that way discover witch one is proper for you.

This all what I write are 80% true.
Some times when you are at CellLock and see the problems are sometimes... then you can thinking then about
* differ signals means parametes of quality link between you and bts
* you should correct position of device etc...
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
User avatar
mutluit
Long time Member
Long time Member
Posts: 505
Joined: Wed Mar 25, 2020 4:04 am

Re: Random connection dropping vol2

Wed May 06, 2020 4:56 pm

As other posters already said: analyze the log files of the devices.
It seems a device is rebooting due to high heat, or due to an internal error, for example when there is an endless loop in internal code or in a script...
Check, whether it's a heat issue. If your devices have active cooling fans, then maybe a fan is defect, or if they are passive cooled, then try to cool the device with an external fan, for example a small USB fan... and monitor whether the error still happens.

Another possibility is that you maybe inadvertently are using a wrong power adapter for a device, ie. maybe its Ampere number is too small. Check & verify with the device documentation/specification.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 07, 2020 8:01 am

I have all the logs enabled even debug but the log is empty? Is there a guide how to turn it on?
You do not have the required permissions to view the files attached to this post.
Last edited by john231 on Thu May 07, 2020 9:15 am, edited 1 time in total.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 07, 2020 9:14 am

Watch LTE parameters - LteLogger should show you a change between BTS Band/Cell and many that behavior like
* after reboot pings are ok
* when I wait ... then can fix itself
* I move device position and it's fix
can be logged to what cell id you are connect and when all works properly you can do:
* cell lock to have connection with one band and his specific "antenna".
* log change of cellid and that way discover witch one is proper for you.

This all what I write are 80% true.
Some times when you are at CellLock and see the problems are sometimes... then you can thinking then about
* differ signals means parametes of quality link between you and bts
* you should correct position of device etc...
What i said was that the LTE end is OK there is no problem pinging from the SXT-LTE. There is no heat issue, the SXT is outside with temps around 15 degrees celsius.

It seems to be a Layer 2 problem and seems to coincide with DHCP lease time expiring.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 07, 2020 9:17 am

Also one thing i noticed, maybe it's ok maybe not but when i look at the SXT-LTE neighbours list i see 2 mac addresses from 1 device.
Although on that AP on eth1 and wlan1 i have ARP disabled.
You do not have the required permissions to view the files attached to this post.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 07, 2020 10:24 am

Okay that mac address problem seemed to do the trick.. had to set the admin mac address on the bridge..

The admin mac address on the bridge is set to eth1 which is my "WAN" port that is connected to the switch.

Also got my logging working as well.
You do not have the required permissions to view the files attached to this post.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Thu May 07, 2020 10:31 am

and I say one, you do other one.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 07, 2020 11:35 am

Like i said it is a layer 2 problem. It has nothing to do with CellLock or anything of the sorts. SXT-LTE works fine. The problem is with the internal network and when i setup the AP i added interfaces to the bridge as follows:
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1


thus auto-mac feature on the bridge interface took wlan1 mac aadress for it's own mac address as well.

it should have been like this..
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1


Or better yet the bridge should have it's own mac address that is unique to the network.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Fri May 08, 2020 5:24 pm

john231

Or better yet the bridge should have it's own mac address that is unique to the network.
True
my all bridge interface have got uniq admin mac-address.
I generate MAC address by adding new EoIP interface who generate mac-address itself - I not add EoIP, just open form of new tunnel to copy from it new mac-address and press Cancel.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Fri May 15, 2020 2:21 pm

One question still.. Now when i have all my interfaces in a bridge and bridge has been assigned an ip and ip neighbor discovery is set as default " !dynamic ".
When i look at discovered neighbours i see the bridge mac and eth1 mac of all the AP's shouldn't i only see the bridge one?
/ip neighbor print
 # INTERFACE ADDRESS                                 MAC-ADDRESS      
 0 ether1    192.168.88.1                            B8:69:F4:01:35:55
   bridge1  
 1 ether1    192.168.88.2                            02:2A:F3:AA:A1:E2
   bridge1  
 2 ether1    192.168.88.2                            B8:69:F4:B1:FC:C0
   bridge1  
 3 ether1    192.168.88.3                            02:2F:19:EF:AF:37
   bridge1  
 4 ether1    192.168.88.3                            B8:69:F4:95:63:8E
   bridge1  
 5 ether1    192.168.88.4                            B8:69:F4:23:27:AE
   bridge1  
 6 ether1    192.168.88.5                            B8:69:F4:B4:1D:66
   bridge1
   
What is the neighbour discovery used for?
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Fri May 15, 2020 5:14 pm

This is normal because this discavery is at Layer2 and show real interface, even if he is assign to bridge... look
Image
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Sun May 17, 2020 3:57 pm

Is there a difference in which order ports should be added to the bridge?

this will cause problems..
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
this will not..
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
add bridge=bridge1 interface=wlan2
add bridge=bridge1 interface=wlan1
why is that?
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Sun May 17, 2020 4:13 pm

no difference
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
mkx
Forum Guru
Forum Guru
Posts: 4221
Joined: Thu Mar 03, 2016 10:23 pm

Re: Random connection dropping vol2

Sun May 17, 2020 5:35 pm

no difference
.... if you manually set MAC address on bridge first. And even then you might experience (transitional) loss of connectivity because management MAC may change this way or another. If you connect to RB via IP (and IP address setup survives changes in L2 configuration of your RB), you might have to re-connect. If you connect to RB via MAC, then you'll have to connect to the new bridge MAC.
BR,
Metod
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Wed May 20, 2020 10:21 am

okay some updates i set up every way watchdog for all devices except watchdog from and to switches. For example SXT -> OruAPMaja and OruAPMaja -> SXT and so on for 10 second interval.
It has been live for 5 days now and i have had no reported problems (i have tested it multiple times by disconnecting random AP's and i have gotten instant emails about it).

Also setup a watchdog from every device (except switches) against google dns ( 8.8.8.8 ) and also i have had no reports of on anything being wrong from the watchdog.

Now i did notice this morning when i moved from one room to another the connection dropped on the ipad and i was not able to ping 192.168.88.1 (SXT - main router) from the ipad.
The isssue lasted for about 1.5minutes and then ping started to work again. Maybe a problem switching from one AP to another? I was moving in the house so it could have been 192.168.88.2 (OruAPMaja) or 192.168.88.6 (OruAPMajaKatusTV) APs.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Wed May 20, 2020 12:18 pm

Now i did notice this morning when i moved from one room to another the connection dropped on the ipad and i was not able to ping 192.168.88.1 (SXT - main router) from the ipad.
The isssue lasted for about 1.5minutes and then ping started to work again. Maybe a problem switching from one AP to another? I was moving in the house so it could have been 192.168.88.2 (OruAPMaja) or 192.168.88.6 (OruAPMajaKatusTV) APs.
This is technical forum, we not speculate... check logs of this event. Try repeat a problem
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 21, 2020 2:22 pm

Now i did notice this morning when i moved from one room to another the connection dropped on the ipad and i was not able to ping 192.168.88.1 (SXT - main router) from the ipad.
The isssue lasted for about 1.5minutes and then ping started to work again. Maybe a problem switching from one AP to another? I was moving in the house so it could have been 192.168.88.2 (OruAPMaja) or 192.168.88.6 (OruAPMajaKatusTV) APs.
This is technical forum, we not speculate... check logs of this event. Try repeat a problem
This is why it is posted in the beginner basics. I don't understand the hostility.
Logs are empty, i have not been able to reproduce it that's why i'm asking for any ideas to go on. What to try, where to look etc.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Thu May 21, 2020 2:34 pm

You have 3x wifi devices, in default configuration all connection to wireless are log into logs and when a wifi-user roam between them he can re-connect.
Maybe you not check the logs at wifi AP but in main SXT, he in logs have got empty logs because he not have wifi radio.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Fri May 22, 2020 8:03 am

Just saw connection drop checked the logs on the AP's only saw this:

MajaAP
07:50:22 wireless,info 24:1B:7A:94:74:AF@wlan1: connected, signal strength -84
07:50:54 wireless,info 24:1B:7A:94:74:AF@wlan1: disconnected, registered to other device in network
MajaAPKatusTV
07:50:23 wireless,info 24:1B:7A:94:74:AF@wlan1: disconnected, registered to other device in network
07:50:54 wireless,info 24:1B:7A:94:74:AF@wlan1: connected, signal strength -56

no logs on the SXT side on that time. Is there a specific topic i should log? Right now i log the default topics.
 
User avatar
SiB
Forum Veteran
Forum Veteran
Posts: 761
Joined: Sun Jan 06, 2013 11:19 pm
Location: Poland

Re: Random connection dropping vol2

Fri May 22, 2020 2:01 pm

As you notice, SXT who is your router see only DHCP actions, traffic by him etc. but he receive that traffic from any of AP.
Only AP can detect and show in logs why the roaming not work, maybe that because MIKROTIK NOT SUPPORT ANY ROAMING at WIFI and you will always be disconnected.
Sorry, I not expert of wifi, I not use wifi at MikroTik devices and that point some other person should give you support.

You can track that logs at AP and be sure if your dropping is from client roam between routers, if yes then try search posts about roaminng, I know they are post with tuning wifi settings to be faster.
MTCNA + MTCRE + MTCINE | ~600 users at ~150 RouterBoards in EMEA | Telegram: @SiB_PL
WinBox Tip: F6 works as ALT+TAB | Gliffy.com - free network schematic | prnt.sc - free ScreenShot software
I will be at MUMEUROPE Prague on ?? ?? 202?
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Fri May 22, 2020 3:05 pm

I have all the logs enabled even debug but the log is empty? Is there a guide how to turn it on?
I see logs disabled in the config files

/system logging
set 0 disabled=yes
set 1 disabled=yes
set 2 disabled=yes
set 3 disabled=yes

Should be

/system logging
set 0 action=memory disabled=no prefix="" topics=info
set 1 action=memory disabled=no prefix="" topics=error
set 2 action=memory disabled=no prefix="" topics=warning
set 3 action=echo disabled=no prefix="" topics=critical

A line with "wireless" as topic is an interesting addition here

add action=memory disabled=no prefix="" topics=wireless
Last edited by bpwl on Fri May 22, 2020 3:13 pm, edited 1 time in total.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Fri May 22, 2020 3:11 pm

Okay that mac address problem seemed to do the trick.. had to set the admin mac address on the bridge..

The admin mac address on the bridge is set to eth1 which is my "WAN" port that is connected to the switch.

Also got my logging working as well.
Actually your ether1 is a "LAN" port. The border between WAN and LAN is in the SXT LTE, everything below that is LAN.

So in:

/interface list member
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan1 list=LAN
add interface=ether1 list=WAN
add interface=wlan2 list=LAN

ether1 should be in the LAN list. But as ether1 is also attached to the bridge it is of no use.

The other interfaces are not important, as they are slave to bridge1. So bridge1 should be in the LAN list.
The list names WAN and LAN are used in the default config, they have no 'meaning' as such. They could be called "Cookie" and "Monster".

Look for the word LAN and WAN in your config files, to see if it matters:
E.G.:
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Fri May 22, 2020 3:27 pm

You selected very well channel 1,6 and 11 on your 3 wifi devices, as seen in the config.

"Every AC lite box runs 2.4GHz on different channels to make sure they don’t overlap."

Excellent, but what about the rest of the site survey? 2.4GHz tends to interfere well over 1 km in all directions.
The only way to now is measuring.
All tools needed are in your AP's. "Freq usage", "SCAN", and "Snooper".
If neighbors are using other channels than 1,6 or 11 you may have a quite bad wifi experience.

I also see that you have set up the 5GHz with the same SSID. Fine for operational status. But you do not want to be confused by devices selecting 5 GHz without expecting that.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Fri May 22, 2020 11:07 pm

You selected very well channel 1,6 and 11 on your 3 wifi devices, as seen in the config.

"Every AC lite box runs 2.4GHz on different channels to make sure they don’t overlap."

Excellent, but what about the rest of the site survey? 2.4GHz tends to interfere well over 1 km in all directions.
The only way to now is measuring.
All tools needed are in your AP's. "Freq usage", "SCAN", and "Snooper".
If neighbors are using other channels than 1,6 or 11 you may have a quite bad wifi experience.

I also see that you have set up the 5GHz with the same SSID. Fine for operational status. But you do not want to be confused by devices selecting 5 GHz without expecting that.
The site is in the middle of a forest with the closest neighbour at least 1.5km away. When i did a survey on 2.4 and 5Ghz frequencies i saw absolutely nothing but my own devices.
Wifi interface 2 (5Ghz) is disabled so only 5Ghz is in use.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Fri May 22, 2020 11:12 pm

Okay that mac address problem seemed to do the trick.. had to set the admin mac address on the bridge..

The admin mac address on the bridge is set to eth1 which is my "WAN" port that is connected to the switch.

Also got my logging working as well.
Actually your ether1 is a "LAN" port. The border between WAN and LAN is in the SXT LTE, everything below that is LAN.

So in:

/interface list member
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan1 list=LAN
add interface=ether1 list=WAN
add interface=wlan2 list=LAN

ether1 should be in the LAN list. But as ether1 is also attached to the bridge it is of no use.

The other interfaces are not important, as they are slave to bridge1. So bridge1 should be in the LAN list.
The list names WAN and LAN are used in the default config, they have no 'meaning' as such. They could be called "Cookie" and "Monster".

Look for the word LAN and WAN in your config files, to see if it matters:
E.G.:
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
So as i understand you correctly and feel free to correct me the correct setup should be

/interface list member
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan1 list=LAN
add interface=bridge1 list=LAN
add interface=wlan2 list=LAN

and ether1 should not be on any list?

and also a futher update my bridge on the APs atm has a seperate admin mac that is unique to the network, should this be changed back to being the same as ether1 mac address?
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Fri May 22, 2020 11:14 pm

I have all the logs enabled even debug but the log is empty? Is there a guide how to turn it on?
I see logs disabled in the config files

/system logging
set 0 disabled=yes
set 1 disabled=yes
set 2 disabled=yes
set 3 disabled=yes

Should be

/system logging
set 0 action=memory disabled=no prefix="" topics=info
set 1 action=memory disabled=no prefix="" topics=error
set 2 action=memory disabled=no prefix="" topics=warning
set 3 action=echo disabled=no prefix="" topics=critical

A line with "wireless" as topic is an interesting addition here

add action=memory disabled=no prefix="" topics=wireless
Right now i have enabled all the topics above. Will add the wireless topic as well.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Sat May 23, 2020 1:41 am



So as i understand you correctly and feel free to correct me the correct setup should be

/interface list member
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan1 list=LAN
add interface=bridge1 list=LAN
add interface=wlan2 list=LAN

and ether1 should not be on any list?

and also a futher update my bridge on the APs atm has a seperate admin mac that is unique to the network, should this be changed back to being the same as ether1 mac address?
Well as all those interfaces are a port on bridge "bridge1", they become slave interfaces. So the really important one is "bridge1".
No need to change back the MAC address of the bridge. Make sure your MAC addresses are unique in the network.
You have some similar devices, and it is tempting to copy/paste a configuration by doing backup/restore which will copy the MAC addresses as well.
Even EXPORT contains MAC addresses that might be imported.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Sat May 23, 2020 1:43 am



The site is in the middle of a forest with the closest neighbour at least 1.5km away. When i did a survey on 2.4 and 5Ghz frequencies i saw absolutely nothing but my own devices.
Wifi interface 2 (5Ghz) is disabled so only 5Ghz is in use.
That's a very clean area. Even the trees are very good RF filters. :)
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Sun May 24, 2020 7:53 am



So as i understand you correctly and feel free to correct me the correct setup should be

/interface list member
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
add interface=ether5 list=LAN
add interface=wlan1 list=LAN
add interface=bridge1 list=LAN
add interface=wlan2 list=LAN

and ether1 should not be on any list?

and also a futher update my bridge on the APs atm has a seperate admin mac that is unique to the network, should this be changed back to being the same as ether1 mac address?
Well as all those interfaces are a port on bridge "bridge1", they become slave interfaces. So the really important one is "bridge1".
No need to change back the MAC address of the bridge. Make sure your MAC addresses are unique in the network.
You have some similar devices, and it is tempting to copy/paste a configuration by doing backup/restore which will copy the MAC addresses as well.
Even EXPORT contains MAC addresses that might be imported.
So i added bridge1 to the LAN interface list. Quick question, if i start without default config and then just paste my configuration to the terminal. How are the interface lists even an issue if i don't use them anywhere in the configuration?
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Sun May 24, 2020 11:03 am


So i added bridge1 to the LAN interface list. Quick question, if i start without default config and then just paste my configuration to the terminal. How are the interface lists even an issue if i don't use them anywhere in the configuration?
:D I could turn the question around. If you don't use the interface list, then why do you make them? I prefer , if you make interface lists, that they are correct, unless you want to confuse yourselves or make the config hard to read for humans. And even more, those WAN/LAN interface lists are in the default configs, and are used there at several places. And so actually you are using them ....

/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

With bridge1 in the LAN list, now you can connect with WinBOX via the MAC address, if you are changing or have an inconsistent IP setup
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Sun May 24, 2020 11:25 am

Just saw connection drop checked the logs on the AP's only saw this:

MajaAP
07:50:22 wireless,info 24:1B:7A:94:74:AF@wlan1: connected, signal strength -84
07:50:54 wireless,info 24:1B:7A:94:74:AF@wlan1: disconnected, registered to other device in network
MajaAPKatusTV
07:50:23 wireless,info 24:1B:7A:94:74:AF@wlan1: disconnected, registered to other device in network
07:50:54 wireless,info 24:1B:7A:94:74:AF@wlan1: connected, signal strength -56

no logs on the SXT side on that time. Is there a specific topic i should log? Right now i log the default topics.
Logging is not 100% insync, I assume ...small diff in clocks or actually the disconnect is only detected after all the retries and a timeout.if the device didn't announce it is leaving. But "registered to other device in network " looks like it did announce.

MajaAPKatusTV 07:50:23 wireless,info 24:1B:7A:94:74:AF@wlan1: disconnected, registered to other device in network
MajaAP 07:50:22 wireless,info 24:1B:7A:94:74:AF@wlan1: connected, signal strength -84
MajaAP 07:50:54 wireless,info 24:1B:7A:94:74:AF@wlan1: disconnected, registered to other device in network
MajaAPKatusTV 07:50:54 wireless,info 24:1B:7A:94:74:AF@wlan1: connected, signal strength -56

Going from MajaAPKatusTV 07:50:23 to MajaAP and then 07:50:54 moving back to MajaAPKatusTV
Looks like excellent roaming.
For the data to flow to the correct AP the RB260GSP switch number 2 has to adapt as well ! It normally learns the new path for 24:1B:7A:94:74:AF from the first packet it receives over the new path..
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Thu May 28, 2020 3:13 pm

okay i removed the interface lists cause i do not use them and at this point i want to have a very minimal setup.

Also i was sitting for 2 hours and working and suddenly i had a disconnect and this was in the logs.

I was sitting on the couch and i did not move for hours. and RSSI is -56
saun_disconnect.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Thu May 28, 2020 5:26 pm

Disconnect due to "extensive data loss". Is disconnect because the ACK was not received in time.
What's the process?
Every unicast transmit needs an ACK respons. Mkt AP will retry "hw-retry" times (default=7) before it considers the transmit as failed. Upon failure it will lower the interface rate and start over. If it keeps failing 3 times (=3*7 transmits) at the lowest supported interface rate it will start the time-out counter (default 3 sec) and retry each retry interval (default=0.1sec). Without succes before the end of the timeout period it will disconnect and log "extensive data loss". The client will search for an AP and try to associate.

What stopped the transmission is not known. For a handheld device it could be your hand. Sudden interference from another device, reflections, ....

One can think of many tweaks to tune this. But every modification has a negative side as well. So be carefull.
 
john231
newbie
Topic Author
Posts: 49
Joined: Wed Aug 08, 2018 12:11 pm

Re: Random connection dropping vol2

Fri May 29, 2020 10:29 am

Thanks for the detailed explanation.

I had to rollback that interface list removal change. After that change the whole network went haywire.

On another note yesterday i worked with an ethernet cable attached from my laptop to OruAPSaun, everything worked like clockwork, no connectivity issues at all.

Behind wifi i cannot even make slack audio calls properly, not to mention even video calls, it's very laggy and keeps disconnecting.
 
User avatar
bpwl
Long time Member
Long time Member
Posts: 598
Joined: Mon Apr 08, 2019 1:16 am

Re: Random connection dropping vol2

Fri May 29, 2020 11:21 am

Thanks for the detailed explanation.

I had to rollback that interface list removal change. After that change the whole network went haywire.

On another note yesterday i worked with an ethernet cable attached from my laptop to OruAPSaun, everything worked like clockwork, no connectivity issues at all.

Behind wifi i cannot even make slack audio calls properly, not to mention even video calls, it's very laggy and keeps disconnecting.
Difficult to hint what the tuning should be without seeing the "registration" information (detailed view) and its fluctuation over time. That, together with "freq usage" and "snooper" scans, would give some clue on what is causing your poor wifi experience.

Remedies are like moving the AP away from wall and furniture. Check signal strength in both directions. Avoid interference by moving channel and even by lowering bandwidth.

Sending smaller aggregation packages can avoid large retransmits (but this also lowers the max data throughput) , by reducing the A-PSMDU from 8192 to 2048.
Improving the respons time on time and jitter critical communication, by setting the user priority and enabling WMM. (enabling WMM without setting priority doesn't help much)
viewtopic.php?f=7&t=161295#p795361
If you start using user priority don't forget to extend the use of A-PMDU for those other priorities except voice (7)

Who is online

Users browsing this forum: solar77 and 45 guests