Community discussions

MikroTik App
 
User avatar
natanielklug
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Mon Apr 02, 2007 6:09 pm
Location: Cascavel/PR/Brasil

PPPoE & External FreeRadius do not receive all logout ack

Fri May 25, 2007 9:54 pm

Hello all,

I have a small WISP and I am using PPPoE (Mikrotik) and a CentOS v4.4 FreeRadius server. All my PPPoE concentrators are in the same networks as my FreeRadius server (so the latency betwen than are less than 20ms).

The problem occur when a PPPoE client just turn off the computer and, when he returns it could not re-connect becouse it is, in FreeRadius server, still connected.

I can't find the problem... When I ask to disconnects a connection it works just fine but if I have a computer shut down without proper pppoe logout this happens. Can someone tell me some way to make it work?

Att,

Nataniel Klug .'.
 
neeraj_k
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Tue Jun 22, 2004 3:28 pm

Re: PPPoE & External FreeRadius do not receive all logout ack

Mon Jun 04, 2007 12:34 am

you can give keep alive timeout to your clients in radreply table.
nk
 
User avatar
natanielklug
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 95
Joined: Mon Apr 02, 2007 6:09 pm
Location: Cascavel/PR/Brasil

Re: PPPoE & External FreeRadius do not receive all logout ack

Mon Jun 04, 2007 2:19 pm

you can give keep alive timeout to your clients in radreply table.
nk
neeraj_k,

I user radius in text mode (I am just already migrating my system to a new MySQL based radius, but it will last a little bit more time). You mean that I can put a timeout condition in radius?

Into /etc/raddb/users I have a condition like this:
DEFAULT Auth-Type = System, Simultaneous-Use := 1
        Fall-Through = 1
#        Idle-Timeout = 300
This is commented becouse I have had a bit problem with this condition but I will uncomment and put the time for 120s (2 minutes). Is this ok?

Who is online

Users browsing this forum: matiss, txfz, yonesmit and 77 guests