Community discussions

MikroTik App
 
wispvt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Tue May 10, 2011 4:20 pm

OSPF MPLS Setup Convergence

Fri Jul 31, 2020 11:00 pm

I'm setting up a couple new CCR2004 with 3 redundant paths between them on the bench using a OSPF, BGP, MPLS, VPLS configuration. When I drop out the link carrying traffic, it takes 20 seconds for traffic to re-establish on the backup link. Is this normal convergence time, or possibly a setting I am missing. Everything seems to work otherwise.
 
wispvt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Tue May 10, 2011 4:20 pm

Re: OSPF MPLS Setup Convergence

Sun Aug 02, 2020 7:23 pm

It looks like its not an OSPF convergence issue as it is looking like with 2 seconds it is re-establing a link but that the VPLS is taking 20 seconds to begin passing traffic after getting notified of the new route.
 
morf
Member Candidate
Member Candidate
Posts: 181
Joined: Tue Jun 21, 2011 5:31 pm
Location: Saint-Petersburg

Re: OSPF MPLS Setup Convergence

Sun Aug 02, 2020 9:55 pm

Hello. Could you give an example of the configuration ?
 
jirinovak
just joined
Posts: 3
Joined: Fri Oct 22, 2010 1:45 pm

Re: OSPF MPLS Setup Convergence

Mon Aug 03, 2020 4:42 pm

Hello I have same configuration without bgp and convergence is very fast. I use ospf with bfd. Max 1 or 2 pings are lost. VPLS connected immediately.

Sent from my VOG-L29 using Tapatalk


 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1326
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: OSPF MPLS Setup Convergence

Tue Aug 04, 2020 7:01 pm

I'm setting up a couple new CCR2004 with 3 redundant paths between them on the bench using a OSPF, BGP, MPLS, VPLS configuration. When I drop out the link carrying traffic, it takes 20 seconds for traffic to re-establish on the backup link. Is this normal convergence time, or possibly a setting I am missing. Everything seems to work otherwise.
The first thing to realize is that MIkroTik does not support MPLS Fast Reroute so you won't get convergence at 50ms.

That said,

There are several timers to be aware of:

BGP and OSPF - Use BFD here instead of standard timers and tune it to ensure the timers aren't too aggressive.
LDP Interface hello and hold timers - Default at 5/15 seconds You can lower these but be careful not to be too aggressive or you'll end up with instability
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com
 
wispvt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Tue May 10, 2011 4:20 pm

Re: OSPF MPLS Setup Convergence

Tue Aug 04, 2020 9:49 pm

After all my testing, I have another setup up on some mikrotik switches that works great, it seems like its possibly a bug with the new ccr2004. I see the vpls shows the new route within 2 seconds on the web interface, but doesn't start passing traffic for another 20 on the vpls connection. My other setup traffic flows within 4 seconds of a route change. Has anyone actually tested VPLS on the CCR2004 hardware and how long to start passing traffic after enabling the VPLS interface?
 
morf
Member Candidate
Member Candidate
Posts: 181
Joined: Tue Jun 21, 2011 5:31 pm
Location: Saint-Petersburg

Re: OSPF MPLS Setup Convergence

Tue Aug 04, 2020 10:16 pm

After all my testing, I have another setup up on some mikrotik switches that works great, it seems like its possibly a bug with the new ccr2004. I see the vpls shows the new route within 2 seconds on the web interface, but doesn't start passing traffic for another 20 on the vpls connection. My other setup traffic flows within 4 seconds of a route change. Has anyone actually tested VPLS on the CCR2004 hardware and how long to start passing traffic after enabling the VPLS interface?
I'm sorry if this isn't relevant. Have you tried VPS "under load" on CCR 2004 ? If so, how much was pumped and what was the CPU load ?
 
wispvt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Tue May 10, 2011 4:20 pm

Re: OSPF MPLS Setup Convergence

Tue Aug 04, 2020 10:55 pm

I just did a quick config in some other ccr with tile processors and its the same. When ping across the bridge and VPLS interface it takes 22 seconds when a link drops or resumes. I've attched a copy of the 2 test routers configs. Changing the OSPF hello and dead timers on each interface has no effect.

Router1

# jan/02/1970 00:36:56 by RouterOS 6.45.9
# software id = TZ79-C80B
#
# model = CCR1016-12G
# serial number = 52A304F21297
/interface bridge
add name=bridge1
add name=loopback protocol-mode=none
/interface vpls
add advertised-l2mtu=1508 disabled=no l2mtu=1508 mac-address=\
02:B1:03:E7:5A:52 name=vpls1 remote-peer=10.255.0.5 vpls-id=1:1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default router-id=10.255.0.1
/routing ospf instance
set [ find default=yes ] router-id=10.255.0.1
/interface bridge port
add bridge=bridge1 interface=ether10
add bridge=bridge1 interface=ether11
add bridge=bridge1 interface=ether12
add bridge=bridge1 interface=vpls1
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge1 network=\
192.168.88.0
add address=10.1.1.1/30 interface=ether1 network=10.1.1.0
add address=10.1.2.1/30 interface=ether2 network=10.1.2.0
add address=10.1.3.1/30 interface=ether3 network=10.1.3.0
add address=10.255.0.1 interface=loopback network=10.255.0.1
/mpls interface
set [ find default=yes ] mpls-mtu=1530
/mpls ldp
set enabled=yes lsr-id=10.255.0.1 transport-address=10.255.0.1
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
/routing bgp peer
add name=peer1 remote-address=10.255.0.5 remote-as=65530 ttl=default
/routing ospf interface
add dead-interval=20s hello-interval=5s interface=ether1 network-type=\
point-to-point
add cost=20 dead-interval=20s hello-interval=5s interface=ether2 \
network-type=point-to-point
add cost=30 dead-interval=20s hello-interval=5s interface=ether3 \
network-type=point-to-point
/routing ospf network
add area=backbone network=10.1.1.0/30
add area=backbone network=10.1.2.0/30
add area=backbone network=10.1.3.0/30
add area=backbone network=10.255.0.0/24


Router 2

# jan/02/1970 00:33:48 by RouterOS 6.40.8
# software id = TDB1-UG5Y
#
# model = CCR1036-8G-2S+
# serial number = 91A909B35591
/interface bridge
add name=bridge1
add name=loopback protocol-mode=none
/interface vpls
add advertised-l2mtu=1508 disabled=no l2mtu=1508 mac-address=\
02:36:AE:8D:4E:60 name=vpls1 remote-peer=10.255.0.1 vpls-id=1:1
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/routing bgp instance
set default router-id=10.255.0.5
/routing ospf instance
set [ find default=yes ] router-id=10.255.0.5
/interface bridge port
add bridge=bridge1 interface=ether6
add bridge=bridge1 interface=ether7
add bridge=bridge1 interface=ether8
add bridge=bridge1 interface=vpls1
/ip address
add address=192.168.88.2/24 comment=defconf interface=bridge1 network=\
192.168.88.0
add address=10.1.1.2/30 interface=ether1 network=10.1.1.0
add address=10.1.2.2/30 interface=ether2 network=10.1.2.0
add address=10.1.3.2/30 interface=ether3 network=10.1.3.0
add address=10.255.0.5 interface=loopback network=10.255.0.5
/mpls interface
set [ find default=yes ] mpls-mtu=1530
/mpls ldp
set enabled=yes lsr-id=10.255.0.5 transport-address=10.255.0.5
/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3
/routing bgp peer
add name=peer1 remote-address=10.255.0.1 remote-as=65530 ttl=default
/routing ospf interface
add dead-interval=20s hello-interval=5s interface=ether1 network-type=\
point-to-point
add dead-interval=20s hello-interval=5s interface=ether2 network-type=\
point-to-point
add dead-interval=20s hello-interval=5s interface=ether3 network-type=\
point-to-point
/routing ospf network
add area=backbone network=10.1.1.0/30
add area=backbone network=10.1.2.0/30
add area=backbone network=10.1.3.0/30
add area=backbone network=10.255.0.0/24
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1326
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: OSPF MPLS Setup Convergence

Wed Aug 05, 2020 5:56 pm

Have you tried BFD?
Global - MikroTik Support & Consulting - English | Español | Serbian | Danish +1 855-645-7684
https://iparchitechs.com/ecosystem/mikr ... consulting mikrotiksupport@iparchitechs.com
 
wispvt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Tue May 10, 2011 4:20 pm

Re: OSPF MPLS Setup Convergence

Wed Aug 05, 2020 11:29 pm

I did enable use BFD on each OSPF interface and BGP peer. Is there anything else to do?

Its so wierd that when I unplug the cable the VPLS interface immediately shows the new next hop but traffic takes 20 seconds afterward to begin flowing again across the VPLS connection. At the top of the VPLS interface it says "not BGP signaled", is this correct?
 
wispvt
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 78
Joined: Tue May 10, 2011 4:20 pm

Re: OSPF MPLS Setup Convergence

Thu Aug 06, 2020 5:10 pm

I was able to solve the issue. I had to set the STP to none on the bridge that the VPLS was connected to. It was already set to none on the loopback, but apparently when the route changes it also trigger RSTP which drops the traffic. Once I disabled that it worked like a champ.

Who is online

Users browsing this forum: Funboy and 9 guests