Community discussions

MikroTik App
 
tashbee
just joined
Topic Author
Posts: 3
Joined: Wed Sep 28, 2016 8:59 pm

CapsMan using the first provisioning

Sat Aug 01, 2020 6:25 pm

Hi,
I am trying to use capsman to use a certain SSID etc depending which port the cap slave is plugged into.
I am defining the bridge port in the datapath and I have also tried defing it in the config too, but no matter what I do it always pulls the config from the first one in the provisioning.

So in the example below it uses the MainHousecfg, but if I change the order then it will use whatever i put at the top of the provisioning list.
I do hope someone can help me with this one.

Regards

Tom

/interface bridge
add name=CottageLeftBridge
add name=CottageRightBridge
add name="Main House Bridge"
/interface bridge port
add bridge="Main House Bridge" interface=ether3-House-WW
add bridge="Main House Bridge" interface=ether4-Office-WW
add bridge=CottageLeftBridge interface=ether1-CottageLeft
add bridge=CottageRightBridge interface=ether2-CottageRight


/caps-man datapath
add bridge=CottageLeftBridge client-to-client-forwarding=yes interface-list=none local-forwarding=no name=CottageLeftDatapath
add bridge="Main House Bridge" client-to-client-forwarding=yes interface-list=none local-forwarding=no name=MainHouseDatapath
add bridge=CottageRightBridge client-to-client-forwarding=yes interface-list=none local-forwarding=no name=CottageRightDatapath
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm name=MainHouseWPA2 passphrase=PASSWORD
add authentication-types=wpa2-psk encryption=aes-ccm name=CottageLeftWPA2 passphrase=PASSWORD
add authentication-types=wpa2-psk encryption=aes-ccm name=CottageRightWPA2 passphrase=PASSWORD
/caps-man configuration
add channel=channel1 country="united kingdom" datapath=MainHouseDatapath mode=ap name=MainHousecfg security=MainHouseWPA2 ssid=WIFI_OC_HW
add channel=channel1 country="united kingdom" datapath=CottageLeftDatapath mode=ap name=CottageLeftcfg security=CottageLeftWPA2 ssid=WIFI_OC_LC
add channel=channel6 country="united kingdom" datapath=CottageRightDatapath mode=ap name=CottageRightcfg security=CottageRightWPA2 ssid=WIFI_OC_RC
/caps-man manager
set ca-certificate=auto certificate=auto enabled=yes upgrade-policy=suggest-same-version
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=MainHousecfg
add action=create-dynamic-enabled master-configuration=CottageLeftcfg
add action=create-dynamic-enabled master-configuration=CottageRightcfg
 
mkx
Forum Guru
Forum Guru
Posts: 4634
Joined: Thu Mar 03, 2016 10:23 pm

Re: CapsMan using the first provisioning

Sat Aug 01, 2020 7:28 pm

If you want certain radio on a cAP get provisioned with certain setup, you have to add radio-mac=<wireless interface MAC> property in /capsman provisioning setup.

My experience is that provisioning rules are parsed in order of apperance (top to bottom) and first one matching gets used ... so be sure to move the radio-specific above the more general rules (i.e. those without radio-mac set).
BR,
Metod

Who is online

Users browsing this forum: Bing [Bot] and 13 guests