Community discussions

MikroTik App
 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1935
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Fault-finding OSPF error "Discarding packet"

Tue Jan 26, 2021 4:29 pm

Is there a way of fault finding with ospf error "Discarding packet: locally originated src address = XX.XXX.XX.XX"
this occurs every few mins?
 
TheLordOfTheShells
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Tue Oct 03, 2017 2:48 am

Re: Fault-finding OSPF error "Discarding packet"

Wed Apr 07, 2021 10:41 am

Hi guy
Have you solved the problem?
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 6218
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Fault-finding OSPF error "Discarding packet"

Wed Apr 07, 2021 11:16 am

If connection tracking is enabled, then add RAW firewall rules for OSPF traffic (in both prerouting and output chains) with action=notrack.

Other common causes:
* Multiple neighbors has the same router-id
* Actual layer2 loop in the network
* If switch is used in between, bad switch may acts as hub, sending multicast packet back to the port the packet was received from.
 
georgekaskader
just joined
Posts: 4
Joined: Wed Sep 11, 2019 5:26 pm

Re: Fault-finding OSPF error "Discarding packet"

Wed Apr 07, 2021 1:02 pm

Or you can add drop firewall rule on input protocol ospf with ip address which is logging discarding packets (It will be IP address of your Router which is reporting problem).
In my case it does work.
 
n21roadie
Forum Guru
Forum Guru
Topic Author
Posts: 1935
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: Fault-finding OSPF error "Discarding packet"

Wed Apr 07, 2021 10:07 pm

Not solved yet
Other common causes:
* Multiple neighbors has the same router-id - Checked OSPF Neighbours and no duplicates!
* Actual layer2 loop in the network - I have been adding extra L2 to the network and this maybe the cause ?
* If switch is used in between, bad switch may acts as hub, sending multicast packet back to the port the packet was received from. - The switch has been active for many months before this issue, so I don't think it's the problem!
et!

Who is online

Users browsing this forum: mikroathome and 15 guests