Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 696
Joined: Thu Dec 11, 2014 8:53 am

v6.47.9 [long-term] is released!

Tue Feb 09, 2021 10:23 am

RouterOS version 6.47.9 has been released in public "long-term" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.47.9 (2021-Feb-05 15:22):

Changes since 6.47.8:

*) bgp - fixed VPNV4 RD byte order;
*) branding - fixed LCD logo loading from new style branding package;
*) crs312 - fixed missing SwOS firmware on revision 2 devices;
*) crs3xx - correctly filter packets by L2MTU size;
*) crs3xx - improved system stability when receiving large frames for CRS317, CRS309, CRS312, CRS326-24S+2Q+ and CRS354 devices (introduced in v6.47.5);
*) defconf - fixed default configuration loading on RBcAP-2nD and RBwAP-2nD;
*) hotspot - fixed "idle-timeout" usage with RADIUS authentication;
*) hotspot - fixed special character parsing in "target" variable (CVE-2021-3014);
*) package - do not include multiple The Dude packages in HDD installer;
*) snmp - fixed "send-trap" functionality;
*) webfig - fixed new interface addition;
*) winbox - fixed enable/disable button presence for "Bridge/Hosts" menu;
*) winbox - renamed IP protocol 41 to "ipv6-encap";
*) winbox - show "System/Health" only on boards that have health monitoring;
*) winbox - use health values reported by gauges for "System/Health" menu;
*) wireless - renamed "macedonia" regulatory domain information to "north macedonia";
*) wireless - updated "indonesia5" regulatory domain information;

For a full changelog please visit https://mikrotik.com/download/changelogs

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this specific RouterOS release.
 
roe1974
Member Candidate
Member Candidate
Posts: 115
Joined: Mon Dec 31, 2018 2:14 pm

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 11:16 am

Is DoH now part from longterm 6.47.9 (i am coming from 6.47.7 stable) ?
br, Richard
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1446
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 11:37 am

roe1974 - DoH support was already added in v6.47.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2034
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 11:53 am

I cant see memory leak on DoH is in the fixed log!!!
Until its fixed, I do not recommend use DoH
 
roe1974
Member Candidate
Member Candidate
Posts: 115
Joined: Mon Dec 31, 2018 2:14 pm

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 11:58 am

what is this "memory leak" ?
I use DoH since 6.47 with more or less no problems.... (ltAp, R4011)
br, Richard
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2034
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 12:17 pm

Do a search in goolge (or at the forum) for "mikrotik doh memory leak"
Yes it work, but have a look of used memory every day and you see it goes up and down.

Eks
viewtopic.php?p=804384#p804384
 
davetickem
just joined
Posts: 1
Joined: Thu Jun 11, 2020 6:13 pm
Location: London

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 2:49 pm

Thank you for promoting 6.47 to long term - had a lot of success with this release stream - has given me an opportunity to easily rollback/forward between 6.48.x while work continues - safe and easy fallback to 6.47 :-)
 
erlinden
Forum Veteran
Forum Veteran
Posts: 755
Joined: Wed Jun 12, 2013 1:59 pm

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 4:03 pm

Got it installed on my RB4011/CRS112/2xcAP ac/wAP ac (coming from 6.478.1), will monitor. Upgrade went very smooth!
 
goodbye
just joined
Posts: 21
Joined: Sat Feb 25, 2017 12:48 am

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 6:40 pm

Thank you for promoting 6.47 to long term - had a lot of success with this release stream - has given me an opportunity to easily rollback/forward between 6.48.x while work continues - safe and easy fallback to 6.47 :-)
Totally concur!
Thank you!
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 114
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 7:59 pm

I updated to this version and enabled DoH. So far everything seems to work as expected. Will keep an eye on the memory usage.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 6573
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 8:54 pm

Awesome been waiting for the "real" stable release. Long term it is!!
 
BigDrive
just joined
Posts: 2
Joined: Tue Feb 09, 2021 9:49 pm

Re: v6.47.9 [long-term] is released!

Tue Feb 09, 2021 9:52 pm

Thank you for not breaking the IKE 2. On the stable version, dynamic connections with LTE, without real IP addresses disappear, I don't know how to solve.
 
za7
just joined
Posts: 8
Joined: Tue Mar 14, 2017 8:59 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 3:16 am

Bug (/system health) in WebFig and Winbox for the Mikrotik hEX RB750Gr3
Firmware v6.47.9
Bootloader v6.46.7
WebFig and Winbox
(/System health) from WebFig and Winbox does not display system voltage or system temperature
Terminal
(/system health print) does display system voltage and system temperature
Does the bootloader need to be updated?
 
goodbye
just joined
Posts: 21
Joined: Sat Feb 25, 2017 12:48 am

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 3:26 am

Bug (/system health) in WebFig and Winbox for the Mikrotik hEX RB750Gr3
Firmware v6.47.9
Bootloader v6.46.7
WebFig and Winbox
(/System health) from WebFig and Winbox does not display system voltage or system temperature
Terminal
(/system health print) does display system voltage and system temperature
Does the bootloader need to be updated?
Try rebooting to find out?
Your bootloader wasn't even on latest for the 6.46 minor release; 6.46.8 was previous.

It's hard to call this a bug for sure when your bootloader is a minor-release behind.
 
za7
just joined
Posts: 8
Joined: Tue Mar 14, 2017 8:59 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 3:45 am

Bug (/system health) in WebFig and Winbox for the Mikrotik hEX RB750Gr3
Firmware v6.47.9
Bootloader v6.46.7
WebFig and Winbox
(/System health) from WebFig and Winbox does not display system voltage or system temperature
Terminal
(/system health print) does display system voltage and system temperature
Does the bootloader need to be updated?
Try rebooting to find out?
Your bootloader wasn't even on latest for the 6.46 minor release; 6.46.8 was previous.

It's hard to call this a bug for sure when your bootloader is a minor-release behind.
Upgraded firmware to v6.47.9 still no display from WebFig (/system health)
 
Alexandepz
just joined
Posts: 2
Joined: Fri Dec 13, 2019 6:07 am

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 3:46 am

It's been 84 years...
Have been waiting for long-term 6.47.X to release, so I could upgrade to it directly from stable 6.46.5 on RB760iGS and cAP AC, given how poor a lot of recent stable 6.47.X (and .48, oh man, oh god) releases were received. But, generally speaking, is it a good idea (meaning "is it safe?") to do both things at the same time - to upgrade to next major version (from .46 to .47) and to hop to different release tree? Well, there are backups of course, so it's just my curiousity itching.
 
goodbye
just joined
Posts: 21
Joined: Sat Feb 25, 2017 12:48 am

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 5:05 am

It's been 84 years...
Have been waiting for long-term 6.47.X to release, so I could upgrade to it directly from stable 6.46.5 on RB760iGS and cAP AC, given how poor a lot of recent stable 6.47.X (and .48, oh man, oh god) releases were received. But, generally speaking, is it a good idea (meaning "is it safe?") to do both things at the same time - to upgrade to next major version (from .46 to .47) and to hop to different release tree? Well, there are backups of course, so it's just my curiousity itching.
I've been in a not-too-dissimilar boat.

I've been waiting for a good time to hop to long-term as well. I held off on the 6.48 jump really hoping 6.47 would get promoted to long-term. I'm glad i did. Just upgraded my whole infrastructure, some of it was on 6.47.8, the rest (wifi/caps) was all 6.46.8.

Now everything is happy all together on a single slow-moving and hopefully well-understood train. :-)
 
Saver
Posts: 0
Joined: Wed Feb 10, 2021 9:26 am

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 9:34 am

Hi!
After updating to FW long-term 6.47.9 strange thing happened. If choose frequency settings in the 5GHz mode and the country russia4, the 5160MHz channel appears. It should not be like that and was not on the FW long-term 6.46.8. When the automatic channel selection mode is on, the device selects 5160 MHz channel, and client devices stop seeing the wireless network.
Russia3 is normal.
Tested for hAP ac lite and hAP ac ^ 2.

SUPPORT TICKET SUP-41402
 
ste
Forum Guru
Forum Guru
Posts: 1896
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 10:02 am

It's been 84 years...
Have been waiting for long-term 6.47.X to release, so I could upgrade to it directly from stable 6.46.5 on RB760iGS and cAP AC, given how poor a lot of recent stable 6.47.X (and .48, oh man, oh god) releases were received. But, generally speaking, is it a good idea (meaning "is it safe?") to do both things at the same time - to upgrade to next major version (from .46 to .47) and to hop to different release tree? Well, there are backups of course, so it's just my curiousity itching.
I've been in a not-too-dissimilar boat.

I've been waiting for a good time to hop to long-term as well. I held off on the 6.48 jump really hoping 6.47 would get promoted to long-term. I'm glad i did. Just upgraded my whole infrastructure, some of it was on 6.47.8, the rest (wifi/caps) was all 6.46.8.

Now everything is happy all together on a single slow-moving and hopefully well-understood train. :-)
We live good with a very lazy update strategy. So we will install 6.46.8 for some months from now. As a long time MT user ...
 
Znevna
Member Candidate
Member Candidate
Posts: 239
Joined: Mon Sep 23, 2019 1:04 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 11:16 am

I was hoping for at least an 6.46.9 version if not more, with more fixes than with added features.. Oh well.
 
aries
just joined
Posts: 12
Joined: Mon Dec 27, 2010 3:50 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 2:17 pm

Hello,
Switch have broken sfp module after resetting to default switch CRS309-1G-8S+ with 6.47.9
We had similar situations with CRS326-24S+2Q+, after firmware upgrade UBNT 10g modules stopped working.

How to deal with such situation in future? It is not possible safely to upgrade o reset the switch. Has anyone similar experience?

Thanks, Albertas
 
avn
just joined
Posts: 11
Joined: Tue Apr 04, 2017 6:34 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 4:14 pm

8 out of ~100 hap lite were bricked during upgrade from 6.46.8 to 6.47.9 and required netinstall.
In some cases (seems totally random) Avaya IP phones can't get IP address from Mikrotik with ROS 6.47.9, ROS 6.46.8 is working fine.
Will revert to 6.46.8 everywhere.
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1151
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 5:12 pm

Upgraded from 6.44 and 6.46 and went largely without incident. Mix of RB4011, RB3011, RB2011, hAP ac lite, hEX PoE, CRS112-8P, CRS326-24G, hAP ac, hAP ac², wAP ac, and cAP ac. This feels like a good update. Time will tell. I miss antenna gain on the AP's but at least can get to it via CLI.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 5:20 pm

I upgraded a hAP mini from 6.47.8 and got the same WiFi problem as with 6.48, fixed by downgrading.
The issue is that on a WiFi connection with 90% CCQ there are interruptions in the traffic every couple of seconds.
As if the retransmit timer is too long (like 200-500ms).
I wonder why this happens on upgrade (nothing is mentioned in the release notes except changes for other countries) and also I do not quite understand why the CCQ is not closer to 100%, the hAP mini is only a meter away from a Chromebook.
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1151
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 5:27 pm

I upgraded a hAP mini from 6.47.8 and got the same WiFi problem as with 6.48, fixed by downgrading.

After upgrading RouterOS and RouterBOARD, then doing a reset, then adding back your config via console, do you still have the same issues?
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 5:41 pm

After upgrading RouterOS and RouterBOARD, then doing a reset, then adding back your config via console, do you still have the same issues?
No idea, and I don't think it should be required to do that on upgrade.
The firmware is on 6.47.7 both before and after test.
 
thomascavinato
Posts: 0
Joined: Sat Apr 21, 2018 11:50 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 10, 2021 8:22 pm

Hi, today unfortunately we tried to update 3 Haplite and they all crashed after updating to version 6.47.9 from 6.40.8. They no longer respond to the winbox and the connected ethernet ports go up and down continuously.
If instead we switch to version 6.48.1 everything is ok. Has this happened to anyone? this is very concerning.
 
User avatar
onovy
just joined
Posts: 1
Joined: Tue Nov 26, 2019 12:43 am

Re: v6.47.9 [long-term] is released!

Thu Feb 11, 2021 1:24 pm

RB2011 upgraded, works fine so far.
 
FezzFest
newbie
Posts: 48
Joined: Wed Jun 03, 2015 12:03 am

Re: v6.47.9 [long-term] is released!

Thu Feb 11, 2021 2:35 pm

Lost a hAP lite on upgrade from 6.46.8 to 6.47.9 as well. Everything else (2011/3011/OmniTik/RB951) seems to have survived the upgrade just fine.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Thu Feb 11, 2021 2:44 pm

hAP mini (is about the same thing as hAP lite I think) did upgrade from 6.47.8 to 6.47.9 here OK but I had already reduced my install to 6 packages instead of combined package.
(system/advanced-tools/dhcp/ppp/security/wireless)
This gives it some more breathing space when updating, very important for these devices with only 32MB RAM.
 
peterda
just joined
Posts: 6
Joined: Mon Jan 18, 2021 11:51 am

Re: v6.47.9 [long-term] is released!

Thu Feb 11, 2021 5:24 pm

I did not find where to report bugs so...

routerboard: yes
model: 450
serial-number: DELETED
firmware-type: ar7100
factory-firmware: 2.20
current-firmware: 6.47.9
upgrade-firmware: 6.47.9

Issue:
Changing the name of an interface does not update view in all places when using WebFig.

Can reproduce:
Yes

Workaround:
Log out of WebFig and in again.

Not affected:
Terminal, is showing the correct information.
Router, change is commit

Browser used:
Name Firefox
Version 85.0.2
Build ID 20210208133944
Distribution ID
Update Folder
/Users/DELETED/Library/Caches/Mozilla/updates/Applications/Firefox
Update History
Update Channel release
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:85.0) Gecko/20100101 Firefox/85.0
OS Darwin 20.3.0 Darwin Kernel Version 20.3.0: Thu Jan 21 00:07:06 PST 2021; root:xnu-7195.81.3~1/RELEASE_X86_64
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2034
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.47.9 [long-term] is released!

Thu Feb 11, 2021 9:48 pm

I did not find where to report bugs so...
Correct is to send this to support@mikrotik.com
This forum is mostly a user forum.
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 114
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.47.9 [long-term] is released!

Fri Feb 12, 2021 3:09 pm

With 6.47.9, there is currently no indication of memory leaking when DoH is used.
/ip dns
set allow-remote-requests=yes use-doh-server=https://dns.adguard.com/dns-query verify-doh-cert=yes
/ip dns static
add address=94.140.14.14 name=dns.adguard.com
add address=94.140.15.15 name=dns.adguard.com
/certificate settings
set crl-download=yes crl-store=system crl-use=yes
/certificate> pr det
Flags: K - private-key, L - crl, C - smart-card-key, A - authority, I - issued, R - revoked, E - expired, T - trusted
 0       T name="DigiCert Global Root CA" issuer=C=US,O=DigiCert Inc,OU=www.digicert.com,CN=DigiCert Global Root CA
           digest-algorithm=sha1 key-type=rsa country="US" organization="DigiCert Inc" unit="www.digicert.com"
           common-name="DigiCert Global Root CA" key-size=2048 subject-alt-name="" days-valid=9131 trusted=yes
           key-usage=digital-signature,key-cert-sign,crl-sign serial-number="083BE056904246B1A1756AC95991C74A"
           fingerprint="4348a0e9444c78cb265e058d5e8944b4d84f9662bd26db257f8934a443c70161"
           akid=03de503556d14cbb66f0a3e21b1bc397b23dd155 skid=03de503556d14cbb66f0a3e21b1bc397b23dd155
           invalid-before=nov/10/2006 01:00:00 invalid-after=nov/10/2031 01:00:00 expires-after=560w2d11h1m35s

 1  L    T name="DigiCertTLSHybridECCSHA3842020CA1 (1).crt_0"
           issuer=C=US,O=DigiCert Inc,OU=www.digicert.com,CN=DigiCert Global Root CA digest-algorithm=sha384 key-type=ec
           country="US" organization="DigiCert Inc" common-name="DigiCert TLS Hybrid ECC SHA384 2020 CA1" key-size=secp384r1
           subject-alt-name="" days-valid=3651 trusted=yes
           key-usage=digital-signature,key-cert-sign,crl-sign,tls-server,tls-client
           serial-number="0A275FE704D6EECB23D5CD5B4B1A4E04"
           fingerprint="d79a2d5e03295c0e9feae36d021ebd5209700ab1a9e817a43f30fa3c66f78d21"
           akid=03de503556d14cbb66f0a3e21b1bc397b23dd155 skid=0abc0829178ca5396d7a0ece33c72eb3edfbc37a
           invalid-before=sep/23/2020 01:00:00 invalid-after=sep/23/2030 00:59:59 expires-after=501w2d11h1m34s
/certificate crl> pr det
Flags: E - expired, D - dynamic, I - invalid
 0  D  cert=DigiCertTLSHybridECCSHA3842020CA1 (1).crt_0 url="http://crl3.digicert.com/DigiCertGlobalRootCA.crl" num=557 revoked=3
       next-update=mar/05/2021 02:29:49 last-update=feb/12/2021 05:54:06 fingerprint="65e210870319eb7c4a8622071fe4b4fa3b2995c9"
       signature="e182e50b0462f80521116059a3fe28df8bee8c96f840614347defb57bd1023da7a45c2bab89cf16012a6edb2161aded65ab512f2ca788fa20
          444467b0cd961ba0c44155149ee196bd04f721ad8037c20acd6a38047f11c7f401a967114c646ef3ea16f25f8856c490c525a5b2ab6f3b987b1e44a94
          94a76e563a5ce0a116a4dce417b578a9be2d6945ec55d1d70c5a087125a9ac301affbf90c0c5c490ba256a6b0702aaa451f9cae56b9a741fc13ca08dc
          1416743f3ebc7c764743f88995e4e79cc72e89e0218394c64e7e77499905a7c2d2dc1a3bd8e997b26726c9ecda42f73ccf1047e80917aa2ae4f44e5de
          9dcc51559dac7b3b49010102897acce6fd5f"

 1  D  cert=DigiCertTLSHybridECCSHA3842020CA1 (1).crt_0 url="http://crl4.digicert.com/DigiCertGlobalRootCA.crl" num=557 revoked=3
       next-update=mar/05/2021 02:29:49 last-update=feb/12/2021 04:54:05 fingerprint="65e210870319eb7c4a8622071fe4b4fa3b2995c9"
       signature="e182e50b0462f80521116059a3fe28df8bee8c96f840614347defb57bd1023da7a45c2bab89cf16012a6edb2161aded65ab512f2ca788fa20
          444467b0cd961ba0c44155149ee196bd04f721ad8037c20acd6a38047f11c7f401a967114c646ef3ea16f25f8856c490c525a5b2ab6f3b987b1e44a94
          94a76e563a5ce0a116a4dce417b578a9be2d6945ec55d1d70c5a087125a9ac301affbf90c0c5c490ba256a6b0702aaa451f9cae56b9a741fc13ca08dc
          1416743f3ebc7c764743f88995e4e79cc72e89e0218394c64e7e77499905a7c2d2dc1a3bd8e997b26726c9ecda42f73ccf1047e80917aa2ae4f44e5de
          9dcc51559dac7b3b49010102897acce6fd5f"    
You do not have the required permissions to view the files attached to this post.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 6573
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: v6.47.9 [long-term] is released!

Fri Feb 12, 2021 4:26 pm

Will upgrade my CCR but leave my capacs where they are for now. To many indications of wifi issues.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2034
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.47.9 [long-term] is released!

Fri Feb 12, 2021 11:49 pm

With 6.47.9, there is currently no indication of memory leaking when DoH is used.
That is a plus, but strange it was not in the change log.
 
usern
just joined
Posts: 2
Joined: Sat May 30, 2020 2:37 am

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 12:40 pm

With 6.47.9, there is currently no indication of memory leaking when DoH is used.
That is a plus, but strange it was not in the change log.
Didn't memory issue appear in 6.48 branch, not 6.47?
I upgraded all my devices to 6.47.9 with no immediate issues.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 12:50 pm

No, the DNS server change to enable DoH caused problems from the beginning. In my case the solution is simple: do not use DoH.
 
deadmaus911
just joined
Posts: 1
Joined: Wed Apr 25, 2018 3:47 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 1:50 pm

Memory leak on my hap ac^2 after upgrade
You do not have the required permissions to view the files attached to this post.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2034
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 5:19 pm

Didn't memory issue appear in 6.48 branch, not 6.47?
I upgraded all my devices to 6.47.9 with no immediate issues.
Memory leakage may have come with the fist version of 6.47 (that wast the first with DoH support), but since not everyone measure memory level its not easy say when it was there first (at least som 6.47.x version and above. It does not break the router, but usage of memory slowly increases over days, before it drop down and goes up again. Saw-toot wave.
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 114
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 6:07 pm

strange, I still see no increase in memory usage. The screenshot I posted is from a 750G r3 (hEX). Does this only occur on arm devices?
We use this device at work to provide internet access to guests, not too much traffic, around 100GB/month.
 
deadmaus911
just joined
Posts: 1
Joined: Wed Apr 25, 2018 3:47 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 7:36 pm

strange, I still see no increase in memory usage. The screenshot I posted is from a 750G r3 (hEX). Does this only occur on arm devices?
We use this device at work to provide internet access to guests, not too much traffic, around 100GB/month.
Not only ARMs devices, at RB951G-2HnD the same situation
You do not have the required permissions to view the files attached to this post.
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 114
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 8:08 pm

hap ac2, exact same dns configuration. There must be something different on those devices showing this problem. Maybe it's a service or setting interacting with the dns, which is disabled on my devices.. just a guess. (Graph)
 
deadmaus911
just joined
Posts: 1
Joined: Wed Apr 25, 2018 3:47 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 13, 2021 8:15 pm

hap ac2, exact same dns configuration. There must be something different on those devices showing this problem. Maybe it's a service or setting interacting with the dns, which is disabled on my devices.. just a guess.
Maybe, in my cases usage of CRL is disabled. I use a Cloudflare DoH servers
 
Chiverel
newbie
Posts: 43
Joined: Fri Jan 12, 2018 7:28 pm

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 10:26 am

I see issues with DoH 1.1.1.1 and certificate validation (clickable image in high res), rb4011
ImageImage
 
Mikhalich
just joined
Posts: 16
Joined: Mon Feb 05, 2018 10:16 am

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 12:28 pm

hEX PoE with 48V Power Supply still have bug with attached cameras powered by poe. It's powered on only then PoE out is "Forced On".
 
mkx
Forum Guru
Forum Guru
Posts: 5680
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 12:39 pm

If cable connecting hEX PoE and camera is long, then detecton/negotiation can fail due to excessive cable resistence. In such case forcing PoE out can help but it also depends on voltage drop over cable, 802.3 af/at requires at least 37V at PD (camera).
 
Mikhalich
just joined
Posts: 16
Joined: Mon Feb 05, 2018 10:16 am

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 12:50 pm

If cable connecting hEX PoE and camera is long, then detecton/negotiation can fail due to excessive cable resistence. In such case forcing PoE out can help but it also depends on voltage drop over cable, 802.3 af/at requires at least 37V at PD (camera).
Unfortunetly not long. About 10 meters.
Netmetal ac can not be turned on from this hEX at 3-4 meters of cable.
System - Health of hEX PoE shows 47.9 Volts.
 
Znevna
Member Candidate
Member Candidate
Posts: 239
Joined: Mon Sep 23, 2019 1:04 pm

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 1:41 pm

The PoE issue was introduced in 6.46.8, as the comments from that release prove it.
Going back to 6.46.7 fixes it. Someone complained in IRC too about that.
One of the reasons I was hoping for a 6.46.9 bugfix release.
 
Mikhalich
just joined
Posts: 16
Joined: Mon Feb 05, 2018 10:16 am

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 3:56 pm

The PoE issue was introduced in 6.46.8, as the comments from that release prove it.
Going back to 6.46.7 fixes it. Someone complained in IRC too about that.
One of the reasons I was hoping for a 6.46.9 bugfix release.
Just tried to install 6.46.7. Same problem... PoE out status - waiting for load.
Maybe it is hardware bug. Mikrotik does not admit this and did not say a word about this problem.
 
User avatar
pcunite
Forum Guru
Forum Guru
Posts: 1151
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 4:42 pm

The PoE issue was introduced in 6.46.8, as the comments from that release prove it.

Using a hEX PoE to power two Dahua SD1A203T-GN. PoE set to auto on. Firmware v6.47.9 without issue. I think these units are 2 or 3 years old. Factory firmware was 6.42.7.
 
Mikhalich
just joined
Posts: 16
Joined: Mon Feb 05, 2018 10:16 am

Re: v6.47.9 [long-term] is released!

Mon Feb 15, 2021 5:23 pm

The PoE issue was introduced in 6.46.8, as the comments from that release prove it.

Using a hEX PoE to power two Dahua SD1A203T-GN. PoE set to auto on. Firmware v6.47.9 without issue. I think these units are 2 or 3 years old. Factory firmware was 6.42.7.
I also have only one of many hEX PoE routers which works without problems with the same cameras (Hikvision) in "auto on" PoE mode with ROS 6.47.8. It doesn't depend on cameras or power supply. I tryed to change it. This gives reason to think this is hardware bug.
 
xylograde
newbie
Posts: 25
Joined: Mon Feb 08, 2021 8:28 pm

Re: v6.47.9 [long-term] is released!

Tue Feb 16, 2021 10:03 pm

Thank you for not breaking the IKE 2. On the stable version, dynamic connections with LTE, without real IP addresses disappear, I don't know how to solve.
Interesting... I have big issues with IKEv2 behind NAT on both sides with actual 6.48.1, but still no news from MT. Was you able to run IKEv2 OK with this latest long term? Do you have your responder (server) behind nat on LTE connection? (see my other post viewtopic.php?f=2&p=844118#p844118)
 
wiyat
newbie
Posts: 45
Joined: Tue Jan 12, 2010 9:38 pm
Contact:

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 2:06 pm

Hola/Hello from Spain
Bugs 6.47.9 Just-work on 6.46.8
Error: Scripting not global or local variable work
Mikrotik Ticket: SUP-42106

My script: Update DNS and find dns-name where I add ip route rule add


:foreach i in=[/ip dns cache all find where (name~"dns-name") && (type="A") && (data!="240.0.0.1")] do={
:local tmpAddress [/ip dns cache get $i address];
delay delay-time=3000ms

:if ( [/ip firewall address-list find where address=$tmpAddress] = "") do={
:local cacheName [/ip dns cache get $i name] ;
:log info ("added entry: $cacheName $tmpAddress");

/ip firewall address-list remove [/ip firewall address-list find list="list_name"];
/ip route rule remove [find table=INTERNET];
/ip route rule add dst-address=1.1.1.1 action=lookup table=INTERNET;
/ip route rule add dst-address=$tmpAddress action=lookup table=INTERNET;
/ip firewall address-list add address=$tmpAddress list=list_name; } }


Best regard,

wiyat
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 766
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 2:22 pm

For me scripting works just fine. Can you be more precise what you think does not (or no longer) work?
 
wiyat
newbie
Posts: 45
Joined: Tue Jan 12, 2010 9:38 pm
Contact:

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 2:41 pm

Hi eworm

can you test my script into your equipment Mikrotik 6.47.9 but remember to replace:
replace dns-name for mikrotik.com
replace list_name for mikrotik1

What do you will be expect after execute my script:
A. /ip route rule print -----> you will be see add two new rule with table=INTERNET
B. /ip firewall address-list -----> you will be see one list=list_name


:foreach i in=[/ip dns cache all find where (name~"dns-name") && (type="A") && (data!="240.0.0.1")] do={
:local tmpAddress [/ip dns cache get $i address];
delay delay-time=3000ms

:if ( [/ip firewall address-list find where address=$tmpAddress] = "") do={
:local cacheName [/ip dns cache get $i name] ;
:log info ("added entry: $cacheName $tmpAddress");

/ip firewall address-list remove [/ip firewall address-list find list="list_name"];
/ip route rule remove [find table=INTERNET];
/ip route rule add dst-address=1.1.1.1 action=lookup table=INTERNET;
/ip route rule add dst-address=$tmpAddress action=lookup table=INTERNET;
/ip firewall address-list add address=$tmpAddress list=list_name; } }

When do you finish please let me know if it work for you,

Gracias / Thank you
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 766
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 3:07 pm

The problem is that /ip dns cache does no longer have an attribute "address", it was renamed to "data".
So replace that in the line where tmpAddress is assigned.
 
wiyat
newbie
Posts: 45
Joined: Tue Jan 12, 2010 9:38 pm
Contact:

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 3:36 pm

Hi [hola] eworm

Work ok. just replace address by data

:foreach i in=[/ip dns cache all find where (name~"dns-name") && (type="A") && (data!="240.0.0.1")] do={
:local tmpAddress [/ip dns cache get $i address];
delay delay-time=3000ms


Question:
1. How do you know that this attribute changes on this version?
2. where is the documentation for read it about the changes that affect to the attribute on the new RouterOS version?

Thank you,

Best regards
 
Ixander
just joined
Posts: 9
Joined: Sun Jun 28, 2020 7:33 pm

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 4:53 pm

On the version 6.47.9 command repartition (e.g. "/partitions repartition partitions =2") causes the router's cyclic reboot (about every 10 seconds). On versions 6.47.x situation the same.
On the version 6.46.X and 6.48.X this command works correctly

Ticket SUP-32199 29/Oct/20 6:33 PM

How could a company release an LTS version with such a bug? And there was a ticket from 29 / Oct / 20
 
User avatar
eworm
Forum Veteran
Forum Veteran
Posts: 766
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.47.9 [long-term] is released!

Wed Feb 17, 2021 6:01 pm

1. How do you know that this attribute changes on this version?
2. where is the documentation for read it about the changes that affect to the attribute on the new RouterOS version?
Just get the column name from CLI, Winbox, Webfig, ...

I do not think that the changes are documented. Whenever something breaks you have to investigate and change the script.
 
sequephonic
just joined
Posts: 4
Joined: Wed Sep 04, 2019 7:03 am
Location: Krasnoyarsk

Re: v6.47.9 [long-term] is released!

Thu Feb 18, 2021 8:11 am

Hi, today unfortunately we tried to update 3 Haplite and they all crashed after updating to version 6.47.9 from 6.40.8. They no longer respond to the winbox and the connected ethernet ports go up and down continuously.
If instead we switch to version 6.48.1 everything is ok. Has this happened to anyone? this is very concerning.
I also have a similar problem with 2 hap light and 1 hap classic.
The problem is one to one as you describe.
 
bonaventure
Posts: 0
Joined: Sat Feb 20, 2021 12:15 am

Re: v6.47.9 [long-term] is released!

Fri Feb 26, 2021 8:26 am

As I downgraded from 6.48.1, and came from some 6.47.x (non-LT), I noticed that immediately:
With 6.47.9 LT, despite SIP with Gigaset N510 works, DNS is slow until a host is in the cache, then it's quick as expected.
It seems that 6.47.9, when getting requests, WAITS for a TIMEOUT period before it forwards the request to the next DNS in chain.

Please fix that ...

Thx.
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Fri Feb 26, 2021 10:55 am

The problem must be in your network, maybe one or more of your configured DNS resolvers does not respond.
 
starlingus
just joined
Posts: 5
Joined: Thu May 21, 2020 1:52 pm

Re: v6.47.9 [long-term] is released!

Fri Feb 26, 2021 11:20 pm

Hi, today unfortunately we tried to update 3 Haplite and they all crashed after updating to version 6.47.9 from 6.40.8. They no longer respond to the winbox and the connected ethernet ports go up and down continuously.
If instead we switch to version 6.48.1 everything is ok. Has this happened to anyone? this is very concerning.
I also have a similar problem with 2 hap light and 1 hap classic.
The problem is one to one as you describe.

Hi, is there a confirmation from MikroTik of this issue and if so, is there any plan for fixing long-term stream? I have planned remote upgrade of hap lite devices and want to make sure that it is safe. Thank You
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 27, 2021 12:19 pm

Hi, is there a confirmation from MikroTik of this issue and if so, is there any plan for fixing long-term stream? I have planned remote upgrade of hap lite devices and want to make sure that it is safe. Thank You
I would recommend to do a manual upgrade in any case. You can control what version gets installed rather than the actual version offered by MikroTik, which could change halfway through your update project.

You can write some script that will upload the desired version to the devices and issues a reboot command, or to make the devices download it and reboot.
I would advise to check if you can use a subset of the available packages (e.g. you do not need routing or mpls or ipv6 etc) and install only those packages that you require instead of the whole "combined" package.
That will save some valuable space on these tiny devices.
 
starlingus
just joined
Posts: 5
Joined: Thu May 21, 2020 1:52 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 27, 2021 5:17 pm

Hi, is there a confirmation from MikroTik of this issue and if so, is there any plan for fixing long-term stream? I have planned remote upgrade of hap lite devices and want to make sure that it is safe. Thank You
I would recommend to do a manual upgrade in any case. You can control what version gets installed rather than the actual version offered by MikroTik, which could change halfway through your update project.

You can write some script that will upload the desired version to the devices and issues a reboot command, or to make the devices download it and reboot.
I would advise to check if you can use a subset of the available packages (e.g. you do not need routing or mpls or ipv6 etc) and install only those packages that you require instead of the whole "combined" package.
That will save some valuable space on these tiny devices.

I would love to stay on long-term branch as I have good experience with stability and preformace of those bits so far. What I am asking for is a confirmed safe way how to upgrade hap lite to from 6.46.8 to 6.47.9. As I wrote this upgrade is done remotely and I do not have possibility to travel to fix those devices physically :(. Thank You
 
pe1chl
Forum Guru
Forum Guru
Posts: 7364
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.47.9 [long-term] is released!

Sat Feb 27, 2021 5:26 pm

- download all_packages.zip file for the version you want to install
- unpack the file and select only the packages you need
- put these files on a location accessible to the routers
- write a small script that fetches the files (/tool fetch) and reboots the router
- upload that script to every router and execute it

when you have remote access to the routers, there is no need to visit them.
 
JJT211
newbie
Posts: 36
Joined: Sun Apr 28, 2019 9:01 pm

Re: v6.47.9 [long-term] is released!

Thu Mar 11, 2021 5:32 pm

8 out of ~100 hap lite were bricked during upgrade from 6.46.8 to 6.47.9 and required netinstall.
In some cases (seems totally random) Avaya IP phones can't get IP address from Mikrotik with ROS 6.47.9, ROS 6.46.8 is working fine.
Will revert to 6.46.8 everywhere.
Same exact thing happened to me with hap lite. It was 2 of 3 bricked and I stopped.
 
oe5nip
just joined
Posts: 5
Joined: Fri Dec 27, 2019 9:00 pm
Location: Kronstorf

Re: v6.47.9 [long-term] is released!

Tue Mar 16, 2021 7:24 am

No problems so far, Updated my Mikrotikerl.... all fine :-)
Mikrotik HEX S (RB760iGS), CRS109-8G-1S-2HnD-IN, CRS-112-8G-4S, hAP RBD52G-5HacD2HnD-TC, cAP ac RBcAPGi-5acD2nD.
 
luca1234567
newbie
Posts: 27
Joined: Tue May 15, 2018 1:27 am
Contact:

Re: v6.47.9 [long-term] is released!

Mon Mar 22, 2021 6:43 pm

v6.47
*) ipsec - added "split-dns" parameter support for mode configuration;
But in v6.47.9 in Webfig there is NOT the option.
Only via terminal. Please, implement in Webfig.

Thank you
Best regards
 
yreks
just joined
Posts: 7
Joined: Sat Aug 16, 2014 5:53 pm

Re: v6.47.9 [long-term] is released!

Fri Apr 09, 2021 9:19 pm

Bug (/system health) in WebFig and Winbox for the Mikrotik hEX RB760GS
Firmware v6.47.9
Bootloader v6.47.9
WebFig and Winbox
(/System health) from WebFig and Winbox does not display system voltage or system temperature

Terminal

system health print
voltage: 12.9V
temperature: 44C
 
erlinden
Forum Veteran
Forum Veteran
Posts: 755
Joined: Wed Jun 12, 2013 1:59 pm

Re: v6.47.9 [long-term] is released!

Fri Apr 09, 2021 10:47 pm

It does on my hEX S, @yreks. Are you using the default power adapter? I thought it was either 24V or 48V (where I'm using an 48V adapter. Not sure if that is related.

Who is online

Users browsing this forum: FBachofner and 7 guests