Community discussions

MikroTik App
 
erykes
just joined
Topic Author
Posts: 1
Joined: Sun Feb 14, 2021 1:05 am

Wireguard Client - Server

Sun Feb 14, 2021 1:19 am

Hi,
I'm trying quite hard to configure a client server roaming IP configuration between two MikroTik routers.
Site A has a public IP an I successfully connected a Windows machine and Android device to it. This client were behind natted networks with private IP's.
But the goal is to ha site-to-site client0server between MikroTiks.

Server on site A has 10.10.100.200/24 for Wireguard and public IP
Client on site B has 10.10.100.100/24 for Wireguard and private natted IP.

I'm not able to configure the client to work. When I try to ping fro client to server the I can clearly seen traffic Tx and Rx on server site but on client it is not receivingActually it is reveivin on the WAN port but no passing it to Wireguard interface.
UDP port for wg in Firewall is open.
What should be the proper client configuration?

Client:
  #  INTERFACE   PUBLIC-KEY                                    ENDPOINT-ADDRE  ENDPO  ALLOWED-A
  0  wireguard1  Server_public_key  Server_public_IP  Srv_port  0.0.0.0/0
Server:
  #  INTERFACE   PUBLIC-KEY                                    ENDPOINT-ADDRE  ENDPO  ALLOWED-A
  0  wireguard1  Client_public_key  no_endpoint no_port  10.10.100.100/24
Changing the allowed IP in client to servers IP does not change anything. What could be the problem?
 
sergeygals
just joined
Posts: 4
Joined: Tue Jan 28, 2020 5:00 pm

Re: Wireguard Client - Server

Tue Feb 16, 2021 8:03 pm

Do you configured static IPs on interfaces wireguard1 on both side and do you create peer on one side ?

Who is online

Users browsing this forum: inxaile, klaus007, raimondsp and 11 guests