Community discussions

MikroTik App
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

KNOT LTE Cat-M with 1nce SIM card

Tue Jul 06, 2021 8:32 pm

I try to use the well known 1nce.com SIM card with KNOT.

The SIM works flawlessly in the LTAP LR8 (in LTE mode)
But in PPP mode in the KNOT , the PPP info will only show an error :
2021-07-06_19-15-44.png
/interface ppp-client> print

name="ppp-out1" max-mtu=1500 max-mru=1500 mrru=disabled port=usb2 data-channel=2 info-channel=2 
      apn="iot.1nce.net" pin="753XXX" user="" password="" profile=default phone="" 
      dial-command="ATDT" modem-init="" null-modem=no dial-on-demand=yes add-default-route=yes 
      default-route-distance=2 use-peer-dns=yes keepalive-timeout=30 allow=pap,chap,mschap1,mschap2


/interface ppp-client> info 
number: ppp-out1
       modem-status: ready
         pin-status: no password required
      functionality: full
       manufacturer: Quectel
              model: BG77
           revision: BG77LAR02A02
      serial-number: 8663XXXXXXX
   current-operator: ERROR (n/a)
               imsi: 9014051XXXXXXXX
  access-technology: ERROR
    signal-strength: ERROR: 3
   frame-error-rate: n/a


The signal-strength value is sometimes a real dB value, and sometime : ERROR: 3

Any guidance on how to troubleshoot this is welcome.

Some backgrounds : https://youtu.be/4XQjBGMSVj4?t=225
and I would have expected something like this:
2021-07-07_14-35-55.png
You do not have the required permissions to view the files attached to this post.
 
ArtisM
MikroTik Support
MikroTik Support
Posts: 5
Joined: Thu Jun 25, 2020 12:29 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Thu Jul 08, 2021 4:11 pm

To troubleshoot serial/PPP connection check using serial terminal SIM/PIN, functional status, and cellular network registration status:
at+cpin?
at+cfun?
at+cops?
If SIM/PIN is OK, functionality ir "1" and modem is registered then enable logging and check logs:
/system logging action add name=support target=memory memory-lines=16384
/system logging add action=support topics=async
/system logging add action=support topics=ppp
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Thu Jul 08, 2021 6:06 pm

How do you issue direct AT commands to the BG77 via Winbox ?

Logging shows:
2021-07-08_16-22-51.png
then
2021-07-08_16-22-58.png
After reboot :
2021-07-08_17-01-55.png
Removed SIM, tested in Phone and SIM800 board, there it is working correctly.
Removed PIN from SIM, same result.
Placed other (vodafone) SIM, same result.

Could it be an issue with the physical SIM slot?
You do not have the required permissions to view the files attached to this post.
 
ArtisM
MikroTik Support
MikroTik Support
Posts: 5
Joined: Thu Jun 25, 2020 12:29 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Fri Jul 09, 2021 10:46 am

On AT+CPIN modem responds with an error, so most likly is does not see SIM card.

Did You reboot or power cycle router after SIM card insertion? In general SIM cards are not hot-pluggable.

RouterOS - Using Serial Terminal
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Fri Jul 09, 2021 12:17 pm

Thank you for the suggestions, I am testing only but would like to get LTE working as well ;)

Connecting to serial with
/system serial-terminal port=usb2   
Will not show anything happening on serial USB2, nor lets me issue AT commands. (do I miss something here?)
I disabled GPS by the way.

After rebooting/resetting I get log errors like

- USB 2.2 sent AT+GMI >> No response >> resetting modem
- UI : could not continue : modem did not respond (6)
- UI : couldnt start : object doesn't exist (4)



some more diags :
2021-07-09_11-10-50.png
One more thing : the LTE led is flashing in steady 1 second interval.
You do not have the required permissions to view the files attached to this post.
 
ArtisM
MikroTik Support
MikroTik Support
Posts: 5
Joined: Thu Jun 25, 2020 12:29 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Fri Jul 09, 2021 2:10 pm

USB ports may have multiple channels, in case of KNOT serial terminal command should be
/system serial-terminal port=usb2  channel=2


AT+COPS=0 means what the modem is not registered in any cellular network. Is external antena connected to NB/Cat-M antenna connector?

You can try to scan/probe networks using "AT+COPS=?". This is a long-running command, which can take few minutes to complete.
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Fri Jul 09, 2021 7:17 pm

Thank you for the "port" hint, I also swapped the antenna.
at+cpin?
+CPIN: READY
OK

at+cfun?
+CFUN: 1
OK

AT+COPS=?
+COPS: (2,"vodafone ES","vodafone","21XXX",9),,(0,1,2,3,4),(0,1,2)
OK

I issued this to check registration :
AT+CREG?
+CREG: 0,5
OK
Then disconnected the serial monitor and tried to do "Scan" in GUI

This failed due to "Couldnt start, object does not exist"

What I did next was rename the PPP client name from "iot.once.net" to "aaa".
Surprise : now both info as scan worked.
Does the dot in the name matter?

Then I renamed it to 123 and the error appeared again.

Renaming it to "aaa" did not resolve it, not even after resetting the modem ( AT+CFUN=0 , AT+CFUN=1, ATZ sequence)

I appreciate your perseverance ;)
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Wed Jul 14, 2021 9:43 pm

@artism , I ordered a new simcard to rule simcard errors out. I will let you know how/if that worked.
 
jcbhltz909
newbie
Posts: 33
Joined: Tue Apr 28, 2020 10:49 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Mon Jul 19, 2021 10:55 pm

I have the same issue. I've tried 3 different SIM cards.

Did your replacement SIM work?
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Tue Jul 20, 2021 5:07 pm

I just received the newly ordered SIM from 1NCE and it does work as expected.
I will create a ticket at 1NCE to inform them.
 
jcbhltz909
newbie
Posts: 33
Joined: Tue Apr 28, 2020 10:49 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Tue Jul 20, 2021 10:40 pm

Any chance you could post your config? Just the defaults?
 
kp3928
just joined
Topic Author
Posts: 10
Joined: Tue Jul 06, 2021 3:47 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Tue Aug 03, 2021 4:04 pm

Any chance you could post your config? Just the defaults?
Yes pretty default bridge config, Check your antenna. Try the AT+COPS? Enable logging.
# MikroTik RouterOS 6.48.3 (c) 1999-2021       http://www.mikrotik.com/
# aug/03/2021 14:55:29 by RouterOS 6.48.3
# software id = ZR56-3MNY
# model = RB924i-2nD-BT5&BG77

/interface bridge
add admin-mac=2C:C8:1B:84:43:A7 auto-mac=no comment=defconf name=bridge

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX disabled=no \
    distance=indoors frequency=auto installation=indoor mode=ap-bridge ssid=knot \
    wireless-protocol=802.11

/interface ethernet switch port
set 0 vlan-mode=fallback
set 1 vlan-mode=fallback
set 2 vlan-mode=fallback

/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN

/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik

/ip pool
add name=dhcp ranges=0.0.0.1-0.0.0.254

/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf

/port
set 0 baud-rate=9600 name=modbus
set 1 name=usb2

/interface ppp-client
add apn=iot.1nce.net data-channel=2 default-route-distance=2 disabled=no info-channel=2 \
    modem-init=AT name=1nce pin=91459 port=usb2

/system logging action
add memory-lines=16384 name=support target=memory

/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge interface=ether1

/ip neighbor discovery-settings
set discover-interface-list=LAN

/interface detect-internet
set internet-interface-list=all

/interface list member
add comment=defconf interface=ether1 list=WAN
add comment=defconf interface=1nce list=WAN
add interface=ether2 list=LAN
add interface=wlan1 list=LAN

/iot mqtt brokers
add address=broker.mqttdashboard.com name=broker.mqttdashboard.com port=8000
add address=test.mosquitto.org name=test.mosquitto.org

/ip address
add address=192.168.88.1/24 comment=defconf disabled=yes interface=bridge network=\
    192.168.88.0

/ip dhcp-client
add comment=defconf disabled=no interface=bridge

/ip dhcp-server network
add address=0.0.0.0/24 comment=defconf gateway=0.0.0.0 netmask=24

/ip dns
set allow-remote-requests=yes

/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan

/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" \
    connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" \
    dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
    in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=\
    in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=\
    out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=\
    established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" \
    connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface-list=WAN

/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none \
    out-interface-list=WAN

/system clock
set time-zone-name=Europe/Madrid

/system gps
set channel=1 init-channel=2 init-string="AT+QGPSCFG=\"outport\",\"usbnmea\";+QGPS=1" port=\
    usb2 set-system-time=yes

/system identity
set name=knot

/system logging
add action=support topics=async
add action=support topics=ppp

/tool mac-server
set allowed-interface-list=LAN

/tool mac-server mac-winbox
set allowed-interface-list=LAN
 
jcbhltz909
newbie
Posts: 33
Joined: Tue Apr 28, 2020 10:49 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Tue Aug 03, 2021 7:34 pm

Thanks, ended up getting it working!
 
auoa
just joined
Posts: 1
Joined: Thu Sep 09, 2021 6:22 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Thu Sep 09, 2021 7:23 pm

I have just tested the same setup here: Mikrotik KNOT with 1nce SIM card.

It took about 24 minutes to establish a PPP connection.
RouterOS 6.48.4

My settings are default except for
  • Dial on Demand is off
  • Modem Init is AT (I am not sure, if this is neccessary)
  • APN is iot.1nce.net
Best, auoa
 
aes
just joined
Posts: 9
Joined: Thu Aug 05, 2021 9:10 pm

Re: KNOT LTE Cat-M with 1nce SIM card

Sun Oct 10, 2021 10:35 pm

No connection, waited more than 24 hours.
What can be the problem?

Firmware version
RouterOS 6.49
Interface settings
/interface ppp-client
add add-default-route=yes allow=pap,chap,mschap1,mschap2 data-channel=2 default-route-distance=2 \
dial-command=ATDT dial-on-demand=no disabled=no info-channel=2 keepalive-timeout=30 max-mru=1500 max-mtu=\
1500 modem-init=AT mrru=disabled name=ppp-out1 null-modem=no password="" phone="" pin="" port=usb2 \
profile=default use-peer-dns=yes user=""
With a SIM card of Megafon and MTS (tariff for IoT).
/system serial-terminal port=usb2 channel=2

[Ctrl-A is the prefix key]
at+cfun=4
OK
at+creg=1
OK
at+cpin?
+CPIN: READY
at+cfun=1
OK
at+cops?
+COPS: 0

OK
at+cops=?
+cops: (1,"MTS RUS","MTS RUS","25001",9),(1,"MegaFon RUS","MegaFon","25002",9),,(0,1,2,3,4),(0,1,2)

OK

+CREG: 2

+CREG: 3

+CREG: 2
Log
22:20:05 async,ppp,debug ppp-out1: LCP opened
22:20:05 async,ppp,debug,packet ppp-out1: rcvd LCP DiscReq id=0xb6
22:20:05 async,ppp,debug,packet <magic 0xd02adc61>
22:20:05 async,ppp,debug,packet ppp-out1: rcvd CHAP Challenge id=0x1
22:20:05 async,ppp,debug,packet <challenge len=16>
22:20:05 async,ppp,debug,packet <name UMTS_CHAP_SRVR>
22:20:05 async,ppp,debug,packet ppp-out1: sent CHAP Response id=0x1
22:20:05 async,ppp,debug,packet <response len=16>
22:20:05 async,ppp,debug,packet <name gdata>
22:20:05 async,ppp,debug,packet ppp-out1: rcvd CHAP Success id=0x1
22:20:05 async,ppp,info ppp-out1: authenticated
22:20:05 async,ppp,info ppp-out1: authenticated
22:20:05 async,ppp,debug ppp-out1: IPCP lowerup
22:20:05 async,ppp,debug ppp-out1: IPCP open
22:20:05 async,ppp,debug,packet ppp-out1: sent IPCP ConfReq id=0xbe
22:20:05 async,ppp,debug,packet <addr 0.0.0.0>
22:20:05 async,ppp,debug,packet <ms-dns 0.0.0.0>
22:20:05 async,ppp,debug,packet <ms-dns 0.0.0.0>
22:20:05 async,ppp,debug ppp-out1: IPV6CP open
22:20:05 async,ppp,debug ppp-out1: MPLSCP lowerup
22:20:05 async,ppp,debug ppp-out1: MPLSCP open
22:20:05 async,ppp,debug,packet ppp-out1: sent MPLSCP ConfReq id=0xbe
22:20:05 async,ppp,debug ppp-out1: BCP open
22:20:05 async,ppp,debug ppp-out1: CCP lowerup
22:20:05 async,ppp,debug ppp-out1: CCP open
22:20:05 async,ppp,debug,packet ppp-out1: rcvd LCP ProtRej id=0xb7
22:20:05 async,ppp,debug,packet 82 81 01 be 00 04
22:20:05 async,ppp,debug,packet ppp-out1: rcvd LCP TermReq id=0xb8
22:20:05 async,ppp,debug ppp-out1: LCP closed
22:20:05 async,ppp,debug ppp-out1: CCP lowerdown
22:20:05 async,ppp,debug ppp-out1: BCP lowerdown
22:20:05 async,ppp,debug ppp-out1: BCP down event in starting state
22:20:05 async,ppp,debug ppp-out1: IPCP lowerdown
22:20:05 async,ppp,debug ppp-out1: IPV6CP lowerdown
22:20:05 async,ppp,debug ppp-out1: IPV6CP down event in starting state
22:20:05 async,ppp,debug ppp-out1: MPLSCP lowerdown
22:20:05 async,ppp,debug,packet ppp-out1: sent LCP TermAck id=0xb8
22:20:05 async,ppp,debug ppp-out1: LCP lowerdown
22:20:05 async,ppp,debug ppp-out1: CCP close
22:20:05 async,ppp,debug ppp-out1: BCP close
22:20:05 async,ppp,debug ppp-out1: IPCP close
22:20:05 async,ppp,debug ppp-out1: IPV6CP close
22:20:05 async,ppp,debug ppp-out1: MPLSCP close
22:20:05 async,ppp,info ppp-out1: terminating...
22:20:05 async,ppp,info ppp-out1: terminating...
22:20:05 async,ppp,debug ppp-out1: LCP lowerdown
22:20:05 async,ppp,debug ppp-out1: LCP down event in starting state
22:20:05 async,ppp,info ppp-out1: disconnected
22:20:05 async,ppp,info ppp-out1: disconnected

[admin@KNOT] /log>

Who is online

Users browsing this forum: msax and 4 guests