Community discussions

MikroTik App
 
nellson
just joined
Topic Author
Posts: 24
Joined: Wed Nov 06, 2019 9:10 am

NV2 and RBwAPG-5HacD2HnD boot loop

Mon Oct 04, 2021 3:46 pm

Hello Forum

I have done some testing lately and found if you enable NV2 on the RBwAPG-5HacD2HnD then it works, but only until you reboot the AP twice. It doesn't matter if NV2 is enabled on wlan1 or wlan2 if. After you reboot the AP, it is stuck in an endless boot loop.

This issue is thoroughly tested on current Beta, Stable, LTS and it´s consistent.

Have any of you come across this as well?

Mikrotik support have a look at SUP-61092.
 
Rugx
newbie
Posts: 42
Joined: Thu Jan 02, 2020 1:44 pm

Re: NV2 and RBwAPG-5HacD2HnD boot loop

Tue Oct 05, 2021 9:02 am

Mind sharing your
/interface wireless export
?
I'm not getting a boot loop but some other oddities are happening once nv2 and ap-bridge is set, like wireless settings resetting after a reboot
 
nellson
just joined
Topic Author
Posts: 24
Joined: Wed Nov 06, 2019 9:10 am

Re: NV2 and RBwAPG-5HacD2HnD boot loop

Tue Oct 05, 2021 12:47 pm

Hello Rugx

There is nothing exotic in there, in this case, only wlan1 is configured to use the nv2 protocol.
And sure enough, reboot the AP and it never surfaces again. Can we maybe extract some logs from it, or attach a serial console for further investigation?
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn default-authentication=no disabled=no mode=ap-bridge nv2-cell-radius=10 nv2-mode=fixed-downlink \
    nv2-preshared-key=demo nv2-security=enabled scan-list=2412 ssid=2G-BH tdma-period-size=1 wireless-protocol=nv2
set [ find default-name=wlan2 ] default-authentication=no ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" supplicant-identity=MikroTik wpa2-pre-shared-key=demo
 
Rugx
newbie
Posts: 42
Joined: Thu Jan 02, 2020 1:44 pm

Re: NV2 and RBwAPG-5HacD2HnD boot loop

Thu Oct 07, 2021 1:14 pm

I was able to get a reboot loop as well with a few more manual reboots. Guess, best would be contacting support with a report at this point
 
nellson
just joined
Topic Author
Posts: 24
Joined: Wed Nov 06, 2019 9:10 am

Re: NV2 and RBwAPG-5HacD2HnD boot loop

Fri Oct 08, 2021 12:07 pm

I did and their response was that They will look into it and they recommend, that I not use the NV2 protocol on my router :? ehh.. we kinda need NV2 on 2G for interoperability reasons, anyway I sincerely hope they will fix it fast.
 
nellson
just joined
Topic Author
Posts: 24
Joined: Wed Nov 06, 2019 9:10 am

Re: NV2 and RBwAPG-5HacD2HnD boot loop

Tue Oct 12, 2021 8:51 pm

Kudos to Mikrotik support, they have fixed the boot loop issue. The fix will be included in the next patch release of routeros.

Who is online

Users browsing this forum: IPANetEngineer and 7 guests