Community discussions

MikroTik App
 
ewoodzy
just joined
Topic Author
Posts: 5
Joined: Thu Nov 01, 2018 3:28 pm

7.1rc4 CAP issue -- data randomly stops flowing during high utilisation

Thu Oct 07, 2021 6:49 am

I'm having an issue with CAPsMAN with CAPs that are running 7.1rc4. Here's my setup:

CAPsMAN: RB3011 running 7.1rc4
CAP 1: wAP ac running 7.1rc4 (problem CAP)
CAP 2: wAP ac running 6.48.4 (control CAP)
Client A: 2019 MBP running macOS version 12.0
Client B: 2014 MBP running Fedora Linux

What happens with both clients is that when I connect to CAP 1, I can connect just fine, and the data flows as expected. However, if I make the client do something network intensive (for example, download a torrent), after a while data transfer will suddenly cease, but I'll still remain connected to the AP. Once this happens I find that the only way to make data transfer work again is to disconnect the client and reconnect (usually by turning WiFi on the client off then on again) or roam out to CAP 2 (except client 2, which doesn't seem to be able to roam APs). I find especially on client 1 that sometimes ICMP pings will still get through, even to the Internet, but TCP and UDP connections don't get through.

CAP 2 does not have this problem at all, and reverting CAP 1 to latest stable fixes the problem as well. The RouterOS version for the CAPsMAN router does not seem to matter.

I'm currently at a loss of how to debug this further, and would like help collecting more information about the issue.

Here's my CAPsMAN config (MAC addresses are snipped out, but all default):
# oct/07/2021 14:46:04 by RouterOS 7.1rc4
# software id = <snip>
#
# model = RB3011UiAS
# serial number = <snip>
/caps-man channel
add band=5ghz-onlyac control-channel-width=20mhz extension-channel=Ceee name=5ghz tx-power=18
add band=2ghz-onlyn control-channel-width=20mhz extension-channel=disabled name=2ghz tx-power=8
/caps-man rates
add basic=18Mbps name=rates-standard supported=18Mbps,24Mbps,36Mbps,48Mbps,54Mbps
/caps-man security
add authentication-types=wpa2-psk disable-pmkid=no encryption=aes-ccm group-encryption=aes-ccm group-key-update=30m name=security-main
add authentication-types=wpa2-psk disable-pmkid=no encryption=aes-ccm group-encryption=aes-ccm group-key-update=30m name=security-guest
/caps-man configuration
add channel=5ghz country=australia datapath=datapath-main distance=indoors hw-protection-mode=none hw-retries=15 keepalive-frames=enabled name=5ghz security=security-main ssid=XXXXXXXXXX
add channel=2ghz country=australia datapath=datapath-main distance=indoors hw-protection-mode=rts-cts hw-retries=15 keepalive-frames=enabled multicast-helper=full name=2ghz rates=rates-standard security=security-main ssid=XXXXXXXXXX
add datapath=datapath-guest name=guest security=security-guest ssid="XXXXXXXXXX - Guest Network"
/caps-man datapath
add bridge=bridge1-lan client-to-client-forwarding=yes local-forwarding=yes name=datapath-main
add bridge=bridge1-lan client-to-client-forwarding=no local-forwarding=no name=datapath-guest vlan-id=20 vlan-mode=use-tag
/caps-man interface
add configuration=2ghz disabled=no l2mtu=1600 mac-address=<snip> master-interface=none name=2ghz-wap-east radio-mac=CC:2D:E0:32:6A:2B radio-name=<snip>
add configuration=guest disabled=no l2mtu=1600 mac-address=<snip> master-interface=2ghz-wap-east name=2ghz-wap-east-guest radio-mac=00:00:00:00:00:00 radio-name=<snip>
add configuration=2ghz disabled=no l2mtu=1600 mac-address=<snip> master-interface=none name=2ghz-wap-south radio-mac=<snip> radio-name=<snip>
add configuration=guest disabled=no l2mtu=1600 mac-address=<snip> master-interface=2ghz-wap-south name=2ghz-wap-south-guest radio-mac=00:00:00:00:00:00 radio-name=<snip>
add configuration=2ghz disabled=no l2mtu=1600 mac-address=<snip> master-interface=none name=2ghz-wap-west radio-mac=<snip> radio-name=<snip>
add configuration=guest disabled=no l2mtu=1600 mac-address=<snip> master-interface=2ghz-wap-west name=2ghz-wap-west-guest radio-mac=00:00:00:00:00:00 radio-name=<snip>
add channel.frequency=5745 .tx-power=20 configuration=5ghz configuration.rx-chains=0,1,2,3 .tx-chains=0,1,2,3 disabled=no l2mtu=1600 mac-address=<snip> master-interface=\
    none name=5ghz-wap-east radio-mac=<snip> radio-name=<snip>
add channel.extension-channel=XXXX .frequency=5500 configuration=5ghz disabled=no l2mtu=1600 mac-address=<snip> master-interface=none name=5ghz-wap-south radio-mac=<snip> radio-name=<snip>
add channel.extension-channel=XXXX .frequency=5660 configuration=5ghz disabled=no l2mtu=1600 mac-address=<snip> master-interface=none name=5ghz-wap-west radio-mac=<snip> radio-name=<snip>
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-enabled hw-supported-modes=ac master-configuration=5ghz name-format=prefix-identity name-prefix=5ghz
add action=create-enabled hw-supported-modes=gn master-configuration=2ghz name-format=prefix-identity name-prefix=2ghz slave-configurations=guest
Notes:
  • Ignore the 2ghz interfaces, they're not being used by either client
  • CAP 1 is "wap-east-5ghz", CAP 2 is "wap-south-5ghz"

Who is online

Users browsing this forum: andkar, drasir and 6 guests