Community discussions

MikroTik App
 
hofi76
just joined
Topic Author
Posts: 9
Joined: Tue Oct 13, 2020 11:01 am

routing in l2tp

Thu Oct 07, 2021 12:26 pm

Hi,

I set up the L2tp server. It has 10.36.6.99 local address but I need to reach 192.168.X.X and 172.16.X.X networks, too.
If I enable the 'use default gateway for remote network on the client I can reach all tree subnet but I cannot reach the internet
If I disable this setting, I can reach the internet but only the 10.36.X.X local network.
I added two manual rule for the client routing table and all is fine
route add 192.168.0.0 mask 255.255.0.0 10.36.6.99 IF 52 -p
route add 172.16.0.0 mask 255.240.0.0 10.36.6.99 IF 52 -p 
I would like to avoid adding these lines for all clients

Maybe somebody can find what is wrong with my way of thinking.
/ip route
add distance=1 gateway=195.228.XX.XX scope=36 target-scope=15
add distance=1 dst-address=10.0.0.0/8 gateway=10.36.7.254
add distance=1 dst-address=10.36.6.99/32 gateway=10.36.7.254
add distance=1 dst-address=172.16.0.0/12 gateway=10.36.7.254
add distance=1 dst-address=192.168.0.0/16 gateway=10.36.7.254
/ip route rule
add dst-address=0.0.0.0/0 interface=01WAN routing-mark=main src-address=10.36.6.0/23

Who is online

Users browsing this forum: Ahrefs [Bot], Bing [Bot], Google [Bot], pacmanfan and 27 guests