Community discussions

MikroTik App
 
icepicknz
just joined
Topic Author
Posts: 18
Joined: Thu Jul 29, 2010 1:39 am

Slow traffic via basic L2TP tunnel

Mon Oct 11, 2021 5:15 am

I have Fiber at home (via PPPoE) on a 200mbps plan and a Server hosted at a DC (Ethernet Assigned IP) on a 1Gb plan.
I have been getting very slow speeds so tried routing all traffic (0.0.0.0/0) through the tunnel to browse and test.

I'm assuming that a fragment issue or something. Try loading a page and it takes many minutes to load.
Run a speedtest.net and takes ages for page to load.
When I can eventually click start, it shoots up fast, then goes down to like 5mbps.

Wireshark showing TCP Out of orders and TCP Dup ACK's

Router at home doing PPPoE
[admin@9DaynaAve] > /interface l2tp-client export 
# oct/11/2021 15:08:59 by RouterOS 6.44.1
# software id = SCBV-EF7W
#
# model = 2011iLS
# serial number = 608405AEC6A8
/interface l2tp-client
add allow=pap connect-to=x.x.x.x disabled=no keepalive-timeout=15 max-mru=1380 max-mtu=1380 mrru=1500 name=l2tp-tga-router password=xyz profile=custom user=\
    dayna-ave
[admin@9DaynaAve]

DC router on 1Gbps
[icepick@TGA-RTR] > /ppp profile export 
# oct/11/2021 15:09:54 by RouterOS 6.48.2
# software id = UQZK-6LIA
#
# model = RB1100x4
# serial number = CE9A0CF25A7F
/ppp profile
add change-tcp-mss=yes name=custom use-compression=no use-encryption=no \
    use-ipv6=no use-mpls=no
[icepick@TGA-RTR] > 
 
ZupoLlask
just joined
Posts: 16
Joined: Mon Jan 26, 2015 1:26 pm

Re: Slow traffic via basic L2TP tunnel

Mon Oct 11, 2021 11:42 pm

Dear @icepicknz,

It's funny you bring this one to the forum as I experienced some sluggish performance of L2TP (over IPsec) when comparing it with EoIP (over the same IPsec tunnel).
It feels the problem is not directly related with performance (as in throughput) but with lag/latency.

Do you want to redo your setup so you can test EoIP against L2TP and report your findings? :-)

Who is online

Users browsing this forum: almdandi, Google [Bot], lazypirate, Semrush [Bot] and 41 guests