Community discussions

MikroTik App
 
makstex
newbie
Topic Author
Posts: 49
Joined: Fri Mar 27, 2009 6:31 am

How do I remove the space in the output to separate the digits?

Wed Oct 13, 2021 2:02 pm

Tell me how to remove this "smart" functionality?
/ip firewall connection print from=[/ip firewall connection find connection-mark~"rdp"] terse
An example of output on a nested picture. Highlighted spaces in red.
You do not have the required permissions to view the files attached to this post.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 5896
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: How do I remove the space in the output to separate the digits?

Wed Oct 13, 2021 6:55 pm

Do not ask help for do things on wrong way...

If you use "print" on scripting, you do something on wrong way...

What you try to achieve?
 
makstex
newbie
Topic Author
Posts: 49
Joined: Fri Mar 27, 2009 6:31 am

Re: How do I remove the space in the output to separate the digits?

Thu Oct 14, 2021 6:41 am

This is the simplest way of obtaining information for statistics, which I can then easily process, the spaces complicate a little, so I asked. Why would I complicate the simplest system if it works?
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2344
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: How do I remove the space in the output to separate the digits?

Thu Oct 14, 2021 8:15 am

"print" is not to be used in script.

You do use find and get to get what you need
{
/ip firewall connection
	:foreach i in=[find where protocol=tcp] do={
	:put $i
	:put [get $i orig-packets]
}
}
PS code is wrapped in and extra {} so you can past it to terminal.
 
Try Splunk> to monitor your MikroTik Router(s). How to set it up. :mrgreen:

MikroTik->Splunk
 

Who is online

Users browsing this forum: Baidu [Spider], Semrush [Bot] and 15 guests