Community discussions

MikroTik App
 
almeiras
newbie
Topic Author
Posts: 34
Joined: Fri Nov 15, 2019 9:16 pm
Location: Spain

Netinstall won't start after finding PXE client [SOLVED]

Thu Oct 14, 2021 1:04 pm

Hello, I'm trying to netinstall a bricked RB4011 using netinstall for Linux (Ubuntu 20.04 VM under VMware Fusion).
mkdir netinstall && cd netinstall
wget https://download.mikrotik.com/routeros/7.1rc4/netinstall-7.1rc4.tar.gz https://download.mikrotik.com/routeros/7.1rc4/routeros-7.1rc4-arm.npk
tar -zxvf netinstall-7.1rc4.tar.gz
sudo ./netinstall -a 192.168.XX.YY routeros-7.1rc4-arm.npk
Using server IP: 192.168.XX.ZZ
Starting PXE server
Waiting for RouterBOARD...
PXE client: AA:BB:CC:DD:EE:FF
...but then nothing happens, no "Sending image". The same PXE client appears then several times. I am currently using DHCP instead of BOOTP. I'm using a console cable to verify the process in the other side. I can access setup. Should I format NAND or use any of the available options in RouterBOOT? Thank you.

EDIT: Some thoughts about netinstall for Linux CLI:
  • It doesn't work on macOS Intel 64 bit:
    cannot execute binary file
    or
    exec format error
  • It doesn't work on neither Raspberry Pi Ubuntu ARM64 nor Raspbian ARM (32 bit):
    Syntax error: "(" unexpected
  • It works on Ubuntu x64
EDIT2: Solved blockage after switching to BOOTP, but then I got:
Sending image: arm
Discovered RouterBOARD...
Key was rejected
On the RB4011 side I get some mac info along with the key:
Welcome to MikroTik Router Software remote installation 7.1rc4
Press Ctrl-Alt-Delete to abort

mac-address: AA:BB:CC:DD:EE:01
mac-address: AA:BB:CC:DD:EE:02
mac-address: AA:BB:CC:DD:EE:03
mac-address: AA:BB:CC:DD:EE:04
mac-address: AA:BB:CC:DD:EE:05
mac-address: AA:BB:CC:DD:EE:06
mac-address: AA:BB:CC:DD:EE:07
mac-address: AA:BB:CC:DD:EE:08
mac-address: AA:BB:CC:DD:EE:09
mac-address: AA:BB:CC:DD:EE:0A
mac-address: AA:BB:CC:DD:EE:0B


software-id: PTLK-WN2S key:
xxxxxxxxxxx xxxxxxxxxxx xxxxxxxxxxx xxxxxxxxxxx xxxxxxxxxxx xxxxxxxxxxx xxxxxxxxxxx

Waiting for installation server...

EDIT3: What is the "-a" parameter for? Is it important? I just put an available IP address in my subnet, but some people put 192.168.88.1


EDIT4: SOLVED!!! Based on this thread: viewtopic.php?p=885791
  • Access bricked RB4011 via serial (Cisco) cable.
  • Enter setup, select boot device:
    e - boot over Ethernet
  • Start netinstall from Linux x86 using old version (6.47.9). Wait for error to appear
    Key was rejected
  • Start again netinstall from Windows using latest version (7.1RC4).
  • Success!
The problem was that Linux recognizes the router but won't flash it. Windows on the other hand would not recognize the router (but it would flash it once recognized).
screenshot.png
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: blackangel1 and 7 guests