Community discussions

MikroTik App
 
remackad
just joined
Topic Author
Posts: 1
Joined: Mon Aug 20, 2018 5:16 am

Tracking buffer overflow wireless interface

Mon Nov 08, 2021 6:23 am

RouterOS has ability to detect buffer overflow of wireless interface driver (wlan, wds).

You can do this using Queue Tree and PCQ.

# Create WLANs list with include dynamic interfaces (dynamic WDS)
/interface list add name=wlans_list include=dynamic
/interface list member add list=wlans_list interface=wlan1

# Marking packets from WLANs list
/interface bridge filter add action=mark-packet chain=forward new-packet-mark=wlans out-interface-list=wlans_list

# Create PCQ queue with little buffer
/queue type add kind=pcq name=1 pcq-classifier=dst-address pcq-limit=1KiB

# Create Queue Tree
/queue tree add name=wifi-buffer-check packet-mark=wlans queue=pcq-buffer parent=wlan1 (or wds1/2/3/n...)

Then, we run SpeedTest from client device (preferably UDP) to cause buffer overflow of wireless interface.
Tracking parameter of dropped packets in Queue Tree. All traffic that could not be sent over Wi-Fi in time will accumulate in buffer of wireless interface driver, and then in buffer of PCQ queue (1 KB).
When PCQ queue is full, packet dropping will begin. Using this parameter, you can take statistics and understand when packets are delayed in buffer for too long (radio interference, bad signal, re-reflections, etc.).

This works when using parent of some interface (wlan1 or wds1/2/3/n...). The problem starts if you use dynamic creation of WDS interfaces.
In this case, only thing you can use as a parent is Global. But when using Global, you will not have packet drops and you will not be able to track buffer overflow.
The only way out of this problem is to use interface-list with include of dynamic interfaces. But we can't use interface-list in Queue Tree.

MikroTik support confirms this possibility, but will not add it until there are more similar requests.
Check out this feature for yourself and if you find it useful, create a future request in support.
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: KingRichard and 26 guests