Community discussions

MikroTik App
 
finkenwerder
just joined
Topic Author
Posts: 3
Joined: Fri Nov 19, 2021 6:20 pm

Establish connection from WiFi to machine on ethernet port

Fri Nov 19, 2021 6:46 pm

Dear all,

I hope that my descriptions / titles are accurate enough.
Even tho I know the basics of computer networks, I could not get this one to work. Thus I would like for advice on how to tackle this.

The problem:
I have a server that has an IP of 192.168.13.1 running on eth1 (I cannot change anything on the server).
I have a mobile device, which I want to log into a wireless network. The wireless device shall then be able to talk to the server at 192.168.13.1.
Whats more is that DNS resolution shall be available for the mobile device. For example component.sys1.local shall point the mobile device to the same 192.168.13.1

The idea is: The mobile device connects to the wireless network and any traffic between the wireless network and the server is bridged between the two on the MikroTik device.
The MikroTik device is using Ethernet Port 7 to connect to the server.

Here is a rather primitive illustration of this:
Image

Please find a list of steps I have taken to realize this below (RouterOS 6.48.3, Apologies for not providing the RouterOS commands, I did feel more comfortable doing this with Winbox)
Unfortunately, I am still unable to ping the Server at 192.168.13.1
Could anybody perhaps help me with this?

Create a new wireless Interface, SSID: Lab-test-WiFi

Create a wireless security profile and assign to wireless profile Lab-test-WiFi

Create a new bridge Lab-test-bridge

Add Ports to Lab-test-bridge
-Lab-test-WiFi
-Ethernet Port 7

Add IP addresses:
Address: 192.168.13.2/24
Network: 192.168.13.0
Interface: Lab-test-WiFi

Add DHCP Server:
Address: 192.168.13.0/24
Gateway (not really required, but RouterOS wants an address here): 192.168.13.254
Netmask: 24
DNS Servers: 192.168.13.2

Add new Address Pool: Lab-test-pool
Addresses: 192.168.13.100-192.168.13.200
 
ConnyMercier
Forum Veteran
Forum Veteran
Posts: 724
Joined: Tue Dec 17, 2019 1:08 pm

Re: Establish connection from WiFi to machine on ethernet port

Tue Nov 23, 2021 12:53 am

This is how I would do it...
I tried to keep all the same names and IP.

Step 1 : Create Bridge
/interface bridge
add name=Lab-test-bridge
Step 2: Assign Interfaces to Bridge (not to Interface!)
/interface bridge port
add bridge=Lab-test-bridge interface=ether7
add bridge=Lab-test-bridge interface=Lab-test-WiFi
Step 3: Assign Network-IP on Bridge
/ip address
add address=192.168.13.2/24 interface=Lab-test-bridge network=192.168.13.0
Step 4: Create DHCP-Server for Network
/ip pool
add name=dhcp_pool0 ranges=192.168.13.100-192.168.13.200
/ip dhcp-server
add address-pool=dhcp_pool0 disabled=no interface=Lab-test-bridge name=dhcp1
/ip dhcp-server network
add address=192.168.13.0/24 dns-server=192.168.13.2 gateway=192.168.13.2
Step 5: Enable DNS-Request
/ip dns
set allow-remote-requests=yes
Step 6: Static-DNS for Server
/ip dns static
add address=192.168.13.1 name=component.sys1.local
 
finkenwerder
just joined
Topic Author
Posts: 3
Joined: Fri Nov 19, 2021 6:20 pm

Re: Establish connection from WiFi to machine on ethernet port

Wed Dec 01, 2021 11:18 am

Hello ConnyMercier,

thank you very much for your help.

I was actually quite close to what you are suggesting.

In the end, I managed to get it working. I was missing one crucial information: The server at 192.168.13.1 is running a DHCP server. Once I relayed that, it worked with no problems.

Again thank you very much for your help and regards.

Who is online

Users browsing this forum: qatar2022 and 33 guests