Community discussions

MikroTik App
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

IPv6 Stateless and Prefix Delegation

Mon Nov 29, 2021 10:03 pm

On our customer ports, we have assigned a /56 per port and are needing to support prefix delegation to any customer routers plugged in and assign IPv6 addresses directly to any customers plugged directly in. We also need to offer the IPv6 DNS servers. So far, we can get prefix delegation working without issue but we are unable to get clients to pull IPv6 addresses. We tried using SLAAC but while they pulled addresses, they did not work. Would anyone have a example of supporting both methods at the same time?

/ipv6 route
add distance=1 dst-address=xxxx:b840:11::/48 type=unreachable
/routing bgp network
add network=xxxx:b840:11::/48 synchronize=no
/ip dns set servers=xxxx:b840:10:1::10,xxxx:b840:10:1::10
/ipv6 pool add name=office prefix-length=56 prefix=xxxx:b840:11::/48
/ipv6 dhcp-server add name=office interface=Office address-pool=office
/ipv6 nd prefix add prefix=::/0 interface=Office on-link=yes autonomous=no
/ipv6 nd add interface=Office managed-address-configuration=yes other-configuration=yes advertise-dns=yes

We have seen information stating that the managed-address-configuration needs to be on for prefix delegation while it needs to be off for SLAAC. We are not sure what to do in this scenario
 
mducharme
Trainer
Trainer
Posts: 1777
Joined: Tue Jul 19, 2016 6:45 pm
Location: Vancouver, BC, Canada

Re: IPv6 Stateless and Prefix Delegation

Mon Nov 29, 2021 11:16 pm

This is fine:
/ipv6 pool add name=office prefix-length=56 prefix=xxxx:b840:11::/48
/ipv6 dhcp-server add name=office interface=Office address-pool=office
But as for this:
/ipv6 nd prefix add prefix=::/0 interface=Office on-link=yes autonomous=no
/ipv6 nd add interface=Office managed-address-configuration=yes other-configuration=yes advertise-dns=yes
You don't need those settings. The interface and the prefix should be automatically added when you add the IPv6 address onto the port.

A lot of customer routers won't even attempt to pull a prefix unless their WAN side gateway (on your end, facing them) has a /64 IPv6 address on it, with advertise set to yes. It acts as some kind of auto detection mechanism.

Who is online

Users browsing this forum: Amazon [Bot], biomesh, GuJack20, korg and 69 guests