Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 852
Joined: Thu Dec 11, 2014 8:53 am

v7.1.2 is released!

Thu Feb 10, 2022 10:28 am

RouterOS version 7.1.2 has been released "v7 stable" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 7.1.2 (2022-Feb-03 16:15):

*) bgp - fixed routing table and BGP configuration order in export;
*) bluetooth - disable scanning by default;
*) chr - improved system stability when writing into memory;
*) chr - temporarily suspended downgrade to RouterOS v6;
*) console - updated copyright notice;
*) dhcpv4-server - remove dynamic leases when server configuration is removed;
*) hotspot - fixed web page loading using HTTPS;
*) interface - fixed minor memory leak when interface or connected route is changed;
*) lte - added MAC address and IPv6 LL address persistence after reboot on EG12 and EG18 modems;
*) lte - added class based support for configless RNDIS LTE modems;
*) lte - expose diagnostics channel for all modems;
*) lte - fixed IPv6 address addition after startup on R11e-LTE6;
*) lte - fixed packet forwarding on R11e-4G and R11e-LTE-US;
*) lte - fixed support for Sierra MC7710;
*) lte - improved stability on "+EGMR" response in MBIM mode;
*) lte - properly recognize MBIM modem in USB port as LTE on Chateau 5G;
*) ntp - allow adding duplicate server address if dynamic entry exists;
*) ntp - fixed "use-local-clock" when enabling server;
*) ntp - fixed multicast mode support;
*) ntp - improved IPv6 address support;
*) ospf - added "ptmp-broadcast" interface type (compatible with RouterOSv6 PTMP type);
*) ospf - convert ospf "static" redistribute to "static,dhcp,modem,vpn" after update from RouterOS v6;
*) ospf - fixed external LSA not updating after prefix netmask change;
*) ppp - fixed AT+CPIN chat when SIM PIN is specified;
*) qsfp - correctly display auto-negotiation status;
*) queue - improved system stability when processing traffic;
*) route - fixed "suppress-hw-offload" update;
*) route - fixed router's LSA for PTP networks;
*) route - show OSPF and RIP specific attributes in "/routing route" table;
*) route-filter - fixed incorrect invert-match configuration upgrade from RouterOS v6;
*) route-filter - fixed range conversion after update from RouterOS v6;
*) rpki - made RPKI verify non-strict, introduces new state "unverified";
*) rpki - show expire timer;
*) socks - fixed SOCKS5 support;
*) system - fixed license loss on some RB1100Dx4 and RB4011 devices;
*) tr069-client - added support for wireless client uptime reporting;
*) usb - fixed display of incorrect port count for USB serial ports;
*) vlan - fixed improper VLAN priority addition for routed packets;
*) webfig - do not show side menu if WebFig is disabled by skin;
*) winbox - added "VRF" parameter to "IP/Services" menu;
*) winbox - added MLAG support;
*) winbox - added ZeroTier support;
*) winbox - allow setting "Interface" parameter for 100G LED types;
*) winbox - do not show "Antenna Scan" button on devices that do not support it;
*) winbox - fixed "action" field in "IP/Web Proxy/Access" menu;
*) winbox - fixed address list type parameters in "Routing" menu;
*) winbox - made OSPF interface type names consistent between CLI and GUI;
*) x86 - added support for Intel E810 NIC;
*) x86 - made "no" the default value for "disable-running-check" ethernet parameter;
*) x86 - properly distinguish multiple NICs that share the same PCI bus number;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this particular RouterOS release.
 
User avatar
morphema
Posts: 0
Joined: Tue Feb 02, 2021 12:15 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 10:48 am

I still have a weird LED indication on my two Audiences. They are always blue and never become green, even when the connection works fine. Is there anything I should do from my side, or you will fix that?
 
User avatar
denisun
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Wed Jul 16, 2014 6:38 pm
Location: Greece

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:11 am

Did you fix this problem?
i cant see anything...
I still have problem with mark packet in ipv6.
When it is enable all traffic pass from input and drop to forward as invalid.
The connections show tab is empty.
When i disable mark packet, all work perfect but i have not QoS.
I cant have a QoS with ipv6 traffic.
All traffic drop to forward as invalid.
Now i have ros 6.49.2 with the same conf and all work perfect.
Last edited by denisun on Thu Feb 10, 2022 11:17 am, edited 1 time in total.
 
erlinden
Forum Guru
Forum Guru
Posts: 1067
Joined: Wed Jun 12, 2013 1:59 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:12 am

Upgraded all my devices...no problem upgrading.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:27 am

Upgraded all my devices...no problem upgrading.
If this is a huge production network, you have big balls, 42 min after release :)
I always wait some weeks (reading forums) to see if some goes wrong.
Also test one test router that are like my production routers to make sure all my functions works.
 
User avatar
nichky
Forum Veteran
Forum Veteran
Posts: 929
Joined: Tue Jun 23, 2015 2:35 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:31 am

what is 6to4 tunnel?
 
Heavy
just joined
Posts: 2
Joined: Mon Dec 21, 2020 6:59 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:43 am

I've seen that has been added the ups package to 7.1.2, but on RB3011 does not recognize the UPS connected to USBHID1 port (my CyberPower OR600ELCDRM1U was recognizable till 6.xx.xx via usbhid1). Is possible to fix this issue ?
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:56 am

what is 6to4 tunnel?
Where did you see this? I do not see any mention on 6to4 in this post.
Found on google
6to4 tunnels enable isolated IPv6 sites to communicate across an automatic tunnel over an IPv4 network that does not support IPv6. To use 6to4 tunnels, you must first configure a boundary router on your IPv6 network as one endpoint of the 6to4 automatic tunnel.

This release has one of the longest time between compiled and released, more than 7 days :)
 
erlinden
Forum Guru
Forum Guru
Posts: 1067
Joined: Wed Jun 12, 2013 1:59 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 11:58 am

If this is a huge production network, you have big balls, 42 min after release :)
Compared to other home networks this is a huge production network ;-)
 
User avatar
fischerdouglas
newbie
Posts: 27
Joined: Thu Mar 07, 2019 6:38 pm
Location: Brazl
Contact:

Re: v7.1.2 is released!

Thu Feb 10, 2022 12:30 pm

RouterOS version 7.1.2 has been released "v7 stable" channel!

*) bgp - fixed routing table and BGP configuration order in export;
Hello Emils!
Any updates on how to check the exported routes per peer on BGP Sessions?

This has been requested for a while.

The primary thread (in my opinion) on this forum about the lack of how to check advertised routes is the following:
ROSv7 equivalent of /routing/bgp/advertisements print

P.S.: If I'm not mistaken, on some of RC versions the BGP route cache was available to prints, what solved the needs of seen exporte routes per peer.
 
DenisPDA
newbie
Posts: 37
Joined: Tue Sep 04, 2018 5:42 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 12:37 pm

There is a glitch
You do not have the required permissions to view the files attached to this post.
 
landy
Posts: 0
Joined: Thu Feb 10, 2022 12:37 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 12:43 pm

I've seen that has been added the ups package to 7.1.2, but on RB3011 does not recognize the UPS connected to USBHID1 port (my CyberPower OR600ELCDRM1U was recognizable till 6.xx.xx via usbhid1). Is possible to fix this issue ?
Same issue with APC Back-UPS ES 550G on Mikrotic hEX S (mmips).
I have connected UPS over USB. It's seen in USB resources:
[admin@mikrotik] /system/ups> /system resource usb print 
Columns: DEVICE, VENDOR, NAME, SPEED
# DEVICE  VENDOR                NAME                                      SPEED
0 1-0     Linux 5.6.3 xhci-hcd  xHCI Host Controller                      480  
1 1-1     APC                   Back-UPS ES 550G FW:870.O3 .I USB FW:O3   1.5  
2 2-0     Linux 5.6.3 xhci-hcd  xHCI Host Controller                      5000 
But not possible to add as UPS (not show port with usbhid. Here offers only "serial0" port.
 
Heavy
just joined
Posts: 2
Joined: Mon Dec 21, 2020 6:59 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 12:48 pm

Same issue with APC Back-UPS ES 550G on Mikrotic hEX S (mmips).
I have connected UPS over USB. It's seen in USB resources:

But not possible to add as UPS (not show port with usbhid. Here offers only "serial0" port.

I confirm that mine too is recognized by the system but not available on usb port selection as i said in the previous post
Columns: DEVICE, VENDOR, NAME, SPEED
# DEVICE  VENDOR                NAME                  SPEED
0 1-0     Linux 5.6.3 xhci-hcd  xHCI Host Controller  480  
1 1-1     CPS                   OR600ELCDRM1U         1.5  
2 2-0     Linux 5.6.3 xhci-hcd  xHCI Host Controller  5000 
 
User avatar
arnaldo
newbie
Posts: 27
Joined: Wed Sep 21, 2016 2:38 am
Location: localhost.localdomain

Re: v7.1.2 is released!

Thu Feb 10, 2022 1:06 pm

WebFig still preent the IP->Routes bug. Will not properly display current routes and will become irresponsive after showing either the "Rules" tab or "Add New" or show route (basically leave and return to the route list tab).

Also, there is a really wierd problem with Firefox: items on the left menu vanish and only clearing the browser cache seems to fix it.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2178
Joined: Mon Apr 08, 2019 1:16 am

Re: v7.1.2 is released!

Thu Feb 10, 2022 1:33 pm

what is 6to4 tunnel?
IPv6 over IPv4
https://www.researchgate.net/figure/Ter ... _271549193
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 212
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: v7.1.2 is released!

Thu Feb 10, 2022 3:40 pm

Metal 2SHPn managed by CAPsMAN going to infinite loop with message about watchdog time out. On CAPsMAN LOG is this message : ap-17: failed to select channel, no usable channels.

AP-17 is that Metal 2SHPn.

Apparently CAPsMAN set some instruction to AP about channel and because AP is not OK with that it freeze and watchdog make reboot. With ros 7.2 rc3 there is no such problem, atleast for now.
 
User avatar
rushlife
Member Candidate
Member Candidate
Posts: 212
Joined: Thu Nov 05, 2015 12:30 pm
Location: czech republic

Re: v7.1.2 is released!

Thu Feb 10, 2022 3:44 pm

Resolved by disabling interface on CAPsMAN, logging to AP-17 and manually upgraded to 7.2rc3.
Than I was able to enable interface on CAPsMAN and so far so gut.

Without disabling interface on CAPsMAN that AP is not accessible because reboot loop.
 
Argosy
just joined
Posts: 8
Joined: Fri Aug 02, 2019 1:26 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 4:14 pm

same problem here with capsman
my ap shows more then once up in capsman.

Funny, now it looks normal.
Last edited by Argosy on Thu Feb 10, 2022 4:50 pm, edited 1 time in total.
 
User avatar
TFyre
just joined
Posts: 16
Joined: Wed Jan 13, 2010 3:37 pm
Contact:

Re: v7.1.2 is released!

Thu Feb 10, 2022 4:46 pm

MPLS / VPLS sorted??

I cant find anything in the changelog
 
User avatar
Chaosphere64
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Wed Aug 10, 2016 10:19 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 5:32 pm

Internet Detect feature does not work any longer after upgrading from RouterOS 7.1.1 to 7.1.2. RB4011, configuration unchanged.

Edit: had to re-configure this from scratch to make it work again.
 
brg3466
Member Candidate
Member Candidate
Posts: 141
Joined: Sat Aug 01, 2015 7:29 am

Re: v7.1.2 is released!

Thu Feb 10, 2022 7:07 pm

Still cannot upgrade the modem firmware to R11eL_v05.04.193841 on my LtAP mini LTE US-Kit. Once you want to upgrade, the LTE lost connection to internet.
 
elbob2002
Member Candidate
Member Candidate
Posts: 153
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: v7.1.2 is released!

Thu Feb 10, 2022 7:33 pm

MPLS / VPLS sorted??

I cant find anything in the changelog
Then it's not sorted then is it? If it was it would be in the changelog!
 
User avatar
Kentzo
Member Candidate
Member Candidate
Posts: 126
Joined: Mon Jan 27, 2014 3:35 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 8:24 pm

Can anyone elaborate on
*) vlan - fixed improper VLAN priority addition for routed packets;
What exactly was fixed?
 
nijol90363
just joined
Posts: 5
Joined: Tue Aug 18, 2020 10:31 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 8:52 pm

Was anyone able to get 7.1 working on a ppc routerboard? I tried 7.1.1 and 7.1.2 on RB333 and the boot failed with "kernel out of range". Even the netinstall is broken, it gets stuck on "waiting for installation server". Is 64MB of RAM not enough for the new version?
 
User avatar
andkar
newbie
Posts: 26
Joined: Tue Aug 11, 2020 9:20 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 9:06 pm

RB3011 only used as Capman controller, v7.1.1 no problem. Upgrade to 7.1.2 resulted in endless boot loop.
Output from console:
RouterBOOT booter 7.1.1

RB3011UiAS

CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
opendir: No such file or directory
opendir: No such file or directory
ERROR: no system package found!
[    6.023110] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000
[    6.023350] CPU: 0 PID: 1 Comm: init Not tainted 5.6.3 #2
[    6.030805] Hardware name: RB3011
[    6.036371] {bf05ff2c} _stext+0x97c4/0x4489f8
[    6.039663] {bf05ff34} _stext+0x4351e0/0x4489f8
[    6.044003] {bf05ff44} _stext+0x19acc/0x4489f8
[    6.048345] {bf05ff6c} _stext+0x1b8f0/0x4489f8
[    6.052855] {bf05ff84} _stext+0x1ca04/0x4489f8
[    6.057281] {bf05ff9c} _stext+0x1ca74/0x4489f8
[    6.061720] CPU1: stopping
[    6.066142] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 5.6.3 #2
[    6.068827] Hardware name: RB3011
[    6.074652] {bf091f34} _stext+0x97c4/0x4489f8
[    6.078035] {bf091f3c} _stext+0x4351e0/0x4489f8
[    6.082373] {bf091f4c} _stext+0xbf10/0x4489f8
[    6.086712] {bf091f64} _stext+0x1b4720/0x4489f8
[    6.091228] {bf091f7c} _stext+0x1acc/0x4489f8
[    6.095563] Exception stack(0xbf091f80 to 0xbf091fc8)
[    6.100104] 1f80: 000006e8 00000000 000006e8 801142a0 bf090000 00000002 80903e24 80903e60
[    6.105143] 1fa0: 4000406a 512f04d0 00000000 00000000 00000000 bf091fd0 80106f80 80106f70
[    6.113284] 1fc0: 60000013 ffffffff
[    6.121436] {bf091fcc} _stext+0x6f70/0x4489f8
[    6.124736] {bf091fd4} _stext+0x3a108/0x4489f8
[    6.129248] {bf091fec} _stext+0x3a398/0x4489f8
[    6.133587] {bf091ff4} 0x4010246c
[    6.138028] Rebooting in 5 seconds..
Netinstall next....
 
sweede
Posts: 0
Joined: Thu Feb 10, 2022 9:54 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 10:01 pm

Can't find this update on my RB5009. Have checked for updates in /system packages

Quick Set > Check for updates shows installed version 7.0.5 and latest version 6.49.2

What am I doing wrong?
 
Sob
Forum Guru
Forum Guru
Posts: 8383
Joined: Mon Apr 20, 2009 9:11 pm

Re: v7.1.2 is released!

Thu Feb 10, 2022 10:19 pm

Was anyone able to get 7.1 working on a ppc routerboard? I tried 7.1.1 and 7.1.2 on RB333 and the boot failed with "kernel out of range". Even the netinstall is broken, it gets stuck on "waiting for installation server". Is 64MB of RAM not enough for the new version?
I sacrificed one RB333 and it's not good. After upgrade from 6.49.2 it fails to boot with same "kernel out of range" as yours. It can be fixed by upgrading firmware as described in v7.1beta4 on RB600A thread (RB333 is mpc8323; I used upgrade over serial port, since the board was already bricked), and then it boots. Problem is, after that, all ethernet ports are dead, autonegotiation is successful, it's connected at 100M full duplex, I see rx traffic, but zero tx, router doesn't send anything, no matter what I do. And no, you don't need to worry about memory, 27MB free, no problem there. But those ethernets ruin the fun.
Last edited by Sob on Thu Feb 10, 2022 10:21 pm, edited 1 time in total.
 
monotsc
just joined
Posts: 1
Joined: Sat Jun 30, 2018 7:15 am
Location: indonesia

Re: v7.1.2 is released!

Thu Feb 10, 2022 10:20 pm

dhcp-server or dhcp-relay on vlan interface still not working on X86 with intel i350 nic since v.7 first release
 
DL7JP
Frequent Visitor
Frequent Visitor
Posts: 80
Joined: Sat Oct 19, 2013 4:14 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 12:05 am

Hm ... the update re-ordered my firewall rules on an RB1100AHx4. Quite a mess.
Last edited by DL7JP on Fri Feb 11, 2022 3:00 am, edited 1 time in total.
 
User avatar
loloski
Member Candidate
Member Candidate
Posts: 127
Joined: Mon Mar 15, 2021 9:10 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 12:16 am

v7 has a weird bug, if you setup a hotspot on wired interface and put external AP like TP-LINK or any other brand the client device will work for a few minutes then it stop to work properly, can't reproduce this issue on v6. The affected device is RB4011 this issue has been ignored by support honestly

@MT this is a common scenario please include this in your smoke test before releasing code in the wild
Last edited by loloski on Fri Feb 11, 2022 12:48 am, edited 1 time in total.
 
monotsc
just joined
Posts: 1
Joined: Sat Jun 30, 2018 7:15 am
Location: indonesia

Re: v7.1.2 is released!

Fri Feb 11, 2022 12:28 am

v7 has a weird bug, if you setup a hotspot on wired interface and put external AP like TP-LINK or any other brand the client device will work for a few minutes then it stop to work properly, can't reproduce this issue on v6. The affected device is RB4011 this issue has been ignored by support honestly
i dont know if its the same, but i got it fixed after removing any firewall rules with action=mark-connection
 
User avatar
loloski
Member Candidate
Member Candidate
Posts: 127
Joined: Mon Mar 15, 2021 9:10 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 12:42 am

v7 has a weird bug, if you setup a hotspot on wired interface and put external AP like TP-LINK or any other brand the client device will work for a few minutes then it stop to work properly, can't reproduce this issue on v6. The affected device is RB4011 this issue has been ignored by support honestly
i dont know if its the same, but i got it fixed after removing any firewall rules with action=mark-connection
I haven't touch the firewall rule created by default by hotspot, the device configuration is pretty basic straight from factory reset and turned on hotspot
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 2:33 am

Was anyone able to get 7.1 working on a ppc routerboard? I tried 7.1.1 and 7.1.2 on RB333 and the boot failed with "kernel out of range". Even the netinstall is broken, it gets stuck on "waiting for installation server". Is 64MB of RAM not enough for the new version?
Have it working on RB1100AH, but that has a lot of memory. most models i check its using almost 50MB of memory so depending on your config may be not enough, cant say for sure, but PPC seems ok.
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 2:42 am

Have it running fine so far on;
Routers;
HapAC
RB450G
RB1100AH
RB3011UiAS - (System bricked only on firmware update, package update was fine, so reset and restored backup - all good but would be inconvenient in the wild)
RB4011iGS+ - from 6.44.7 all good except SFP (Cisco GLC-T) had to be hard coded to 1Gbps (Auto showed connected at 10M but no connectivity)
CCR2004-1G-12S+2XS
X86 Hyper-V (works fine, with exception of no Dude server still)
Switches;
CRS328-24P-4S+
CRS226-24G-2S+
CRS112-8P-4S
CRS309-1G-8S+

Still waiting to test;
Routers;
CCR1072-1G-8S+ (will be testing full BGP tables as well)
Switches;
CRS326-24S+2Q+
CRS354-48G-4S+2Q+

more to test later pending results above..
Last edited by nexusds on Mon Feb 14, 2022 4:57 pm, edited 2 times in total.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Fri Feb 11, 2022 8:19 am

Can't find this update on my RB5009. Have checked for updates in /system packages
Quick Set > Check for updates shows installed version 7.0.5 and latest version 6.49.2
Upgrade to 6.49.2 and you should see 7.1.2
 
elbob2002
Member Candidate
Member Candidate
Posts: 153
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: v7.1.2 is released!

Fri Feb 11, 2022 9:14 am

Can't find this update on my RB5009. Have checked for updates in /system packages
Quick Set > Check for updates shows installed version 7.0.5 and latest version 6.49.2
Upgrade to 6.49.2 and you should see 7.1.2

6.49.2 won't run on an RB5009

You'll need to remove any extra packages that may be installed and then upload the npk from the Mikrotik Downloads page and reboot.
 
User avatar
TFyre
just joined
Posts: 16
Joined: Wed Jan 13, 2010 3:37 pm
Contact:

Re: v7.1.2 is released!

Fri Feb 11, 2022 9:43 am

MPLS / VPLS sorted??

I cant find anything in the changelog
Then it's not sorted then is it? If it was it would be in the changelog!
One can hope!! Wouldnt be the first time things are omitted from the changelog :P
 
cwt
Posts: 0
Joined: Fri Feb 11, 2022 9:58 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 10:00 am

v7 has a weird bug, if you setup a hotspot on wired interface and put external AP like TP-LINK or any other brand the client device will work for a few minutes then it stop to work properly, can't reproduce this issue on v6. The affected device is RB4011 this issue has been ignored by support honestly

@MT this is a common scenario please include this in your smoke test before releasing code in the wild
I have the same problem on all 7 series, now I have to switch back to 6.

FYI: My device is RB3011UiAS
 
Matrix64
just joined
Posts: 4
Joined: Thu Apr 18, 2019 11:37 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 10:10 am

I just upgraded from 7.1.1 and some of my firewall rules were reordered again (it has happened before on v7). Additionally some filter and all NAT rules were deleted, so the Internet stopped working on LAN. Really buggy behavior. My device is x86.
 
RyperX
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Thu May 21, 2015 11:14 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 10:53 am

Upgraded rb2011 / rb5011 from 7.1.1 to 7.1.2

Lost on both devices part from my config (firewall rules for example), restored config backup and worked again.
DHCP on rb5011 worked only after 2 reboots.
 
tri
just joined
Posts: 14
Joined: Tue Sep 01, 2015 6:23 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 11:01 am

CHR no longer boots after 7.1.2 update in Hetzner cloud. Rolled back to 7.1.1 snapshot which works as well as it used to.

Have you removed some disk driver along the way? And why on earth between minor versions and without a notice?

Edit: FYI disk-related kernel output from a generic linux box running in the similar VPS:
SCSI subsystem initialized
libata version 3.00 loaded.
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 246)
ata_piix 0000:00:01.1: version 2.13
scsi host0: Virtio SCSI HBA
scsi 0:0:0:0: Direct-Access QEMU QEMU HARDDISK 2.5+ PQ: 0 ANSI: 5
scsi host1: ata_piix
sd 0:0:0:0: Attached scsi generic sg0 type 0
scsi host2: ata_piix
ata1: PATA max MWDMA2 cmd 0x1f0 ctl 0x3f6 bmdma 0xc0c0 irq 14
ata2: PATA max MWDMA2 cmd 0x170 ctl 0x376 bmdma 0xc0c8 irq 15
Attached SCSI disk
ata2.01: NODEV after polling detection
ata2.00: ATAPI: QEMU DVD-ROM, 2.5+, max UDMA/100
scsi 2:0:0:0: CD-ROM QEMU QEMU DVD-ROM 2.5+ PQ: 0 ANSI: 5
scsi 2:0:0:0: Attached scsi generic sg1 type 5
r 2:0:0:0: [sr0] scsi3-mmc drive: 4x/4x cd/rw xa/form2 tray
r 2:0:0:0: Attached scsi CD-ROM sr0
Last edited by tri on Fri Feb 11, 2022 11:42 am, edited 1 time in total.
 
Kindis
Member
Member
Posts: 416
Joined: Tue Nov 01, 2011 6:54 pm
Location: Sweden

Re: v7.1.2 is released!

Fri Feb 11, 2022 11:14 am

A bit worried about 3011 reports here. Anyone who have updated a 3011 including the firmware as well without issues?
 
monotsc
just joined
Posts: 1
Joined: Sat Jun 30, 2018 7:15 am
Location: indonesia

Re: v7.1.2 is released!

Fri Feb 11, 2022 11:15 am

just some reminder before using v7....
1. always use netinstall, dont use upgrade from v6
2. reconfigure from scratch or import .rsc file, dont use restore .backup file
 
azazel
just joined
Posts: 2
Joined: Fri May 08, 2020 4:40 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 12:52 pm

still can not detect usb serial port on ros 7.1.2
 
nijol90363
just joined
Posts: 5
Joined: Tue Aug 18, 2020 10:31 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 1:03 pm

I sacrificed one RB333 and it's not good. After upgrade from 6.49.2 it fails to boot with same "kernel out of range" as yours. It can be fixed by upgrading firmware as described in v7.1beta4 on RB600A thread (RB333 is mpc8323; I used upgrade over serial port, since the board was already bricked), and then it boots. Problem is, after that, all ethernet ports are dead, autonegotiation is successful, it's connected at 100M full duplex, I see rx traffic, but zero tx, router doesn't send anything, no matter what I do.
Interesting. In my case it responded to ping, but couldn't make a TCP connection. I downgraded the bootloader to 6.49.2, but it no longer boots from network. It gets the IP address and then fails with "failed to resolve mac address". In tcpdump I can see it's sending ARP requests, but not receiving the responses.

Edit: downgrading to 2.18 fixed it
Last edited by nijol90363 on Fri Feb 11, 2022 1:38 pm, edited 1 time in total.
 
User avatar
arnaldo
newbie
Posts: 27
Joined: Wed Sep 21, 2016 2:38 am
Location: localhost.localdomain

Re: v7.1.2 is released!

Fri Feb 11, 2022 1:27 pm

Just found out that OpenVPN server is not working in 7.1.2.
 
Spidermila
just joined
Posts: 8
Joined: Wed May 19, 2021 12:37 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 2:12 pm

I have upgraded my 3011UiAS and it got stuck in a boot loop. I had to go back to 7.1.1 using NetInstall. Now I am afraid to upgrade any other devices that I manage. I will wait for the next version.

p.s. I recommend to use cloud backup or download your backup file to your PC before upgrade. This was the first time I have used NetInstall and I've learned that it wipes the disk, so all local backup files were lost. Luckily I had a reasonably old backup in the cloud.
 
Note
Frequent Visitor
Frequent Visitor
Posts: 78
Joined: Fri Jun 03, 2016 12:39 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 2:19 pm

Just an advice for mikrotik people......

If u r not able to release something thats works flawlesly from 6 to 7 and without any problems, just do not bother to do that. Keep in mind that there r people that they use the machines in work environment and they do not want to be beta rc or other kind of testers.

You r the only company that u do that in every release. Im sorry that u keep the level of responsibility in such a low height.

That was a friendly advice if u can understand it............
 
mkx
Forum Guru
Forum Guru
Posts: 7871
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 2:36 pm

There are two failures from Mikrotik in this regard:
  1. they are releasing devices unable to run a really stable ROS (e.g. 6.49)
  2. they made ROS v7 available but didn't really indicate that there's functionallity missing and that there are bugs

But you can't claim anybody is forcing you to install beta or rc software. Or can you?

It's not exactly trivial to upgrade from 6.49 to 7.x ... if your device is set to "long term" channel, then 7.x won't be offered to you for upgrade. And if you're concerned about your network stability, then you should be on "long term" chanbel, nothing else. If you decide to go forward and install something on your device other than suggested via normal channels/interface, then it's your decission and if things break, you keep the pieces.
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 12000
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: v7.1.2 is released!

Fri Feb 11, 2022 2:46 pm

Amen brother, I am a homeowner and my CCR1009 is still at long term 6.48. I wont experiment on the family, been there done that, not worth it. Boggles my mind someone would experiment at a business location.
 
User avatar
andkar
newbie
Posts: 26
Joined: Tue Aug 11, 2020 9:20 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 3:02 pm

I run Long-Term at customer sites and upgrade only after LAB testing. At home I run stable (party testing). That said I did not expect a boot loop going from 7.1.1 to 7.1.2 (minor version upgrade).


Edited: Corrected from "Stable" to "Long-Term" at customer....
Last edited by andkar on Fri Feb 11, 2022 6:08 pm, edited 1 time in total.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Fri Feb 11, 2022 3:19 pm

I do see some strange on a 750Gr3 running 6.49.2
When I select upgrade, it shows 7.1.2 That is ok.
But when I select testing, it shows 7.1.1???
Why would some one install 7.1.1 when 7.1.2 on the same train is released?

7.2.rc2 is not shown in any of the channels.
Development gives ERROR: file not found.
 
rpingar
Long time Member
Long time Member
Posts: 586
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1.2 is released!

Fri Feb 11, 2022 3:28 pm

dhcp-server or dhcp-relay on vlan interface still not working on X86 with intel i350 nic since v.7 first release
try to set tx and rx flow control to AUTO, we find it helps with intel interface.

regards
Ros
 
infabo
Member Candidate
Member Candidate
Posts: 297
Joined: Thu Nov 12, 2020 12:07 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 4:14 pm

I know that it was not mentioned in the changelog, but: why is `/export` still hanging and vomiting errors on a 7.1.2 stable release? The particular device was netinstalled with 7.1.1 and reset multiple times. This is vanilla/clean as it can get. But still all these errors in the export, which slows it down to like never ending story. On a stable version. Stable!
# feb/11/2022 13:16:53 by RouterOS 7.1.2
# software id = AUYL-X4PA
#
# model = RB941-2nD
# serial number = xxx
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
    country=austria disabled=no installation=indoor mode=station-pseudobridge \
    ssid=jupiter wireless-protocol=802.11
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk group-ciphers=\
    tkip,aes-ccm mode=dynamic-keys supplicant-identity=MikroTik \
    unicast-ciphers=tkip,aes-ccm
#error exporting /mpls/traffic-eng/path
#error exporting /routing/bgp/template
#error exporting /routing/pimsm/instance
/interface bridge filter
add action=drop chain=input dst-port=68 in-interface=!wlan1 ip-protocol=udp \
    mac-protocol=ip
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface list member
add interface=wlan1 list=WAN
add list=LAN
add interface=ether1 list=LAN
add interface=ether2 list=LAN
add interface=ether3 list=LAN
add interface=ether4 list=LAN
#error exporting /interface/vpls/bgp-vpls
/ip dhcp-client
add interface=bridge1
/ip service
set telnet address=192.168.0.0/24 disabled=yes
set ftp address=192.168.0.0/24 disabled=yes
set www address=192.168.0.0/24 disabled=yes
set ssh address=192.168.0.0/24
set www-ssl address=192.168.0.0/24
set api address=192.168.0.0/24 disabled=yes
set winbox address=192.168.0.0/24
set api-ssl address=192.168.0.0/24 disabled=yes
#error exporting /mpls/interface
#error exporting /mpls/ldp
#error exporting /mpls/ldp/accept-filter
#error exporting /mpls/ldp/advertise-filter
#error exporting /mpls/ldp/interface
#error exporting /mpls/ldp/local-mapping
#error exporting /mpls/ldp/neighbor
#error exporting /mpls/ldp/remote-mapping
#error exporting /mpls/traffic-eng/interface
#error exporting /mpls/traffic-eng/tunnel
#error exporting /routing/bgp/connection
#error exporting /routing/bgp/vpn
#error exporting /routing/pimsm/bsr/candidate
#error exporting /routing/pimsm/bsr/rp-candidate
#error exporting /routing/pimsm/interface-template
#error exporting /routing/pimsm/static-rp
/system clock
set time-zone-name=Europe/Vienna
/system identity
set name=tv-cpe
/system routerboard settings
set auto-upgrade=yes
Started 13:16, finished now 16:40. 3,5 hours - what can be so hard? CPU is idle. So it is not a CPU thing. So ridiculous.
Last edited by infabo on Fri Feb 11, 2022 5:41 pm, edited 1 time in total.
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 5:26 pm

A bit worried about 3011 reports here. Anyone who have updated a 3011 including the firmware as well without issues?
We should have some 3011 kicking around.. is there any special config to test?
 
Kindis
Member
Member
Posts: 416
Joined: Tue Nov 01, 2011 6:54 pm
Location: Sweden

Re: v7.1.2 is released!

Fri Feb 11, 2022 7:25 pm

Just a bit worrying that more then one said their 3011 dies after upgrade and specifically firmware (router boot).
I just did not feel like netinstalling today so if someone know that 7.1.2 with same firmware do not cause a issue I might try this out this weekend.
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 7:59 pm

seems adding a new VPLS the VPLS ID field in winbox wont take any normal input (ie 1:1 or 22:22), says "address expected!"

EDIT - this is with previous and current winbox as well as webfig
EDIT - SOLVED - put an & in front.. (ie; &1:1 or &22:22) in the field
Last edited by nexusds on Fri Feb 11, 2022 8:56 pm, edited 1 time in total.
 
User avatar
yasuhiro
Posts: 0
Joined: Fri Feb 11, 2022 8:11 pm

Re: v7.1.2 is released!

Fri Feb 11, 2022 8:48 pm

I have tried upgrading on 3 devices.

1. RB450Gx4 no issues arise (currently)
2. On hAP Mini, Device always restarts (version 7.1.1, which when CPU always Reach 100%) is this solved in version 7.1.2?
3. On RB951G-2HnD, After upgrading via Netinstall, there is a bug in Simple Queue. has this been resolved too? (as of version 7.1.2)
Last edited by yasuhiro on Fri Feb 11, 2022 9:07 pm, edited 1 time in total.
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 9:04 pm

Just a bit worrying that more then one said their 3011 dies after upgrade and specifically firmware (router boot).
I just did not feel like netinstalling today so if someone know that 7.1.2 with same firmware do not cause a issue I might try this out this weekend.
Yes, had this issue on firmware upgrade only.. then did a reset (i think - when winbox did connect via MAC a lot of things were blank) and restore config and was fine. not recommending upgrading at all if you are doing remote.
 
ormandj
just joined
Posts: 6
Joined: Tue Jun 15, 2021 12:25 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 9:11 pm

I had the common issue where router board firmware update required a hard power cycle, after which point, the device booted normally, with the upgraded firmware, on a CRS328-24P-4S+.

Also, I can confirm, the SFP+ NIC flapping is still occurring on 7.1.2. I didn't see release notes about it, but I sure hoped it was resolved..: SUP-68278
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Fri Feb 11, 2022 11:34 pm

I had the common issue where router board firmware update required a hard power cycle, after which point, the device booted normally, with the upgraded firmware, on a CRS328-24P-4S+.

Also, I can confirm, the SFP+ NIC flapping is still occurring on 7.1.2. I didn't see release notes about it, but I sure hoped it was resolved..: SUP-68278
did your log show loop protect or any else? do you have the ethernet hard coded or auto?
 
User avatar
amb3r
just joined
Posts: 7
Joined: Fri Oct 31, 2014 8:35 am

Re: v7.1.2 is released!

Sat Feb 12, 2022 4:43 am

openvpn not working, webproxy redirect still not working. hotspot portal not showing if client is forced disconnect (need to disable/enable hotspot server)
 
bda
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Sep 03, 2010 11:07 am

Re: v7.1.2 is released!

Sat Feb 12, 2022 11:47 am

OpenVPN still crash and reboot CCR1009-7G with only one user. Same as ROS 7.1.1... Very bad...
 
prawira
Trainer
Trainer
Posts: 341
Joined: Fri Feb 10, 2006 5:11 am

Re: v7.1.2 is released!

Sat Feb 12, 2022 1:23 pm

hi emils,

upgrade to v7.1.2 and stil having the same problem like v7.1.1

i am using hap-mini / RB931-2nD

1. mac-winbox show nothing IF the interface on the router has no ip address OR the windows ethernet port setting obtain automatically. the setting is allowed from any interfaces
[admin@MikroTik] > tool/mac-server/mac-winbox/print 
  allowed-interface-list: all

2. export take forever and end-up with nothing

3. mpls giving and error
[admin@MikroTik] > ip/address/print 
Columns: ADDRESS, NETWORK, INTERFACE
# ADDRESS         NETWORK      INTERFACE
0 172.16.1.2/32   172.16.1.2   loopback 
1 10.1.1.2/30     10.1.1.0     ether1   
2 192.168.2.1/29  192.168.2.0  ether2   
3 10.1.2.1/30     10.1.2.0     ether3   
[admin@MikroTik] > mpls/ldp/add lsr-id=172.16.1.2
action timed out - try again, if error continues contact MikroTik support and send a supout file (13)

Make supout.rif take forever as well while the router cpu only 4%

P
 
User avatar
colinardo
just joined
Posts: 10
Joined: Sun Jan 08, 2017 9:02 pm

Re: v7.1.2 is released!

Sat Feb 12, 2022 4:36 pm

1. mac-winbox show nothing IF the interface on the router has no ip address OR the windows ethernet port setting obtain automatically. the setting is allowed from any interfaces
[admin@MikroTik] > tool/mac-server/mac-winbox/print 
  allowed-interface-list: all
Hi, is neighbor discovery enabled for the interfaces and protocol mndp ? Without this enabled the device will not show in winbox discovery tab
/ip neighbor discovery-settings 
set discover-interface-list=all
set protocol=cdp,lldp,mndp

Here MAC-Server and neighbor discovery works without problems on 7.1.2 and current Winbox Version 3.33.

Regards @colinardo
 
woodych
just joined
Posts: 12
Joined: Fri Nov 12, 2021 7:09 pm

Re: v7.1.2 is released! => CCR1009 stuck in boot loop

Sat Feb 12, 2022 9:56 pm

Well of course this happens when I am away in holidays.

I had an autoupdate script active. CCR1009 upgraded from 7.1.1. to 7.1.2 and my home hosted services were - offline.
Tonight I am back from holidays and find the CCR1009 crashes and bootes while loading the kernel.

Come on Microtik. You did test that release prior to publish it? Right?

I have not yet managed to revive it. But luckily I had an RB760iGS with a config about a year old which sort-of still works.

Will examine the issue tomorrow.
 
forestarean
just joined
Posts: 2
Joined: Sat Feb 12, 2022 10:08 pm

Re: v7.1.2 is released!

Sat Feb 12, 2022 10:12 pm

My RB3011 and RB1100AHx4 are working fine after the update, including OpenVPN. I just didn't upgrade the firmware on RB3011, having been warned here.
 
mkx
Forum Guru
Forum Guru
Posts: 7871
Joined: Thu Mar 03, 2016 10:23 pm

Re: v7.1.2 is released! => CCR1009 stuck in boot loop

Sat Feb 12, 2022 10:21 pm

I had an autoupdate script active. CCR1009 upgraded from 7.1.1. to 7.1.2 ...

Come on Microtik. You did test that release prior to publish it? Right?

I was about to write something about ROS v7 and autoupdate script running on same device ... but I forgot what. Was it that this is a really stupid thing to do? Dunno ...
 
troffasky
Member
Member
Posts: 430
Joined: Wed Mar 26, 2014 4:37 pm

Re: v7.1.2 is released! => CCR1009 stuck in boot loop

Sun Feb 13, 2022 12:36 am

Well of course this happens when I am away in holidays.
You need to add to your "going away on holiday" checklist, right after "cancel the milk", an entry saying "Disable ****ing script that updates my router without me there to test it".
 
ormandj
just joined
Posts: 6
Joined: Tue Jun 15, 2021 12:25 am

Re: v7.1.2 is released!

Sun Feb 13, 2022 1:29 am

I had the common issue where router board firmware update required a hard power cycle, after which point, the device booted normally, with the upgraded firmware, on a CRS328-24P-4S+.

Also, I can confirm, the SFP+ NIC flapping is still occurring on 7.1.2. I didn't see release notes about it, but I sure hoped it was resolved..: SUP-68278
did your log show loop protect or any else? do you have the ethernet hard coded or auto?
Didn’t check log for the problem, was headed out the door. SFP+s flap every 5 minutes when not set to 1G forced, only happens at 10G. Set to 1G the links stay solid. No flapping on 6.x.
 
t4thfavor
just joined
Posts: 5
Joined: Tue Apr 13, 2021 4:40 pm

Re: v7.1.2 is released!

Sun Feb 13, 2022 5:20 am

Upgraded from 6.49.x to 7.1.1 finally, moved Openvpn server there, upgraded to 7.1.2 because it's a .1 release, Openvpn is now DOA, and I can't properly export my certificates anymore (Just the cer comes out, and no key, no matter what I do with the password). I have to go back to the hex on 7.1.1 I guess until I can downgrade my 4011.
 
jaytcsd
Member
Member
Posts: 323
Joined: Wed Dec 29, 2004 9:50 am
Location: Pittsboro IN
Contact:

Re: v7.1.2 is released!

Sun Feb 13, 2022 7:09 am

Both my hAP ac routers upgraded but lost their wireguard links to each other.
 
woodych
just joined
Posts: 12
Joined: Fri Nov 12, 2021 7:09 pm

Re: v7.1.2 is released! => CCR1009 stuck in boot loop

Sun Feb 13, 2022 9:10 am

[/quote]
You need to add to your "going away on holiday" checklist, right after "cancel the milk", an entry saying "Disable ****ing script that updates my router without me there to test it".
[/quote]
Learning the hard way....

Post Mortem analysis:


RouterBOOT booter 7.1

CCR1009-7G-1C-1S+

CPU frequency: 1200 MHz
Memory size: 2048 MiB
NAND size: 128 MiB

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Could not mount ubifs/yaffs filesystem: No such device
[ 9.149142] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000
[ 9.149246] CPU: 5 PID: 1 Comm: init Not tainted 5.6.3 #1
[ 9.149299] frame 0: __schedule+0x12288/0x7e10f8 (sp 0xfffffe007a70fb20)
[ 9.151329] frame 1: __schedule+0x7bb3b8/0x7e10f8 (sp 0xfffffe007a70fb90)
[ 9.158988] frame 2: __schedule+0x3ca50/0x7e10f8 (sp 0xfffffe007a70fbc0)
[ 9.166550] frame 3: __schedule+0x40ca0/0x7e10f8 (sp 0xfffffe007a70fc80)
[ 9.174113] frame 4: __schedule+0x431a8/0x7e10f8 (sp 0xfffffe007a70fd20)
[ 9.181676] frame 5: __schedule+0x43270/0x7e10f8 (sp 0xfffffe007a70fd60)
[ 9.189239] frame 6: __schedule+0x7de940/0x7e10f8 (sp 0xfffffe007a70fd80)
[ 9.196895] <syscall 94 while in user mode>
[ 9.201729] frame 7: 0x45040 (sp 0x7fcefb30)
[ 9.206576] Rebooting in 5 seconds..
Resetting chip and restarting.
logo.bmp not found or data is corrupted
 
rpingar
Long time Member
Long time Member
Posts: 586
Joined: Fri May 28, 2004 2:46 pm
Location: Italy

Re: v7.1.2 is released!

Sun Feb 13, 2022 10:04 am

ICMP issue after ~30hours of operation still present on x86 and chr.
ticket [SUP-67221] updated with the supout generated during the issue.

regards
Ros
 
chojrak11
Member Candidate
Member Candidate
Posts: 129
Joined: Sun Apr 05, 2009 10:37 am

Re: v7.1.2 is released!

Sun Feb 13, 2022 12:30 pm

Both my hAP ac routers upgraded but lost their wireguard links to each other.
Were you able to restore the links by manually re-adding them?
 
HighTech
just joined
Posts: 3
Joined: Fri Feb 22, 2019 2:26 pm

Re: v7.1.2 is released!

Sun Feb 13, 2022 12:34 pm

Just a Warning do not upgrade from v7.1.1 to v7.1.2 on CHR
If you have more then 1 interface type, it will change all interfaces and delete configuration.

It changed my form ether 1,2,3,4,6 so it is now: ether 4,6,1,2,3
All configuration is gone and i have to reconfigure all from backup
 
nicolap
just joined
Posts: 5
Joined: Mon Sep 09, 2019 12:16 am

Re: v7.1.2 is released!

Sun Feb 13, 2022 12:58 pm

Hi all,
upgraded a hAP lite RB941-2nD to 7.1.2. The problem with export remains:
export terse show-sensitive file=haplite20220213
take some hours!
 
biomesh
Member
Member
Posts: 460
Joined: Fri Feb 10, 2012 8:25 pm

Re: v7.1.2 is released! => CCR1009 stuck in boot loop

Sun Feb 13, 2022 2:53 pm

Learning the hard way....

Post Mortem analysis:

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Could not mount ubifs/yaffs filesystem: No such device
This just means you need to netinstall. This is a random issue seen at least on the ccr1009 devices with different 7.x updates.
 
indy
just joined
Posts: 11
Joined: Sun Mar 22, 2020 10:17 pm

Re: v7.1.2 is released!

Sun Feb 13, 2022 9:57 pm

RB3011 updated from 7.1.1 to 7.1.2 (without the firmware).
Unfortunately the high CPU usage is still a problem.
 
cjmaxik
just joined
Posts: 1
Joined: Thu Sep 09, 2021 9:27 pm

Re: v7.1.2 is released!

Sun Feb 13, 2022 10:54 pm

Half of my config is gone... Thank you for the "stable" update.
 
coolalexg
Posts: 0
Joined: Thu Dec 07, 2017 10:13 am

Re: v7.1.2 is released!

Sun Feb 13, 2022 11:51 pm

rb4011 rev.2 without wifi.

uPnP crashes after few minutes of work. Only reboot helps to work for another few minutes. 6.49.2 the same... Mikrotik become not discoverable by upnp clients, generated dst-nat rules stay in nat table until reboot or until manual delete.
 
User avatar
loloski
Member Candidate
Member Candidate
Posts: 127
Joined: Mon Mar 15, 2021 9:10 pm

Re: v7.1.2 is released!

Mon Feb 14, 2022 12:44 am

repartition is not working on RB5009 after reboot the partition still the same as before, but it's working on RB4011 weird
 
gigabyte091
Member Candidate
Member Candidate
Posts: 123
Joined: Fri Dec 31, 2021 11:44 am

Re: v7.1.2 is released!

Mon Feb 14, 2022 7:19 am

hEX S (RB760iGS) and cAP ac (RBcAPGi-5acD2nD) working fine for now, CPU usage is the same, memory usage is about 5 MiB less. CAPsMAN working fine.
 
ElNecio
just joined
Posts: 6
Joined: Thu Nov 04, 2010 2:55 pm

Re: v7.1.2 is released!

Mon Feb 14, 2022 10:32 am

RB1100AHx2(powerpc), after upgrade from 7.1.1 to 7.1.2 lost all bridge interfaces and 6to4 tunnels. Network inoperative until site visit to locally connect to device.
 
User avatar
Ullinator
just joined
Posts: 3
Joined: Tue Jun 08, 2021 12:53 pm
Location: North-West Germany

Re: v7.1.2 is released!

Mon Feb 14, 2022 11:00 am

CAPsMAN in ROS 7 (and even 6.49.2 is not usable) is a catastrophy. Regardless if I use 7.0.5, 7.1.1, 7.1.2 or 7.2RCX, in every ROS version I found a full hand of bugs.
I´ve configured all from scratch (no config update from ROS 6.X), but nothing worked.
The errors are:
- no DHCP leases
- no traffic from or to the CAPs after a few minutes
- no traffic from or to the CAPsMAN after a few minutes
- unregulary disconnects from the WLAN every 10-60 sec. (with a bunch of devices)
The config was not really complicate, only 2 vLANS and 5 CAPs with auto-Provisioning. DHCP for LAN is served from a Windows Server, the GUEST DHCP comes from the MT router.

After netinstall 6.48.6 and recreate the config from scratch everything is working again without problems.
(The config within ROS 6 and 7 was exactly the same.)
It was a really nightmare weekend... :-(
 
mafiosa
Member Candidate
Member Candidate
Posts: 240
Joined: Fri Dec 09, 2016 8:10 pm
Location: Kolkata, India
Contact:

Re: v7.1.2 is released!

Mon Feb 14, 2022 2:17 pm

IDK why mikrotik can't fix the god damn IPv6 torch function.
 
hecatae
Member Candidate
Member Candidate
Posts: 139
Joined: Thu May 21, 2020 2:34 pm

Re: v7.1.2 is released!

Mon Feb 14, 2022 4:31 pm

Remote Ping Latency on 7.1.2 vs 7.2rc3 is up about 6 milliseconds:
Image

Had to go back to 7.2rc3, unsure what's causing latency on ping to jump from 9 milliseconds to 15 milliseconds.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Mon Feb 14, 2022 8:30 pm

Ping from where to where? If its over internet you do not have much control.
What do you get when you ping from a device connected to the router, to the router? Did that go up?
 
User avatar
npeca75
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Thu Aug 03, 2017 3:12 pm

Re: v7.1.2 is released!

Mon Feb 14, 2022 10:40 pm

7.1.2, CHR
SNMP readout constantly flood my LibreNMS with errors on WG IF

.1.3.6.1.2.1.2.2.1.2.12 = STRING: "WG: Android"
.1.3.6.1.2.1.2.2.1.2.13 = STRING: "WG: Asus"
.1.3.6.1.2.1.2.2.1.2.14 = STRING: "WG: Dell"
.1.3.6.1.2.1.2.2.1.2.15 = STRING: "WG: Lenovo"
.1.3.6.1.2.1.2.2.1.2.16 = STRING: "WG: SoLaptop"
.1.3.6.1.2.1.2.2.1.2.17 = STRING: "WG: SoNms"
.1.3.6.1.2.1.2.2.1.2.18 = STRING: "WG: SoSrvB"

.1.3.6.1.2.1.2.2.1.20.12 = Counter32: 47394
.1.3.6.1.2.1.2.2.1.20.13 = Counter32: 47394
.1.3.6.1.2.1.2.2.1.20.14 = Counter32: 47394
.1.3.6.1.2.1.2.2.1.20.15 = Counter32: 47394
.1.3.6.1.2.1.2.2.1.20.16 = Counter32: 47394
.1.3.6.1.2.1.2.2.1.20.17 = Counter32: 47394
.1.3.6.1.2.1.2.2.1.20.18 = Counter32: 47394


well, thank you Mikrotik for stable release
 
brloomis
Posts: 0
Joined: Fri Nov 15, 2019 7:40 pm

Re: v7.1.2 is released!

Mon Feb 14, 2022 10:53 pm

LTE with a USB-connected AirCard 340U seems to have stopped working on my hAP / RB951Ui-2nD after upgrading to 7.1.2, the interface just disappeared.
Same result on 7.2rc3. Downgrading back to 7.1.1 restores it.
 
mhugo
Member Candidate
Member Candidate
Posts: 171
Joined: Mon Sep 19, 2005 11:48 am

Re: v7.1.2 is released!

Tue Feb 15, 2022 2:04 am

If u r not able to release something thats works flawlesly from 6 to 7 and without any problems, just do not bother to do that. Keep in mind that there r people that they use the machines in work environment and they do not want to be beta rc or other kind of testers.
I have 20+ boxes running 7.1.1 and 7.1.2 in full production with full BGP feeds. We see issues with 6.x on BGP that were solved with rolling out 7.x. Things like routers crashing ospf when full feed neighbour went dont.

We have 500+ mikrotiks in production.

I do agree that its not really awesome release quality but expecting flawless is not realistic, and 7.x gave me big value over 6.x

/Mikael
 
nexusds
newbie
Posts: 27
Joined: Fri Aug 16, 2019 6:51 am

Re: v7.1.2 is released!

Tue Feb 15, 2022 5:56 am

"I have 20+ boxes running 7.1.1 and 7.1.2 in full production with full BGP feeds. We see issues with 6.x on BGP that were solved with rolling out 7.x. Things like routers crashing ospf when full feed neighbour went dont."

Which units did you upgrade using full BGP and was it seemless upgrade - (im still getting used to the new terminology before I upgrade)?
 
mhugo
Member Candidate
Member Candidate
Posts: 171
Joined: Mon Sep 19, 2005 11:48 am

Re: v7.1.2 is released!

Tue Feb 15, 2022 4:51 pm

Which units did you upgrade using full BGP and was it seemless upgrade - (im still getting used to the new terminology before I upgrade)?
1036, 1072 and 2004s. Its was not seamless - We had to rewrite some of the bgp filters and make some smaller adjustments.

/Mikael
 
dominicbatty
Member Candidate
Member Candidate
Posts: 100
Joined: Wed Jul 07, 2010 12:26 pm

Re: v7.1.2 is released!

Tue Feb 15, 2022 4:56 pm

We have been testing 7.1.2 on a CCR1009-7G-1C-1S+ device for the last few days and other than the change to the TLS command notation on the /tool e-mail function in v7 the device has been stable. However, we have noticed that some but not all of our IPSEC links, are showing as up and established but will not route any traffic.

MikroTik to MikroTik links appear to be fine but links to our Azure Cloud services and some of our customers just won't work at all, even through they appear to be in sync and not reporting any issues in the winbox application. Has anyone experienced anything similar in this area? Our configuration in our backup device is identical to this but running on v6.49.2 and as soon as we switch back to this device everything works fine again.

Thanks, Dominic.
 
mane
just joined
Posts: 1
Joined: Tue Feb 15, 2022 10:31 pm
Location: Italy

Re: v7.1.2 is released!

Tue Feb 15, 2022 10:41 pm

Hi Everyone

Today i upgraded my hap ac3 to 7.1.2 and started using the wave2 package. Now i'm getting
MAC@wifi1 connected, signal strength -73
MAC@wifi1 disconnected, key handshake failure, signal strength -73
when i try to connect from smartphones, while it works fine when connecting using computers and IP cameras.
# feb/15/2022 21:36:53 by RouterOS 7.1.2
# model = RBD53iG-5HacD2HnD
/interface wifiwave2 channel
add frequency=2412,2432,2472 name=ch-2ghz width=20mhz
add frequency=5180,5260,5500 name=ch-5ghz skip-dfs-channels=disabled width=20/40/80mhz
/interface wifiwave2 security
add authentication-types=wpa2-psk,wpa3-psk name=common-auth wps=disable
/interface wifiwave2 configuration
add country=Italy name=common-conf security=common-auth ssid=mywifi
/interface wifiwave2
set [ find default-name=wifi1 ] channel=ch-2ghz configuration=common-conf disabled=no
set [ find default-name=wifi2 ] channel=ch-5ghz configuration=common-conf disabled=no
add channel=ch-2ghz configuration=common-conf configuration.country=Italy .mode=ap .ssid=smarties disabled=no mac-address=MAC \
    master-interface=wifi1 name=smarties1 security=common-auth
add channel=ch-5ghz configuration=common-conf configuration.country=Italy .mode=ap .ssid=smarties disabled=no mac-address=MAC \
    master-interface=wifi2 name=smarties2 security=common-auth
 
samasd
just joined
Posts: 9
Joined: Tue Jul 30, 2019 12:37 am

Re: v7.1.2 is released!

Wed Feb 16, 2022 12:01 am

upgrade to 7.1.1 and some problem came up have to roll back all the routers to 6.49.2, now i just upgrade my home 951u , router s goes to boot loop ,reset the router restore the backup config and agian stuck in noot loop , couldnt downgrade so decide to config manually from scratch, now winbox disconnects randomly!
 
fragtion
Member Candidate
Member Candidate
Posts: 187
Joined: Fri Nov 13, 2009 10:08 pm
Location: Johannesburg, South Africa

Re: v7.1.2 is released!

Wed Feb 16, 2022 12:48 am

upgrade to 7.1.1 and some problem came up have to roll back all the routers to 6.49.2, now i just upgrade my home 951u , router s goes to boot loop ,reset the router restore the backup config and agian stuck in noot loop , couldnt downgrade so decide to config manually from scratch, now winbox disconnects randomly!
sounds like you're having a rough time :o
 
User avatar
Halfeez92
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Tue Oct 30, 2012 12:58 pm
Location: 127.0.0.1
Contact:

Re: v7.1.2 is released!

Wed Feb 16, 2022 1:28 am

I can\t delete dynamic dhcp leases. Try to click and delete but nothing happened. The leases is still there even though I deleted the dhcp setup and also the pool.
 
swenske
just joined
Posts: 13
Joined: Mon Aug 03, 2015 12:17 pm

Re: v7.1.2 is released!

Wed Feb 16, 2022 8:09 am

RB3011 only used as Capman controller, v7.1.1 no problem. Upgrade to 7.1.2 resulted in endless boot loop.
Output from console:
RouterBOOT booter 7.1.1

RB3011UiAS

CPU frequency: 1400 MHz
  Memory size: 1024 MiB
    NAND size: 128 MiB

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
opendir: No such file or directory
opendir: No such file or directory
ERROR: no system package found!
[    6.023110] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000000
[    6.023350] CPU: 0 PID: 1 Comm: init Not tainted 5.6.3 #2
[    6.030805] Hardware name: RB3011
[    6.036371] {bf05ff2c} _stext+0x97c4/0x4489f8
[    6.039663] {bf05ff34} _stext+0x4351e0/0x4489f8
[    6.044003] {bf05ff44} _stext+0x19acc/0x4489f8
[    6.048345] {bf05ff6c} _stext+0x1b8f0/0x4489f8
[    6.052855] {bf05ff84} _stext+0x1ca04/0x4489f8
[    6.057281] {bf05ff9c} _stext+0x1ca74/0x4489f8
[    6.061720] CPU1: stopping
[    6.066142] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 5.6.3 #2
[    6.068827] Hardware name: RB3011
[    6.074652] {bf091f34} _stext+0x97c4/0x4489f8
[    6.078035] {bf091f3c} _stext+0x4351e0/0x4489f8
[    6.082373] {bf091f4c} _stext+0xbf10/0x4489f8
[    6.086712] {bf091f64} _stext+0x1b4720/0x4489f8
[    6.091228] {bf091f7c} _stext+0x1acc/0x4489f8
[    6.095563] Exception stack(0xbf091f80 to 0xbf091fc8)
[    6.100104] 1f80: 000006e8 00000000 000006e8 801142a0 bf090000 00000002 80903e24 80903e60
[    6.105143] 1fa0: 4000406a 512f04d0 00000000 00000000 00000000 bf091fd0 80106f80 80106f70
[    6.113284] 1fc0: 60000013 ffffffff
[    6.121436] {bf091fcc} _stext+0x6f70/0x4489f8
[    6.124736] {bf091fd4} _stext+0x3a108/0x4489f8
[    6.129248] {bf091fec} _stext+0x3a398/0x4489f8
[    6.133587] {bf091ff4} 0x4010246c
[    6.138028] Rebooting in 5 seconds..
Netinstall next....
Same usage, same issue...
 
evbocharov
just joined
Posts: 17
Joined: Tue May 25, 2021 11:06 pm

Re: v7.1.2 is released!

Wed Feb 16, 2022 8:36 am

RB4011iGS+5HacQ2HnD-IN
Ros 7.1.2 (clean install from netinstall) + wave2
wireless not renamed - is default - wifi1
After reboot error:
08:15:49 echo: system,error,critical error while running customized default configuration script: interrupted
08:15:49 echo: system,error,critical
 
fragtion
Member Candidate
Member Candidate
Posts: 187
Joined: Fri Nov 13, 2009 10:08 pm
Location: Johannesburg, South Africa

Re: v7.1.2 is released!

Wed Feb 16, 2022 11:41 am

I can\t delete dynamic dhcp leases. Try to click and delete but nothing happened. The leases is still there even though I deleted the dhcp setup and also the pool.
I had the same problem. The error message was that the item doesn't exist. So it's a winbox bug still showing leases that no longer exist. If you close winbox and log back in you'll see those leases you tried to delete are gone
 
llpax
Posts: 0
Joined: Tue Dec 07, 2021 11:57 pm
Location: Belarus

Re: v7.1.2 is released!

Wed Feb 16, 2022 5:58 pm

RB3011 updated from 7.1.1 to 7.1.2 (without the firmware).
Unfortunately the high CPU usage is still a problem.
Thanks for information. You safe my time.
Mikrotik team don't care about the problem with RB3011 and ros7.
 
godoy
just joined
Posts: 1
Joined: Tue Dec 21, 2021 2:16 pm

Re: v7.1.2 is released!

Wed Feb 16, 2022 8:01 pm

@mhugo

I also have routers 1036 and 1072 that use OSPF and BGP.

after corrections applied, how has the performance and stability been for these models?
 
hrcho
just joined
Posts: 4
Joined: Thu Apr 12, 2018 11:29 am

Re: v7.1.2 is released!

Thu Feb 17, 2022 7:23 am

Upgrade RB4011iGS+RM from 7.1.1 to 7.1.2 drops this lines from configuration:
/interface/ethernet set [ find default-name=ether1 ] name=ether1-ISP
/interface/bridge add ...
/interface/ipip add ...
/interface/ovpn-client add ...
/interface/l2tp-client add ...
/interface/pptp-client add ...
/interface/wireguard add ...
/ppp/secret add ...
 
User avatar
ufm
Member Candidate
Member Candidate
Posts: 100
Joined: Fri Nov 15, 2013 12:02 pm
Location: Ukraine

Re: v7.1.2 is released!

Thu Feb 17, 2022 10:55 am

Just for information:
1. MLAG in 7.x is unuseable.
2. Support is also broken No reaction at all for 3 days (business days, as written on the mikrotik website).
Sadly
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: v7.1.2 is released!

Thu Feb 17, 2022 11:14 am

I have tried this release (and 7.1) on an PTP link.
After upgrade i have a lot of packet loss on nv2, but when downgrading to 6.49.2 its stable.
Any idea whats causing this?
I know nv2 is "stopping" when it sees trafick on same channel, but it should be the same on both software versions?

RB922UAGS-5HPacD with UltraHorn
Signal -51
CCQ 94-99%
2km
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Thu Feb 17, 2022 12:10 pm

In 7.2.1 (7.x) you can get Bridge Port for the IP arp list. But this seems to work only in WinBox. Is this a bug, or is it a hidden command to see it in the terminal as well? If its a bug, please fix. If I miss some, please enlighten me :)
.
BridgePort.jpg
You do not have the required permissions to view the files attached to this post.
 
mhugo
Member Candidate
Member Candidate
Posts: 171
Joined: Mon Sep 19, 2005 11:48 am

Re: v7.1.2 is released!

Thu Feb 17, 2022 12:55 pm


I also have routers 1036 and 1072 that use OSPF and BGP.

after corrections applied, how has the performance and stability been for these models?
@godoy

Up since upgrade with no issues in network purely ospf/bgp. 2004s are stable too but we see some packetloss on some of them and also on some (oddly) routing process is running quite heavy.
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2178
Joined: Mon Apr 08, 2019 1:16 am

Re: v7.1.2 is released!

Thu Feb 17, 2022 1:10 pm

I know nv2 is "stopping" when it sees trafick on same channel
Where is this documented, missed it? NV2 is not using CSMA and is not using the 802.11 clear-channel-acces and contention process. AFAIK.

https://wiki.mikrotik.com/wiki/Manual:N ... _protocols
 
fungogh
Posts: 0
Joined: Thu Jan 10, 2019 5:00 am
Location: Singapore

Re: v7.1.2 is released!

Thu Feb 17, 2022 2:54 pm

I'm unable to update hAP AC that is on 7.1.1. RB is not online at the moment so only option is Files > Reboot. I load MIPSBE version from the download section routeros-7.1.2-mipsbe.npk, update will not happen and log shows "can not install system-7.1.2: it is not made for mips, but for mmips" Tried couple times, reloaded the file, still same... It will update to 7.2rc3 from the same tree - routeros-7.2rc3-mipsbe.npk
Last edited by fungogh on Thu Feb 17, 2022 3:10 pm, edited 1 time in total.
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: v7.1.2 is released!

Thu Feb 17, 2022 3:10 pm

I'm unable to update hAP AC that is on 7.1.1. RB is not online at the moment so only option is Files > Reboot. I load MIPSBE version from the download section routeros-7.1.2-mipsbe.npk, update will not happen and log shows "can not install system-7.1.2: it is not made for mips, but for mmips" Tried couple times, reloaded the file, still same...
Seems like u are using *mmips* and not *mipsbe* ?
 
fungogh
Posts: 0
Joined: Thu Jan 10, 2019 5:00 am
Location: Singapore

Re: v7.1.2 is released!

Thu Feb 17, 2022 3:11 pm

nono, I'm using mipsbe, I have also stated that in my post...
 
lenarts
Posts: 0
Joined: Sun Dec 10, 2017 10:34 pm

Re: v7.1.2 is released!

Thu Feb 17, 2022 3:28 pm

I updated RB OmniTIK U-5HnD 6.49.2 to 7.1.2 CPU usage 100
 
langgengshl
Posts: 0
Joined: Mon Dec 27, 2021 8:38 am

Re: v7.1.2 is released!

Fri Feb 18, 2022 1:52 am

all of my pppoe server binding interfaces under vlan show tx drops "2", does anyone know about this??
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: v7.1.2 is released!

Fri Feb 18, 2022 12:17 pm

I know nv2 is "stopping" when it sees trafick on same channel
Where is this documented, missed it? NV2 is not using CSMA and is not using the 802.11 clear-channel-acces and contention process. AFAIK.

https://wiki.mikrotik.com/wiki/Manual:N ... _protocols
Im not sure where its documentet. I think I read about it on forum or atother site. But I have seen it happening when using a "crowded" channel and NV2.
Wireless trafic stops for a few ms and resumes.
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: v7.1.2 is released!

Fri Feb 18, 2022 12:18 pm

I have tried this release (and 7.1) on an PTP link.
After upgrade i have a lot of packet loss on nv2, but when downgrading to 6.49.2 its stable.
Any idea whats causing this?
I know nv2 is "stopping" when it sees trafick on same channel, but it should be the same on both software versions?

RB922UAGS-5HPacD with UltraHorn
Signal -51
CCQ 94-99%
2km
Tried this on 2 other PTP links with the same hardware, same problem.
No packet loss on 6.49.2, alot of packet loss on v7
 
User avatar
bpwl
Forum Guru
Forum Guru
Posts: 2178
Joined: Mon Apr 08, 2019 1:16 am

Re: v7.1.2 is released!

Fri Feb 18, 2022 2:46 pm

But I have seen it happening when using a "crowded" channel and NV2.
Wireless trafic stops for a few ms and resumes.
It was not in the early releases of NV2 (viewtopic.php?t=43612#p220435) , it may have been added later, but I found no sign of this.
Nstreme clearly has it, there is even an option to disable CSMA.
With nv2, destructive interference is always possible, as it transmits regardless of 802.11 or other activity.

V7 can be worse than V6, I see many different performance issues in this thread.
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: v7.1.2 is released!

Fri Feb 18, 2022 3:01 pm

But I have seen it happening when using a "crowded" channel and NV2.
Wireless trafic stops for a few ms and resumes.
It was not in the early releases of NV2 (viewtopic.php?t=43612#p220435) , it may have been added later, but I found no sign of this.
Nstreme clearly has it, there is even an option to disable CSMA.
With nv2, destructive interference is always possible, as it transmits regardless of 802.11 or other activity.

V7 can be worse than V6, I see many different performance issues in this thread.
I have seen this on many ptp links when using nv2. sometimes Nstreme is better, but slower..
Just my experience, I am sure i read someting about it somewhere, but i cant find the source..
 
Muzaki
newbie
Posts: 43
Joined: Wed May 13, 2009 3:12 pm
Contact:

Re: v7.1.2 is released!

Fri Feb 18, 2022 3:03 pm

Another problem with v7:
One client has many voip phones. After upgrade, just 1 or 2 is working at the time, and they are alternating who is working.
Downgrade, everyting is OK.

I did see that dccp, sctp and udplite was in invalide state (Firewall-Service Ports) but i dont know if this is the cause
 
radenli
just joined
Posts: 19
Joined: Tue Apr 04, 2017 10:45 am

Re: v7.1.2 is released!

Fri Feb 18, 2022 8:51 pm

I tried v7.1.2 on my HAP AC. last night.
Sadly, the wifi connection is not stable. Speed dropped frequently.
I had to downgrade back to v6.49.3 which has no issue with wifi.
 
User avatar
genesispro
Member Candidate
Member Candidate
Posts: 249
Joined: Fri Mar 14, 2014 12:33 pm

Re: v7.1.2 is released!

Sat Feb 19, 2022 10:17 am

In one of my setups I upgraded from latest 6 to 7.1.2 and I had many issues. The setup was running fine for 6+ months. Lots of ping timeouts (50% sometimes).
The main router is a CCR2004-1G-12S+2XS and the switches are CRS328-24P-4S+
After trying to figure out what was wrong it was finally solved when I downgraded all switches back to 6.49.3, the ccr2004 is still on 7.1.2
Note: I am using dot1x and bridge filtering on those switches.
I have upgraded many setups to 7.1.2 but I only had issue in this (more complex) one.
Has anyone had a similar issue?
BTW I also played enabling and disabling l3 hw offloading and it didn't help
 
mafiosa
Member Candidate
Member Candidate
Posts: 240
Joined: Fri Dec 09, 2016 8:10 pm
Location: Kolkata, India
Contact:

Re: v7.1.2 is released!

Sat Feb 19, 2022 8:16 pm

PPPoE still at 1480 MTU
 
User avatar
arnis128
just joined
Posts: 3
Joined: Mon Aug 29, 2016 1:03 pm
Location: Riga, Latvia

Re: v7.1.2 is released!

Sat Feb 19, 2022 8:30 pm

RouterOS version 7.1.2 has been released "v7 stable" channel!
*) ntp - fixed multicast mode support;
NTP server does not work as expected, the same in 7.2rc3.
The strangest thing was that the multicast server was up and running, clients were able to synchronize their clocks to 224.0.1.1, unfortunately it stopped working after a few hours. Unicast server does not work at all. Rolled back to 6.49.3.
 
User avatar
Znevna
Forum Veteran
Forum Veteran
Posts: 764
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.1.2 is released!

Sat Feb 19, 2022 9:52 pm

In 7.2.1 (7.x) you can get Bridge Port for the IP arp list. But this seems to work only in WinBox. Is this a bug, or is it a hidden command to see it in the terminal as well? If its a bug, please fix. If I miss some, please enlighten me :)
.
BridgePort.jpg
Data is probably taken from bridge/hosts.
I'd call it a WinBox feature, not a bug.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 2878
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v7.1.2 is released!

Sat Feb 19, 2022 10:20 pm

I'd call it a WinBox feature, not a bug.
Table are far from equal.
Bridge/Host has on my test router 40 entry and only mac

IP/Arp has 7 item and do include IP and MAC

I do like that Cli and WinBox show the same at same place in the same menu structure (MT are far off for the latter).
 
User avatar
Znevna
Forum Veteran
Forum Veteran
Posts: 764
Joined: Mon Sep 23, 2019 1:04 pm

Re: v7.1.2 is released!

Sat Feb 19, 2022 10:23 pm

You can match the entries in ARP to the ones in hosts if you want to script something.
Or make a feature request.
But, at least for now, on RB5009 it's better to query the bridge for data only when you seriously need to do so, because of that cpu usage bug.
 
LinuxEngineer
just joined
Posts: 7
Joined: Fri Apr 22, 2016 11:46 am
Location: United Kingdom
Contact:

Re: v7.1.2 is released!

Sat Feb 19, 2022 10:30 pm

Upgrading my RB4011 FROM 6.49.3 TO 7.1.2 using WebFig.

However, when I go to "System" > "Packages" > "Check for updates" and I chose "Channel" > "Upgrade" and then "Download & Install", it pukes the following error:

"multicast-7.1.2-arm.npk missing, use ignore-missing or disable package(s)"

My current packages for 6.49.3 are:
system package print  
Flags: X - disabled 
 #   NAME                                                                                                                    VERSION                                                                                                                   SCHEDULED              
 0   gps                                                                                                                     6.49.3                                                                                                                                           
 1   ntp                                                                                                                     6.49.3                                                                                                                                           
 2   tr069-client                                                                                                            6.49.3                                                                                                                                           
 3   user-manager                                                                                                            6.49.3                                                                                                                                           
 4   routeros-arm                                                                                                            6.49.3                                                                                                                                           
 5   system                                                                                                                  6.49.3                                                                                                                                           
 6   ipv6                                                                                                                    6.49.3                                                                                                                                           
 7   wireless                                                                                                                6.49.3                                                                                                                                           
 8   hotspot                                                                                                                 6.49.3                                                                                                                                           
 9   mpls                                                                                                                    6.49.3                                                                                                                                           
10   routing                                                                                                                 6.49.3                                                                                                                                           
11   ppp                                                                                                                     6.49.3                                                                                                                                           
12   dhcp                                                                                                                    6.49.3                                                                                                                                           
13   security                                                                                                                6.49.3                                                                                                                                           
14   advanced-tools                                                                                                          6.49.3                                                                                                                                           
15   multicast                                                                                                               6.49.3  
And I'm running the 6.49.3 firmware. So I'm as current and level as I can be. I ran "Check installation" confirms no issues.

This error appears to be telling me that the packages in the 7.1.2 download are missing "multicast-7.1.2-arm.npk".

I guess that I could get around the blocker per the suggestion in the error "use ignore-missing or disable package(s)" from the CLI, but if something is not correct, I'm thinking using a hack to upgrade when the system is refusing to upgrade due to a missing dependency is a very bad idea ;-)

Over to you MikroTik...
 
s3uz
just joined
Posts: 3
Joined: Thu Dec 30, 2021 1:40 pm

Re: v7.1.2 is released!

Sun Feb 20, 2022 3:03 pm

Waiting for docker extra package
 
ormandj
just joined
Posts: 6
Joined: Tue Jun 15, 2021 12:25 am

Re: v7.1.2 is released!

Sun Feb 20, 2022 4:44 pm

In one of my setups I upgraded from latest 6 to 7.1.2 and I had many issues. The setup was running fine for 6+ months. Lots of ping timeouts (50% sometimes).
The main router is a CCR2004-1G-12S+2XS and the switches are CRS328-24P-4S+
After trying to figure out what was wrong it was finally solved when I downgraded all switches back to 6.49.3, the ccr2004 is still on 7.1.2
Note: I am using dot1x and bridge filtering on those switches.
I have upgraded many setups to 7.1.2 but I only had issue in this (more complex) one.
Has anyone had a similar issue?
BTW I also played enabling and disabling l3 hw offloading and it didn't help
Check the logs on the switch if you test again. All of my ports were flapping at regular 5 minute intervals with 7.1 until I forced them to 1G instead of 10/auto.
 
User avatar
morphema
Posts: 0
Joined: Tue Feb 02, 2021 12:15 pm

Re: v7.1.2 is released!

Mon Feb 21, 2022 12:29 pm

Hey guys.

I don't get how the communication works with the support team. There are no answers on the forum. I created a ticket SUP-74144 on February 10 and haven't had any feedback.

Is there any ETA from your side?
 
PSz
just joined
Posts: 2
Joined: Fri May 14, 2021 6:00 pm

Re: v7.1.2 is released!

Mon Feb 21, 2022 12:38 pm

Hello,
- HAP AC - update OK 7.1.2 from 6.49.3
- CAP AC - update OK 7.1.2 from 6.49.3
- CAP AC XL - update OK 7.1.2 from 6.49.3
- WAP AC - update OK 7.1.2 from 6.49.3
- RB951G-2HnD - update OK 7.1.2 from 6.49.2 (routerboard firmware 6.47)
- RB3011UiAS on friday dead after update to 7.1.2 from 6.49.3.... (bootloop). Only repair by Netinstall will resurect router. Remember to copy the configuration. After that I'm afraid to update another RB at clients.... :(
 
Dude2048
Member Candidate
Member Candidate
Posts: 192
Joined: Thu Sep 01, 2016 4:04 pm

Re: v7.1.2 is released!

Mon Feb 21, 2022 1:16 pm

I have read it to many times. We will upgrade when we replace the units or CVE related issues.
 
User avatar
dkmj
just joined
Posts: 11
Joined: Fri Feb 15, 2013 2:23 pm

Re: v7.1.2 is released!

Mon Feb 21, 2022 2:17 pm

Newbie Q. Is RouterOS7 backwards compatible with RouterOS6? I'm hesitating to upgrade from 6.49.3. My usecase is very very basic, running one link in bridge mode to extend private LAN between buildings. My Routerboard hw is old, came with formware 2.36 way back n the day but almost every upgrade along the way has been smooth. but jumping from 6 to 7 has me anxious? for no good reason?

cheers,
Peter
 
Kindis
Member
Member
Posts: 416
Joined: Tue Nov 01, 2011 6:54 pm
Location: Sweden

Re: v7.1.2 is released!

Mon Feb 21, 2022 2:19 pm

Hello,
- HAP AC - update OK 7.1.2 from 6.49.3
- CAP AC - update OK 7.1.2 from 6.49.3
- CAP AC XL - update OK 7.1.2 from 6.49.3
- WAP AC - update OK 7.1.2 from 6.49.3
- RB951G-2HnD - update OK 7.1.2 from 6.49.2 (routerboard firmware 6.47)
- RB3011UiAS on friday dead after update to 7.1.2 from 6.49.3.... (bootloop). Only repair by Netinstall will resurect router. Remember to copy the configuration. After that I'm afraid to update another RB at clients.... :(
Yet another report of 3011 dying after upgrade to 7.1.2. I wonder if this happens both from v6 to v7 and v7 to v7.
Well I'm staying on 7.1.1 for the moment being.
 
User avatar
dkmj
just joined
Posts: 11
Joined: Fri Feb 15, 2013 2:23 pm

Re: v7.1.2 is released!

Mon Feb 21, 2022 2:19 pm

My HW is 2 identical SXT 5HnD
 
holvoetn
Forum Guru
Forum Guru
Posts: 1164
Joined: Tue Apr 13, 2021 2:14 am
Location: Belgium

Re: v7.1.2 is released!

Mon Feb 21, 2022 2:55 pm

Newbie Q. Is RouterOS7 backwards compatible with RouterOS6? I'm hesitating to upgrade from 6.49.3. My usecase is very very basic, running one link in bridge mode to extend private LAN between buildings. My Routerboard hw is old, came with formware 2.36 way back n the day but almost every upgrade along the way has been smooth. but jumping from 6 to 7 has me anxious? for no good reason?
If you have no urgent reason to use any of the new ROS7 features and everything you have now on ROS6 is sufficient for your usage, no problem to stay on ROS6.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 852
Joined: Thu Dec 11, 2014 8:53 am

Re: v7.1.2 is released!

Mon Feb 21, 2022 3:42 pm

New version v7.1.3 has been released:

viewtopic.php?t=183474

Who is online

Users browsing this forum: iddqdesnik, Panbambaryla and 10 guests