Community discussions

MikroTik App
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

A little help please

Wed Apr 06, 2022 4:50 pm

I have the following script and it works very well for me, every time the electricity is cut off it tells me in a file.txt the date and time the service was cut off.
:global stopRouterRun false;

:do {
	:local file "electric cut.txt";
	:local day ([:pick [/system clock get date] 4 6]);
	:local mon ([:pick [/system clock get date] 0 3]);
	:local year ([:pick [/system clock get date] 7 11]);
	:local date "$day-$mon-$year";
	:local time (:put [/system clock get time]);
	:local data1 ("  court: " . $date . " at: " . $time .  " ) ;
	/file print file="$file"
	/file set $file contents=$data1;

	:delay 60;
} while=(!$stopRouterRun)
I would like you to help me with a script that records in a .txt file, the time when the electrical service was restored,
but it should be taken into account that every time the electricity arrives, the internet does not arrive at the same time,
I do not know if you understand me Thanks for your help, especially Rextended and Jotne.


EL DONCITO.
 
afuchs
Frequent Visitor
Frequent Visitor
Posts: 81
Joined: Wed Jul 03, 2019 11:10 am

Re: A little help please

Wed Apr 06, 2022 5:15 pm

Have you tryed
//system scheduler add name="create _file" on-event=<your script to generate file> policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup
?
startup - execute the script 3 seconds after the system startup.
(from https://wiki.mikrotik.com/wiki/Manual:System/Scheduler)

PS: please reduce the allowed policies to what is needed.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 6:51 pm

Have you tryed
//system scheduler add name="create _file" on-event=<your script to generate file> policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup
?
startup - execute the script 3 seconds after the system startup.
(from https://wiki.mikrotik.com/wiki/Manual:System/Scheduler)

PS: please reduce the allowed policies to what is needed.


It doesn't work friend

EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 7:00 pm

Is clear that @afuchs do not read your OP....

I have the following script and it works very well for me, every time the electricity is cut off it tells me in a file.txt the date and time the service was cut off.
but you do not have history if the power go away more than one time...

add
:delay 60s
at start of the script

you can add more seconds, for the time needed to the connection go up...
Last edited by rextended on Wed Apr 06, 2022 7:11 pm, edited 3 times in total.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 7:09 pm

Is clear that @afuchs do not read your OP....

add
:delay 60s
at start of the script

you can add more seconds, for the time needed to the connection go up...


This is YOUR script fixed, with horrors, ehm..., errors removed...
:delay 60s
:global stopRouterRun false
:do {
    :local file "electric-cut.txt"
    :local data [/system clock get date]
    :local day [:pick $data 4 6]
    :local mon [:pick $data 0 3]
    :local year [:pick $data 7 11]
    :local date "$day-$mon-$year"
    :local time [/system clock get time]
    /file print file="$file"
    /file set $file contents="court: $date at: $time"
    :delay 60s
} while=(!$stopRouterRun)
Thanks for assisting me Rextended, but I need a script that creates a file.txt for me to know at what time the electrical service was restored in my RB, I hope you understand me.

EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 7:20 pm

... a script that creates a file.txt for me to know at what time the electrical service was restored in my RB ...
The routerboard need internet to setup correctly the clock, the 120s waiting is for waiting the Internet and time sync

Shedule the script to start at startup.

Keeping values of each boot
:delay 120s
:global shutname "shutdown.txt"
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6] $[/system clock get time]"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set shutname "flash/$shutname"}
:if ([:len [find where name=$shutname]] = 0) do={print file=$shutname; :delay 5s; set $shutname contents=""}
:delay 5s
:local filecontent [get $shutname contents]
:local newfilecontent "$now\r\n$filecontent"
set $shutname contents=$newfilecontent
}

Only the last
:delay 120s
:global shutname "shutdown.txt"
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6] $[/system clock get time]"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set shutname "flash/$shutname"}
:if ([:len [find where name=$shutname]] = 0) do={print file=$shutname; :delay 5s; set $shutname contents=""}
:delay 5s
set $shutname contents=$now
}

If you notice.... everytime is the same script.....
Last edited by rextended on Wed Apr 06, 2022 9:22 pm, edited 3 times in total.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 8:11 pm

... a script that creates a file.txt for me to know at what time the electrical service was restored in my RB ...
The routerboard need internet to setup correctly the clock, the 120s waiting is for waiting the Internet and time sync

Shedule this script to start at startup:
:delay 120s
:global shutname "shutdown.txt"
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6] $[/system clock get time]"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set shutname "flash/$shutname"}
:if ([:len [find where name=$shutname]] = 0) do={print file=$shutname; :delay 5s; set $shutname contents=""}
:delay 5s
:local filecontent [get $shutname contents]
:local newfilecontent "$now\r\n$filecontent"
set $shutname contents=$newfilecontent
}

If you notice.... everytime is the same script.....
Rextended, the script is overwriting the file, what I want is for it to tell me at what time the electricity was restored, and from there it stops, Wouldn't it be better to do a subtraction of the hour minus the uptime, I don't know.
Do you understand me?

EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 8:34 pm

the script keep history of shutdown (every time the script is launched...)
the file is never deleted, last bootup is added on top
do some operations, like subtract minutes, is useless, everytime the routerboard is started 120s + 3s before the date inside the script.
Why do not correct it?
For example 00:00 - 2min and 3 sec = -23:57:57, not the date of previous day, but a negative time value....
Last edited by rextended on Wed Apr 06, 2022 8:39 pm, edited 1 time in total.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 8:39 pm

the script keep history of shutdown (every time the script is launched...)


I want is for me to register, the last start of the RB and not to be overwriting the file. Thank you for your valuable collaboration.



EL DONCITO.
Last edited by eldoncito2019 on Wed Apr 06, 2022 8:44 pm, edited 1 time in total.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 8:43 pm

Ok, this create single files:
:delay 120s
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6]_$[/system clock get time]"
:local shutname "booted_$now.txt"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set shutname "flash/$shutname"}
:if ([:len [find where name=$shutname]] = 0) do={print file=$shutname; :delay 5s; set $shutname contents=""}
}

Every time the router is powered (and after 120s for make internet available and time sincronized)
a file name booted_2022-04-06_19:42:23.txt is created.
do not deplete the space because the file is empty. (really use ~64byte for each filename)
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 8:53 pm

Ok, this create single files:
:delay 120s
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6]_$[/system clock get time]"
:local shutname "booted_$now.txt"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set shutname "flash/$shutname"}
:if ([:len [find where name=$shutname]] = 0) do={print file=$shutname; :delay 5s; set $shutname contents=""}
}

Every time the router is powered (and after 120s for make internet available and time sincronized)
a file name booted_2022-04-06_19:42:23.txt is created.
do not deplete the space because the file is empty. (really use ~64byte for each filename)

Now it is creating many files, Rextended.
What I am saying is that for example we have the next time 14:10:00, and the uptime is 01:03:00, make a file for me and say that the equipment booted 13:07:00,
you understand me friend.

EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 9:18 pm

You can use the "Only the last" script at post #6:
viewtopic.php?p=924514#p924514

Why continuosly run the script?
The boot time is still the same...
Is useless every minute do the calc and write it on file, the boot time is the exact same value...
the equipment booted everytime at 13:07:00

Is better you explain what you want do at the end, instead of ask about intermediate process, because often I do not understand you...
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 9:25 pm

You can use the "Only the last" script at post #6:
viewtopic.php?p=924514#p924514

Why continuosly run the script?
The boot time is still the same...
Is useless every minute do the calc and write it on file, the boot time is the exact same value...
the equipment booted everytime at 13:07:00

Is better you explain what you want do at the end, instead of ask about intermediate process, because often I do not understand you...
I want to make a script that writes me a file.txt, where it says at what time the RB booted and leaves it like that, but we have to take into account that the internet does not arrive all at once, that's why I say that it is better to execute it every 10 minutes , you understand me friend Rextended.


EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 9:27 pm

Still the same, as long as the routerboard is not powered, it is useless to recalculate and rewrite the file...

Also, if routerboard do not have time sincronized, is useless do any calc, because can not provide any usable values.

Let me think for some seconds ...
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 9:34 pm

ok... I write one script....
just the time to fix it...
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 9:44 pm

This script must be launched at startup.
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local filename "firsttimesync.txt"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set filename "flash/$filename"}
:if ([:len [find where name=$filename]] = 0) do={print file=$filename}
:delay 5s
set $filename contents="undefined"
:do { :delay 1s } while=([:typeof [/system ntp client get last-update-before]] != "time")
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6] $[/system clock get time]"
set $filename contents=$now
}

What do: at startup replace previous datetime with "undefined", then wait until time is syncronized for first time from routerboard boot,
and write inside the file firsttimesync.txt the date and time of that moment.
Any more execution is useless.

Subtracting uptime from that datetime for obtain the precise date and time of boot is another thing...
Last edited by rextended on Wed Apr 06, 2022 10:15 pm, edited 3 times in total.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 9:57 pm

This script must be launched at startup.
:global arrMonths {jan="01";feb="02";mar="03";apr="04";may="05";jun="06";jul="07";aug="08";sep="09";oct="10";nov="11";dec="12"}
{
:local filename "firsttimesync.txt"
/file
:if ([:len [find where name="flash" and type="disk"]] = 1) do={:set filename "flash/$filename"}
:if ([:len [find where name=$filename]] = 0) do={print file=$filename}
:delay 5s
set $filename contents="undefined"
:do {
:put "X"
    :delay 10s
} while=([:typeof [/system ntp client get last-update-before]] != "time")
:local ndate [/system clock get date]
:local now "$[:pick $ndate 7 11]-$($arrMonths->[:pick $ndate 0 3])-$[:pick $ndate 4 6] $[/system clock get time]"
/file
set $filename contents=$now
}

What do: at startup replace previous datetime with "undefined", then wait until time is syncronized for first time from routerboard boot,
and write inside the file firsttimesync.txt the date and time of that moment.
Any more execution is useless.

Subtracting uptime from that datetime for obtain the precise date and time of boot is another thing...
and using this:
:global time [/system clock get time];
:local uptime [/system resource get uptime];

EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 10:03 pm

On RouterOS the variable of type datetime do not exist....
:put [:typeof [/sys clock get date]]
:put [:typeof [/sys clock get time]]
:put [:typeof [/system resource get uptime]]
the returned value for date are simply a string...
and a time for time and uptime...

working with string is like to do
:put ("useless" - "nothing")

If the time is 21:04 and your subtract uptime, for example 2 days, you simply obtain
-1d02:55:31

And you must still calculate manually the value.....
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 10:07 pm

With my script you have a great approximation when the RouterBOARD is for the first time online after (re)boot
And the value is close to last boot datetime
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 10:10 pm

On RouterOS the variable of type datetime do not exist....
:put [:typeof [/sys clock get date]]
:put [:typeof [/sys clock get time]]
:put [:typeof [/system resource get uptime]]
the returned value for date are simply a string...
and a time for time and uptime...

working with string is like to do
:put ("useless" - "nothing")

If the time is 21:04 and your subtract uptime, for example 2 days, you simply obtain
-1d02:55:31

And you must still calculate manually the value.....
So do you think the script is fine, if it writes in the file the time the routerboard booted



EL DONCITO
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 10:12 pm

not exactly when routerboard booted, but:
the value is close to last boot datetime if the RouterBOARD have Internet on reasonable time,
because it write the exact moment when RouterBOARD syncronize the time
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 10:16 pm

Please stop to reply with "reply with quote" but use the "+ Post Reply" button at the end of the page.....
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 10:19 pm

not exactly when routerboard booted, but:
the value is close to last boot datetime if the RouterBOARD have Internet on reasonable time,
because it write the exact moment when RouterBOARD syncronize the time

Let's wait to see how it works, I'll let you know when I try it, thanks friend Rextended.



EL DONCITO.
 
msatter
Forum Guru
Forum Guru
Posts: 2897
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: A little help please

Wed Apr 06, 2022 11:12 pm

WOW, there is an edit option to your posts. Just press
edit.JPG
and edit away. Please insert a text that you added content to your earlier posting.
You do not have the required permissions to view the files attached to this post.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 11:18 pm

Rextended friend, I gave the routerboard in system reboot, and nothing happened



EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 11:23 pm

WOW, there is an edit option to your posts. Just press edit.JPG and edit away. Please insert a text that you added content to your earlier posting.
This do not matter for you, I'm on your foes list and you do not see my posts, OR NOT?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 11:26 pm

Rextended friend, I gave the routerboard in system reboot, and nothing happened
Where you put the script?
You schedule it for run on startup?
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 11:37 pm

I put the script in scheduler and I put 1 minute to execute




EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 11:43 pm

as I have already write some time,
the script must be launch only at startup, or if you launch multiple time the script can have unpredicted behaviors....
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 11:45 pm

So how can I do it?



EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 11:50 pm

on scheduler select for start-time "startup" and for interval 0
0 = run only once

you have used this? or the previous?
viewtopic.php?p=924599#p924559
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Wed Apr 06, 2022 11:54 pm

where is run only once.



EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 11:57 pm

A detail than I have omitted: is for ROS 6.48.6 (must work for 6.44.6 and up)
NTP separate packages must not be installed
And System / SNTP Client must be enabled and with set at least one server SNTP
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Wed Apr 06, 2022 11:58 pm

where is run only once.
sometime is like you do not read my post...

0 = run only once
mean that if you specify 0 as interval..... the scheduled script is runned only one time....
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Thu Apr 07, 2022 12:00 am

I have version 6.49.4, there it is not necessary to have SNTP Client enabled



EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 12:01 am

if you do not enable it, and set at least one working server,
my script do not work, because do not know if the time is syncronized or not
>>> [/system ntp client get last-update-before] <<<
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Thu Apr 07, 2022 12:08 am

I have version 6.49.4, and the time is automatically synchronized, the SNTP CLIENT is not necessary

which SNTP servers do you have configured in your RB, give them to me to see if they work for me in mine.



EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 12:12 am

pool.ntp.org
Last edited by rextended on Thu Apr 07, 2022 12:15 am, edited 3 times in total.
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Thu Apr 07, 2022 12:13 am

Let's see if it works dear friend

By the way, what command should I use to get out of this?
[admin@CYBER ENK\B4AS] /system script>



EL DONCITO.
Last edited by eldoncito2019 on Thu Apr 07, 2022 12:16 am, edited 2 times in total.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 12:14 am

generic pool.ntp.org do not work on some versions, put directly the IP
193.204.114.232
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 12:16 am

By the way, what command should I use to get out of this?
[admin@CYBER ENK\B4AS] /system script>
EL DONCITO.
quit?
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Thu Apr 07, 2022 12:19 am

give me the IP

where is quit



EL DONCITO.
Last edited by eldoncito2019 on Thu Apr 07, 2022 12:21 am, edited 2 times in total.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 12:20 am

193.204.114.232
 
eldoncito2019
Member
Member
Topic Author
Posts: 333
Joined: Fri Jun 14, 2019 1:07 pm

Re: A little help please

Thu Apr 07, 2022 12:57 am

and if we use
/system clock get time
instead of

/system ntp client get last-update-before


EL DONCITO.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 1:03 am

your business
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11982
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: A little help please

Thu Apr 07, 2022 1:07 am

For sure you obtain a time, and the file is generated just when booted, but contain everytime 00:00:10 or something like this,
because when just booted, the clock start at 00:00:00 and [/system clock get time] everytime return a value, syncronized or not.

I do not want to stay on this game.
One thing is help, one thing is teaching

Who is online

Users browsing this forum: marcelofares and 22 guests