Community discussions

MikroTik App
 
jbird
newbie
Topic Author
Posts: 28
Joined: Tue Jul 22, 2014 11:29 pm

Setting up NV2 QOS - VoIP over wireless links

Wed May 04, 2022 9:50 pm

I need to set up QoS on NV2 wireless to prioritize VoIP traffic. We have DSCP enabled on the network. I set the NV2 queue count to 8, and QoS to Frame Priority. In a older post, someone recommended the following Mangle rules for the AP. I am not sure how these settings alone would enable NV2 QoS to prioritize DSCP. Is this the correct way to set up QoS on NV2? Is there more that I need to do? How can I check to see if QoS is actually working on this link?
/ip firewall mangle
add action=set-priority chain=postrouting comment="From dscp high 3 bits" \
    new-priority=from-dscp-high-3-bits
add action=mark-packet chain=postrouting comment="Priority 0" \
    new-packet-mark=prio0 priority=0
add action=mark-packet chain=postrouting comment="Priority 1" \
    new-packet-mark=prio1 priority=1
add action=mark-packet chain=postrouting comment="Priority 2" \
    new-packet-mark=prio2 priority=2
add action=mark-packet chain=postrouting comment="Priority 3" \
    new-packet-mark=prio3 priority=3
add action=mark-packet chain=postrouting comment="Priority 4" \
    new-packet-mark=prio4 priority=4
add action=mark-packet chain=postrouting comment="Priority 5" \
    new-packet-mark=prio5 priority=5
add action=mark-packet chain=postrouting comment="Priority 6" \
    new-packet-mark=prio6 priority=6
add action=mark-packet chain=postrouting comment="Priority 7" \
    new-packet-mark=prio7 priority=7
Getting the m[/code]
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 2990
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Setting up NV2 QOS - VoIP over wireless links

Wed May 04, 2022 11:27 pm

be sure you have Fast-track disabled

keep in mind prioritizing only does matter when you have high-priority traffic competing with less-priority traffic

so it's important to classify every kind of traffic
 
jbird
newbie
Topic Author
Posts: 28
Joined: Tue Jul 22, 2014 11:29 pm

Re: Setting up NV2 QOS - VoIP over wireless links

Thu May 05, 2022 1:15 am

[*] I found examples that showed classifying UDP, TCP, and ICMP. When you say to classify all types of traffic, should I classify those three, plus add a classification for DSCP? The mangle rule that I currently have for DSCP is:
add action=set-priority chain=postrouting comment="From dscp high 3 bits" \

    new-priority=from-dscp-high-3-bits passthrough=yes

[*] I've seen QoS examples that showed setting the mangle rules on the postrouting chain, and some that showed using the output chain. Which is preferable for this scenario?

[*] This link is NV2 in bridge mode. Do I need to add the mangle rules only to the AP, or do they also need to go on the client bridges?
 
jbird
newbie
Topic Author
Posts: 28
Joined: Tue Jul 22, 2014 11:29 pm

Re: Setting up NV2 QOS - VoIP over wireless links

Thu May 05, 2022 10:09 pm

I changed the mangle rules and NV2 settings to the settings below. These are the only parameters that I've set. Anyone who's had success with NV2 QoS, please let me know if you would do anything differently or if I've left anything out. Thank you.
/ip firewall mangle
add action=set-priority chain=output new-priority=3 protocol=udp
add action=set-priority chain=output new-priority=6 passthrough=yes protocol=tcp
add action=set-priority chain=output new-priority=7 protocol=icmp
add action=set-priority chain=output new-priority=from-dscp-high-3-bits passthrough=yes

/interface wireless
set nv2-qos=frame-priority
set nv2-queue-count=8

Who is online

Users browsing this forum: No registered users and 20 guests