Community discussions

MikroTik App
 
User avatar
techkyle
just joined
Topic Author
Posts: 4
Joined: Fri May 20, 2022 6:14 am
Location: PNW, US

MikroTik LTE Sierra Wireless MC7455

Sat May 21, 2022 3:18 am

Just wanted to document some of my journey to getting the MC7455 (and possibly other Sierra Wireless AirPrime modems) working with the LHG R I picked up since I was having trouble finding information on these.

Before you begin
I ran across a number of people who said they needed to tape off the USB pins to get the MikroTik to recognize the LTE interface (seen here and here) For me, taping off the USB pins was not required. Hopefully, this saves some people some time from trying to carefully count and cut some tape to the exact length needed.
Also, the latest MikroTik firmware did not recognize the LTE interface and I had to downgrade to 7.3beta40 (I think I was on a development build which wasn't working). I'm not sure which range of firmwares will work, but if you've

Update: Big thanks to Amm0's post below clarifying the need for taping the USB pins on some devices!
FWIW, re "tape the pin" on the MC7455 is needed ONLY if the Mikrotik miniPCIe support does NOT support USB 3.0. Not a definitive list: basically older RBs, SXT, & top-slot LtAP WOULD require taping (not a complete list) since the miniPCIe bus only supports USB 2.0. Stuff like wAPacR, LHGR, Audience, and bottom-slot LtAP all support USB 3.0 – those would NOT require taping. Search for postings from @SiB and your model number, since Mikrotik website isn't helpful on which models use USB 2.0 or USB 3.0 with their miniPCIe slots – but that's why you may, or may not need to cause the MC7455 to be recognized as a USB device on USB 2.0-only RouterBoards.

Sierra Wireless MC7455 Install and Config
The physical install seemed pretty straightforward. Pop the cover off the MikroTik LHG R, remove stickers on the included thermal pad and sandwich it between the MC7455 and the mPCI-e slot, connect up the antenna leads (black to "Main", grey to "Aux"), make sure both ends of both cables are secure (mine had popped off the MikroTik side), pop the cover back on.
In my case, the MC7455 I picked up was only showing up as a USB device (found under "/system resource usb print" or in Winbox under System > Resources > USB), not an LTE device.
This allows serial access which shows up in the port list, System > Ports. (Note the 5 channels here)
portlist.png
Trying to get into the serial console of the modem, open a new terminal and start probing the serial channels to see if one of them returns a response. The modem's console, when working, only seems to return characters that start with a valid command. Most commands seem to be under the "AT" command (which I'll get into later), so for now just hit the A key a few times to see if anything starts showing up in console.
If everything is working correctly, you should be able to type "AT", press return, and see if you get a response. If the console does not respond, break out of the serial sesssion with "Ctrl-A" followed by "Q" and try a different channel.
If you receive the following error..
[admin@MikroTik] > /system serial-terminal usb1 channel=0
failure: port's channel is already in use
That channel is in-use, probably by a PPP client. Check to see what is using the port with "/port print"
[admin@MikroTik] > /port print
Columns: DEVICE, NAME, CHANNELS, USED-BY, BAUD-RATE
# DEVICE  NAME  CHANNELS  USED-BY         BAUD-RATE
0 1-1     usb1         5  PPP <ppp-out1>  auto
Disabling that interface is enough to free up the serial port. While poking around to write up this post, I managed to break something which required a reboot to free up the serial channel. The MikroTik said the port was in-use by a ppp client that had been removed. After a reboot, the channel was accessible again.

For me, I was able to get access on channel=2
[admin@MikroTik] > /system serial-terminal usb1 channel=2

[Ctrl-A is the prefix key]


AT
OK
This will hopefully save you from having to buy a USB to mPCIe adapter like it sounds so many have done.


Now that we're in, we can start running commands on the modem. I'm referencing the "AirPrime EM74xx/MC74xx AT Command Reference" manual which is available on Sierra Wireless's website (which requires an account, although that's free and easy to set up) and I've also found it hosted here.

Getting into the command structure, most commands begin with AT! and it seems that most commands are locked behind a user-configurable password. For the MC7455, the default appears to be "A710". Unlock the device with AT!ENTERCND=“A710”
Note how AT!ANTSEL=? does not work before entering the password but does after.
AT!ANTSEL=?
ERROR
AT!ENTERCND="A710"
OK
AT!ANTSEL=?
AT!ANTSEL= <Band>,<gpio1>,<gpio2>,<gpio3>,[<gpio4>]
 Band:    1-60
 gpio1-4: GPIO Level(0 -2)
          0: LOW 
          1: HIGH
          2: Not used


OK
From the MikroTik Wiki page for Perephials, we can see at the bottom of the USB list that we'll want to change USBCOMP to 1009. Page 56 of the AirPrime AT Command Reference manual has information for this as does the serial interface. We can query the current config by adding a ? to the end of the command.
AT!USBCOMP?
Config Index: 1
Config Type:  1 (Generic)
Interface bitmask: 0000050D (diag,nmea,modem,rmnet0,rmnet1)
..and we can get help on our options by adding =? to the end of that command.
AT!USBCOMP=?
!USBCOMP: 
AT!USBCOMP=<Config Index>,<Config Type>,<Interface bitmask>
  <Config Index>      - configuration index to which the composition applies, should be 1

  <Config Type>       - 1:Generic, 2:USBIF-MBIM, 3:RNDIS
                        config type 2/3 should only be used for specific Sierra PIDs: 68B1, 9068
                        customized VID/PID should use config type 1

  <Interface bitmask> - DIAG     - 0x00000001,
                        NMEA     - 0x00000004,
                        MODEM    - 0x00000008,
                        RMNET0   - 0x00000100,
                        RMNET1   - 0x00000400,
                        MBIM     - 0x00001000,
  e.g.
  10D  - diag, nmea, modem, rmnet interfaces enabled
  1009 - diag, modem, mbim interfaces enabled

  The default configuration is:
  at!usbcomp=1,1,10F

OK

Some other useful commands: (May expand on some of these later)
AT!GSTATUS? - Very nice human-readable LTE status
AT!LTEINFO? - More detailed LTE breakdown of available bands and performance (check this EARFCN to Band calc)
AT!GETBAND? - Lock to
ATI3 - Manufacturer, Model, Revision, MEID, IMEI, FSN
AT+CPIN? - ??
AT!BAND? - View/set "band", seems to relate to 3G, LTE, regions. Manual isn't too helpful, see this post?
AT!SELRAT? - Related to !BAND,
AT!GSTATUS?
AT+COPS? -
AT+COPS=? - Command will hang for a bit, need to wait before it responds. It will eventually return a list of all carriers.
AT!IMPREF? - Current firmware information
AT!IMAGE? - Firmware slot information
AT!CUSTOM? - Customization strings, GPS, IPV6, etc
AT!PCINFO? - Power control status information
AT!PRIID? - PRI part number and revision, firmware related?

WARNING! SETTING !USBCOMP INCORRECTLY CAN POTENTIALLY LOCK YOU OUT OF CONSOLE ACCESS!
Thankfully, I haven't done this but I've found others that have?
I would double-check you know what exact command you need to run for your model of modem. For the MC7455, it appears to be 1,1,1009 as recommended by the MikroTik Wiki. It would be good to verify this with the bitmask before setting this! The important interface to get console access back appears to be "modem". None of the others seemed to return anything of use.
I'm running out of time for today, I'll update more as I go.

The full command for the MC7455 was the one recommended in the help text, AT!USBCOMP=1,1,1009
Definitely, *DEFINITELY* verify this with either the manual or the help text, seen with AT!USBCOMP=?

Edit 1: Currently seeing good signal but the ppp interface is dropping in and out every few seconds. My USBCOMP is "0000050D (diag,nmea,modem,rmnet0,rmnet1)", will be trying mbim mode soon.
Edit 2: Set to mbim and now none of the serial interfaces are usable. Will try a different RouterOS version.
Edit 3: Downgrading to 7.3beta40 firmware now recognizes the LTE interface. All is working well!
I've created a VLAN interface on ether1 for management and enabled ether1 as a passthrough interface for this APN. All routing handled my by main MikroTik, a CRS109.
AT&T SIM, -95-ish dBm RSSI through a good few trees ~3 miles, speeds are generally around 60 down and 30 up, sometimes slowing to 30 and 15 respectively (I suspect if carrier aggregation stops working). Sometimes at night, I see upwards of 80-90 down. I switched from a CAT 18 Inseego MiFi 8800L which saw ~10-20 down.


MikroTik Config Notes
For my physical layout, I have my main MikroTik router with an ethernet run that goes up to the LHG R on my roof. I reused a Ubiquiti 24v PoE injector I already had laying around for this install but the included injector seemed to work too.
If you enable interface passthrough as I did below, you will lose management access on ether1 when the LTE modem connects to a tower. I disabled the LTE interface before continuing until I set up management on a VLAN interface, which I did after this.
/interface lte
set [ find ] allow-roaming=no name=lte1 network-mode=lte
/interface lte apn
set [ find default=yes ] apn=broadband ip-type=ipv4 name="broadband (ATT)" passthrough-interface=\
    ether1 passthrough-mac=auto use-network-apn=no use-peer-dns=no
I kept the auto-discovered LTE interface unchanged but the LTE APN must be changed to match your provider's APN. This can usually be found with a quick search but common ones are "broadband" for AT&T, "vzwinternet" for Verizon, "fast.t-mobile.com" for T-Mobile, etc.

Since this is a 1 core 650 MHz MIPSBE CPU, it should be able to somewhat handle LTE6 speeds if the firewall rules aren't too complex but I would feel much better offloading its workload to a better device. For that reason, I enabled interface passthrough on the LHG R. In the GUI, this setting is under Interfaces > LTE tab > LTE APNs button. Change the default as needed.

Speaking of which, lets create a new interface for management access. I modified some of the defaults and created new what I needed with the final config coming out as follows.
/interface vlan
add interface=ether1 name=vlan1337 vlan-id=1337
/ip address
add address=192.168.254.2/24 interface=vlan1337 network=192.168.254.0
/ip dns
set servers=8.8.8.8
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=192.168.254.1 routing-table=main suppress-hw-offload=no
Since I've enabled passthrough, this seems to disable untagged access to the management IP bound to ether1. As a solution, I set up tagged VLAN 1337 (any unused VLAN ID will do, of course) on ether1 and set up a /30 subnet bound to that VLAN interface as well as a default route out to my main router and DNS so we can resolve the MikroTik server for package upgrades.
I removed/disabled all default-config DHCP clients and other IPs. With that all set up, we're ready to reenable the LTE interface.

With the LTE modem reenabled and the LHG unaligned outside, I was able to get a connection and pull an IP via DHCP from my main router on the port facing the LHG. Using the VLAN interface for access, I aligned with a mix of reading RSL from the LTE status page and running speedtests from my phone. I found aligning based on the upload speeds seemed to be the most reliable measure for figuring out which tower the modem was connected to. I was seeing -105 dBm RSSI no matter which way I spun the antenna but by checking upload, I was able to determine the rough direction of the tower until I found a spot where RSSI increased to -97ish. Still somewhat poor signal but it was a huge improvement over the battery-powered hotspot I was using prior.

MikroTik/RouterBoard, thanks for the work on the continual improvements to this platform. I hope to see a modemless LHGG kit or better yet, a LHGG LTE18 US version soon!
You do not have the required permissions to view the files attached to this post.
Last edited by techkyle on Mon Jun 27, 2022 8:13 pm, edited 2 times in total.
 
JardinEspanol
newbie
Posts: 38
Joined: Sun Dec 22, 2019 6:16 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Fri Jun 03, 2022 1:59 am

Can you try LTE passthrough on VLAN instead of ether1?
 
User avatar
techkyle
just joined
Topic Author
Posts: 4
Joined: Fri May 20, 2022 6:14 am
Location: PNW, US

Re: MikroTik LTE Sierra Wireless MC7455

Tue Jun 07, 2022 9:44 pm

Can you try LTE passthrough on VLAN instead of ether1?
Sure thing. It works as expected.

On the LHG R, I created vlan100 bound to ether1, set the LTE passthrough to the VLAN interface...
lte-apn-passthrough.jpg
..and a matching vlan100 bound to ether3 on my CRS109 set up with DHCP. It grabs an address as expected and appears to work just fine.
lte-apn-passthrough2.jpg
I set a temporary IP bound to ether1 on the LHG and ether3 on the CRS. I was able to ping untagged between my LHR and CRS while LTE passthrough was working on vlan100.
lte-apn-passthrough3.jpg
I had originally considered this since I wanted to keep management access untagged for ease of access when directly attached to a PC. I decided to set the LTE passthrough untagged in an attempt to keep internet traffic as untouched by the CPU as possible. I've seen occasions where the LHG's CPU usage gets a little high. I would be tempted to increase clock speed if the box wasn't in direct sunlight. Maybe I'll try it in winter. :lol:

Just did a quick test of CPU usage. With the LTE passthrough still set to a VLAN interface, CPU usage appears to be ~30-40% at 60Mbps download speeds and 20-30% at 15-20Mbps upload.
lte-apn-passthrough4-cpu.jpg
You do not have the required permissions to view the files attached to this post.
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Wed Jun 08, 2022 5:29 pm

Great write up!

FWIW, re "tape the pin" on the MC7455 is needed ONLY if the Mikrotik miniPCIe support does NOT support USB 3.0. Not a definitive list: basically older RBs, SXT, & top-slot LtAP WOULD require taping (not a complete list) since the miniPCIe bus only supports USB 2.0. Stuff like wAPacR, LHGR, Audience, and bottom-slot LtAP all support USB 3.0 – those would NOT require taping. Search for postings from @SiB and your model number, since Mikrotik website isn't helpful on which models use USB 2.0 or USB 3.0 with their miniPCIe slots – but that's why you may, or may not need to cause the MC7455 to be recognized as a USB device on USB 2.0-only RouterBoards.
 
kiloon
just joined
Posts: 12
Joined: Sat Jul 09, 2022 2:14 pm

Re: MikroTik LTE Sierra Wireless MC7455

Sat Aug 27, 2022 3:26 pm

Hello folks! Looks like a very good wright up!
I have SW MC7455 and was unable to recognize on my RBwAPR-2ND model(Mipsbe 7.5Beta5).
And I was able to switch USB compositions using a miniPCIE to usb converter via terminal in Windows 10.
Should i tape some of the pins in this situation? if so please let me know which one. I will try to search and update if I will found sooner.
I was unable to open links with examples that said @here and here@ Page said "access denied"
den.PNG
Update: Looks like i found what pins need to be taped. Will try later today and see how this will workout.
ddd.jpg
You do not have the required permissions to view the files attached to this post.
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sun Aug 28, 2022 1:19 am

The RBwAPR-2ND (wAP R) requires taping the pins as does not have the USB 3.0 pins wired. Alternatively, never tried this either, but in some newer firmware version Sierra added an AT command to set the USB speed, AT!USBSPEED=0 to force USB 2.0 mode them.
AT!ENTERCND="A710"
AT!USBSPEED=0
AT!RESET
Important Note: you have a "first mover problem" here – you either need to use a PC+USB adapter, another Mikrotik with USB 3.0, OR tape the PIN in order to even send AT commands. e.g. if the modem isn't showing up in the first place, you cannot send AT commands to it to change the USB speed mode!

Again never tried this approach myself but may be worth a look since the "taping method" doesn't seem like a great long term approach. I'd worry that heat might cause issue with the tape, or wear if the card is removed, etc., etc. On that front, non-conductive Kapton tape might be a better choice.
 
kiloon
just joined
Posts: 12
Joined: Sat Jul 09, 2022 2:14 pm

Re: MikroTik LTE Sierra Wireless MC7455

Thu Sep 01, 2022 2:33 pm

The RBwAPR-2ND (wAP R) requires taping the pins as does not have the USB 3.0 pins wired. Alternatively, never tried this either, but in some newer firmware version Sierra added an AT command to set the USB speed, AT!USBSPEED=0 to force USB 2.0 mode them.
AT!ENTERCND="A710"
AT!USBSPEED=0
AT!RESET
Important Note: you have a "first mover problem" here – you either need to use a PC+USB adapter, another Mikrotik with USB 3.0, OR tape the PIN in order to even send AT commands. e.g. if the modem isn't showing up in the first place, you cannot send AT commands to it to change the USB speed mode!

Again never tried this approach myself but may be worth a look since the "taping method" doesn't seem like a great long term approach. I'd worry that heat might cause issue with the tape, or wear if the card is removed, etc., etc. On that front, non-conductive Kapton tape might be a better choice.
Thanks for answering here!
I was able to download this firmware that you recommended and it was easy to flash this MC7455. After that i was able to change AT!USBSPEED=0
Also i have to setup and clean all stored APN's via AT commands. Currently this modem is working just fine with Mikrotik RouterBoard RB951Ui-2nD hAP (mmips v7.5) in MBIM mode. Not much information in cellular data, I can only see RSSI signal numbers.
 
leopold84
just joined
Posts: 2
Joined: Sat Apr 08, 2023 4:39 pm

Re: MikroTik LTE Sierra Wireless MC7455

Sat Apr 08, 2023 4:56 pm

Hi everyone,

Was there any fix regarding incomplete cellular data?

I'm thinking of getting this modem for a custom RBM11G-based LTE receiver, but I would like to have cellular information properly displayed.
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sat Apr 08, 2023 9:25 pm

Unfortunately, it just reads the ONLY the RSSI on the Sierra modems. The RSRP/RSPQ/SINR/etc are offered by the Quectel and Telit modems.

But the AT commands AT!GSTATUS? and AT!LTEINFO? will show details signal information. One trick you can use is use small script to loop on the those commands. The following script runs both AT "status" commands, clears the screen, and loops again. You need to use Ctrl-C to stop the script since it runs "forever" (or well, until the terminal window closes too)
:while (1) do={
:put "\1Bc" 
/interface/lte at-chat [find] input="AT!GSTATUS?"
/interface/lte at-chat [find] input="AT!LTEINFO?"
:put "\r\nUse Ctrl-C to stop"
:delay 2s
}
See also: viewtopic.php?t=163031#p876585

I suppose it can't hurt to put a feature request in at help.mikrotik.com for this support. But the underlying issue Mikrotik use AT commands to read the RSRP stuff, but on the Sierra it's hard, since the output of the above command varies a lot depending on 3G, LTE, and importantly the specific carrier firmware that loaded. So RouterOS reports the signal strength that comes back from MBIM protocol, which only supports a single signal reading...
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sat Apr 08, 2023 10:41 pm

I'm thinking of getting this modem for a custom RBM11G-based LTE receiver,
One side-note on these modems do support GPS. And I'm not sure this is cataloged in the forum, and this thread seem to capture most of the Sierra details. With a recent verison with the right combo of /system/gps and AT!GPS... commands, it's possible to read position information. I don't have any devices with MC7455 available right now, but from my notes enabling GPS is generally the following...

GPS support on Sierra MC74xx modems

1. Install the GPS package from the platform's "extra-packages".

2. For the modem to output NMEA GPS data needed for RouterOS, the "USB composition" needs to include NMEA as an exposed port. That be "100D" — see top of post for details on viewing/setting the AT!USBCOMP.

3. You also need GPS needs an antenna. On the Sierra that can be either a separate GPS antennas, or it can be "shared" with the LTE "DIV" antenna. Depending on your needs and/or frequency range of the DIV antenna. This is control by:
# use LTE "DIV" antenna to receive GPS signal:
/interface/lte/at-chat [find] input="AT!CUSTOM=\”GPSSEL\”,1"
# OR... to use the GPS u.FL on modem to a seperate GPS antennas:
/interface/lte/at-chat [find] input="AT!CUSTOM=\”GPSSEL\”,0"

4. To see the current GPS search status (which will show if GPS is enabled:
/interface/lte/at-chat [find] input="AT!GPSSTATUS?"

output: Current time: 2022 04 22 4 17:42:46
          2022 04 22 4 06:54:06 Last Fix Status    = FAIL,  FAILCODE = 9
          2022 04 22 4 06:54:07 Fix Session Status = ACTIVE
          TTFF (sec) = 4
          OK

5. You'll likely need to enable "AT!GPSAUTOSTART" for the modem to actually start an internal process to read the GPS. This may be already enabled by the default in firmware, but to check:
/interface/lte/at-chat [find] input="AT!GPSAUTOSTART?"

output:   function:  1
            fixtype: 1
            maxtime: 255 seconds
            maxdist: 1000 meters
            fixrate: 1 seconds
          OK

To see what the specific options are...
/interface/lte/at-chat [find] input="AT!GPSAUTOSTART=?"

output: !GPSAUTOSTART: <function>[,<fixtype>,<maxtime>,<maxdist>,<fixrate>]
          <function>:  0-Disabled, 1-On bootup, 2-When NMEA port opened
          <fixtype>: 1-Standalone, 2-MS-Based, 3-MS-Assisted
          <maxtime>: 1-255 seconds
          <maxdist>: 1-4294967280 meters
          <fixrate>: 1-65535 seconds
          OK

For example, my notes show this worked, but see above to match your perferences:
/interface/lte/at-chat [find] input="AT!GPSAUTOSTART=2,1,60,4294967280,1"

6. Beyond this gets it gets into preferences on how you want GPS to work for your use case...you can read about the AT!GPS... in the Sierra MC94xx AT command reference. For example, there are command to see the details on the satellites its using:
AT!GPSSATINFO?
Satellites in view:  17 (2022 04 22 4 06:54:06)
* SV:  1  ELEV: 27  AZI:  x16  SNR: 35
* SV:  3  ELEV:  2  AZI:  x85  SNR: 3ZI:   71  SNR: 42
* SV: 66  ELEV: 18  AZI:  x62  SNR: 36
* SV: 73  ELEV:  6  AZI:   x28  SNR: 30
* SV: 88  ELEV: 61  AZI:  x77  SNR: 40
* SV: 87  ELEV: 45  AZI:  x92  SNR: 42
* SV: 81  ELEV: 19  AZI:  x29  SNR: 44

7. Enable GPS in RouterOS with a specific init-string that cause the Sierra to start sending NMEA over the usb serial channel. From the CLI,
/system gps set enabled=yes init-string="\$GPS_START" port=usb1 

8. At this point, assuming all worked,
/system gps monitor 
will report the location. And winbox, etc should have GPS data.
 
leopold84
just joined
Posts: 2
Joined: Sat Apr 08, 2023 4:39 pm

Re: MikroTik LTE Sierra Wireless MC7455

Sun Apr 09, 2023 11:28 am

Unfortunately, it just reads the ONLY the RSSI on the Sierra modems. The RSRP/RSPQ/SINR/etc are offered by the Quectel and Telit modems.

But the AT commands AT!GSTATUS? and AT!LTEINFO? will show details signal information. One trick you can use is use small script to loop on the those commands. The following script runs both AT "status" commands, clears the screen, and loops again. You need to use Ctrl-C to stop the script since it runs "forever" (or well, until the terminal window closes too)
:while (1) do={
:put "\1Bc" 
/interface/lte at-chat [find] input="AT!GSTATUS?"
/interface/lte at-chat [find] input="AT!LTEINFO?"
:put "\r\nUse Ctrl-C to stop"
:delay 2s
}
See also: viewtopic.php?t=163031#p876585

I suppose it can't hurt to put a feature request in at help.mikrotik.com for this support. But the underlying issue Mikrotik use AT commands to read the RSRP stuff, but on the Sierra it's hard, since the output of the above command varies a lot depending on 3G, LTE, and importantly the specific carrier firmware that loaded. So RouterOS reports the signal strength that comes back from MBIM protocol, which only supports a single signal reading...
Thanks a lot for the detailed reply, I'm considering Quectel EP06-E as well.

Do you know by any chance, which one of them is better in terms of overall performance?
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sun Apr 09, 2023 7:00 pm

I'm considering Quectel EP06-E as well.
Do you know by any chance, which one of them is better in terms of overall performance?
To be honest, they should be pretty similar. Both are "Category 6" modems, and use similar Qualcomm core, so imagine performance be pretty similar in practice. I recall the EP06 having a lot of variants, so exactly which module version you're using, it may support less LTE bands. The EP06 report full signal stats directly in RouterOS, which is for sure helpful with a directional antenna. For an omni antenna...maybe RSSI-only is in a "good spot" or "bad spot" may be good enough.

But making sure the modem supports the bands in your area, that your carrier uses, is WAY more important than brands IMO. With 3G being sunset'ed in a lot of places, both EP06 and MC7455 are more limited to take advantage of new bands and full carrier aggregation – the later can potential dramatically improve speeds since using 2+ frequency bands at same time...

Used a bunch of the MC7354 in past(some currently still) and a handful of MC7455 – the Sierra's really have been solid modems for years. Have tested some of the EP06s, pretty similar to MC7455s I'd say...but I'm in the US, so always worry Quectels may be the next Huawei, so I've avoid using them to avoid issues down the road. Generally been using the Telit LM960A18 for new projects, while more expensive have way more bands and tons of carrier aggregation modes.
 
User avatar
ctop
newbie
Posts: 39
Joined: Tue Sep 03, 2019 11:13 pm
Location: Edmonton

Re: MikroTik LTE Sierra Wireless MC7455

Sun Dec 17, 2023 8:14 pm

Thank you techkyle for the great write up....

I was a bit worried but I followed it to a tee and got a MC7455 working in a LtAP (used bottom slot for 3.0) but I'm not sure I'm totally happy with its performance.

Used a Quectel EP06-A in a different install and that was a easier setup and it integrates so much better, I can do firmware updates from the GUI and use the LED's to show strength.

Besides going the M.2 adapter route - any other cards to try for the NorthAmerica market?

Just wanted to document some of my journey to getting the MC7455 (and possibly other Sierra Wireless AirPrime modems) working with the LHG R I picked up since I was having trouble finding information on these.

 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sun Dec 17, 2023 9:16 pm

You want to make sure the right carrier firmware is loaded. MC7455 can switch firmware, but the firmware has to be loaded before that can happen. e.g. if you're using Verizon, AT&T, or TMobile, there are specific carrier firmware for them. There is a "generic" package. While having the wrong firmware would likely "work", it also where you might see difference since configured/preferred bands/CA/etc are slightly different between the carrier firmware.

What is your carrier, and what does "AT!IMPREF?" report?
 
User avatar
ctop
newbie
Posts: 39
Joined: Tue Sep 03, 2019 11:13 pm
Location: Edmonton

Re: MikroTik LTE Sierra Wireless MC7455

Sun Dec 17, 2023 9:22 pm

BELL (Canada)

!IMPREF:
preferred fw version: 02.33.03.00
preferred carrier name: GENERIC
preferred config name: GENERIC_002.072_001
preferred subpri index: 000
current fw version: 02.33.03.00
current carrier name: GENERIC
current config name: GENERIC_002.072_001
current subpri index: 000


Do I go get the BELL firmware? can I do this switch on the Mikrotik or do I have to stick the card back into the RV50 I took it from =)

Also I just picked up on the Telit LM960 might be a good option to try - any thoughts on that?
 
User avatar
ctop
newbie
Posts: 39
Joined: Tue Sep 03, 2019 11:13 pm
Location: Edmonton

Re: MikroTik LTE Sierra Wireless MC7455

Sun Dec 17, 2023 10:25 pm

I see there is a BELL firmware.... but clueless if I can update this while installed in the LtAP
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sun Dec 17, 2023 11:14 pm

I see there is a BELL firmware.... but clueless if I can update this while installed in the LtAP
You can't AFAIK. You need to do it a Windows machine using a USB-to-miniPCIe adapter.
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Sun Dec 17, 2023 11:23 pm

Also I just picked up on the Telit LM960 might be a good option to try - any thoughts on that?
Use a lot of the LM960. There is just one firmware package and it switches carrier automatically based on SIM. And can also switch between USB 2.0/3.0 via AT#USBSWITCH. It also have the most bands with AT&T (and Bell uses same as AT&T AFAIK)... so imagine it's not a bad choice. You'd likely want to use 4 antennas with LM960 & need the smaller MHF-4 pigtails for it (the Sierra MC7455 using U.FL pigtails) to take full advantage since its 4x4 MIMO.

I used to use the MC7354 before so the Sierra are generally good modems too. But LM960 is cat18 so it should be a lot better than the MC7455.
 
User avatar
ctop
newbie
Posts: 39
Joined: Tue Sep 03, 2019 11:13 pm
Location: Edmonton

Re: MikroTik LTE Sierra Wireless MC7455

Mon Dec 18, 2023 12:30 am

I see there is a BELL firmware.... but clueless if I can update this while installed in the LtAP
You can't AFAIK. You need to do it a Windows machine using a USB-to-miniPCIe adapter.
Cool - do you think it will help anything?
 
User avatar
Amm0
Forum Guru
Forum Guru
Posts: 3169
Joined: Sun May 01, 2016 7:12 pm
Location: California

Re: MikroTik LTE Sierra Wireless MC7455

Mon Dec 18, 2023 12:33 am



You can't AFAIK. You need to do it a Windows machine using a USB-to-miniPCIe adapter.
Cool - do you think it will help anything?
If speed is an issue, then it might. The bands it selects are controlled by the firmware. So may be using less-preferred band is my guess. In general, running the latest, carrier-specific firmware is a good idea anyway. At least eliminate it as potential reason for poor performance.

You should be able to get the firmware from https://source.sierrawireless.com if you register for an account.

Who is online

Users browsing this forum: No registered users and 8 guests