Community discussions

MikroTik App
 
kortxero
just joined
Topic Author
Posts: 1
Joined: Tue Sep 13, 2022 12:20 pm

Is this translation from cisco to mikrotik correct?

Tue Sep 13, 2022 1:32 pm

Hello,

I am a recent graduate in networking and the company I have just started working for has asked me to do a Cisco to Mikrotik conversion.

After some research I have made the following translation, but I don't know if it is completely correct:

The cisco code is as follow
router ospf 1
 network 10.0.0.21 0.0.0.0 area 0
 network 10.0.11.0 0.0.0.3 area 0
 default-information originate metric-type 1
!
router bgp 120523
 bgp log-neighbor-changes
 network A.A.A.A mask 255.255.255.0
 network B.B.B.B mask 255.255.254.0
 neighbor PruebaiBGP peer-group
 neighbor PruebaiBGP remote-as 120523
 neighbor PruebaiBGP shutdown
 neighbor PruebaiBGP update-source Loopback0
 neighbor PruebaiBGP next-hop-self
 neighbor PruebaiBGP route-map OnlyDefault in
 neighbor PruebaiBGP route-map OnlyDefault out
 neighbor 10.0.0.22 peer-group PruebaiBGP
 neighbor 10.0.0.23 peer-group PruebaiBGP
 neighbor C.C.C.C remote-as 7689
 neighbor C.C.C.C route-map OnlyDefault in
 neighbor C.C.C.C route-map OnlyPruebaPublicas out
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 C.C.C.C
ip route 172.16.0.0 255.255.0.0 172.26.0.10
ip ospf name-lookup
!
!
ip prefix-list OnlyDefault_PL seq 5 permit 0.0.0.0/0
!
ip prefix-list OnlyPruebaPublicas_PL seq 5 permit A.A.A.A/21 le 24
logging origin-id hostname
logging facility local1
logging D.D.D.D
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.15.255.255
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 1 permit E.E.E.E 0.0.0.15
access-list 1 deny   any log
access-list 2 permit 10.0.0.0 0.255.255.255
access-list 2 permit 172.16.0.0 0.15.255.255
access-list 2 permit 192.168.0.0 0.0.255.255
access-list 2 permit E.E.E.E 0.0.0.15
access-list 2 deny   any log
access-list 11 permit F.F.F.F 0.0.0.63
access-list 12 permit G.G.G.G 0.0.0.255
access-list 21 permit 172.26.0.0 0.0.255.255
access-list 21 permit 172.16.0.0 0.0.255.255
access-list 22 permit E.E.E.E 0.0.0.15
access-list 23 permit I.I.I.I 0.0.0.15
access-list 24 permit A.A.A.A 0.0.0.63
access-list 25 permit B.B.B.B 0.0.0.255
access-list 190 permit ip G.G.G.G 0.0.0.255 any
access-list 190 deny   ip any any
!
!
!
!
route-map OnlyPruebaPublicas permit 10
 match ip address prefix-list OnlyPruebaPublicas_PL
!
route-map ip-from-isp permit 11
 match ip address 11
 set ip default next-hop C.C.C.C
!
route-map ip-from-isp permit 12
 match ip address 12
 set ip default next-hop H.H.H.H
!
route-map OnlyDefault permit 10
 match ip address prefix-list OnlyDefault_PL
!

The Mikrotik code I have translated is as follows:
/routing bgp instance
set default as=120523
/routing ospf instance
set [ find default=yes ] router-id=10.0.0.21
/ip firewall filter
add action=accept chain=forward src-address=10.0.0.0/8
add action=accept chain=forward src-address=172.16.0.0/20
add action=accept chain=forward src-address=192.168.0.0/16
add action=accept chain=forward src-address=E.E.E.E/28
add action=accept chain=forward src-address=F.F.F.F/26
add action=accept chain=forward src-address=G.G.G.G/24
add action=accept chain=forward src-address=I.I.I.I/28
add action=accept chain=forward src-address=A.A.A.A/26
add action=accept chain=forward src-address=B.B.B.B/24
add action=drop chain=forward
/ip route
add distance=1 gateway=C.C.C.C
add distance=1 dst-address=172.16.4.0/24 gateway=172.26.0.10
/routing bgp network
add network=A.A.A.A/24 synchronize=no
add network=B.B.B.B/23 synchronize=no
/routing bgp peer
add in-filter=FT-IN name=OpenteliBGP3 out-filter=FT-OUT remote-address=\
    C.C.C.C remote-as=7689 ttl=default
add name=OpenteliBGP1 remote-address=10.0.0.22 remote-as=120523 ttl=default
add name=OpenteliBGP2 remote-address=10.0.0.23 remote-as=120523 ttl=default
/routing ospf network
add area=backbone network=10.0.0.21/32
add area=backbone network=10.0.11.0/30

Is the translation correct or am I missing some things?

Regards

Who is online

Users browsing this forum: No registered users and 15 guests