Community discussions

MikroTik App
 
luca773
just joined
Topic Author
Posts: 6
Joined: Fri Jun 09, 2017 3:12 pm

Performance issue and QoS question

Sun Sep 18, 2022 10:32 pm

Hello,
I have a quite simple setup on a RB750GL: PPPoE internet on eth1, LAN subnet on eth4, LAN2 on eth5 and VoIP phones on eth2.
I would like to implement some sort of QoS to give VoIP phones on eth2 highest routing priority. So I started by marking Voip packets and then added a global queue.
Is that a correct approach?
Also by disabling fastrack-connection to take advantage of firewall mangle feature I had a massive drop in performance (throughput on SMB share falls from ~90MB/s to 20MB/s with 100% RB750GL cpu usage). Is that normal or am I missing something?

thanks
# sep/18/2022 21:13:11 by RouterOS 6.49.6
/ip firewall filter
add action=fasttrack-connection chain=input connection-state=established,related disabled=yes
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=\
    established,related,untracked
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=fasttrack-connection chain=forward connection-state=established,related disabled=yes
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=\
    established,related,untracked
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
/ip firewall mangle
add action=mark-connection chain=forward comment="VOIP Packets" \
    in-interface="eth2 - VoIP 86.0" new-connection-mark=VoIP_connection passthrough=yes
add action=mark-packet chain=forward connection-mark=VoIP_connection new-packet-mark=VOIP_Packet passthrough=\
    yes
add action=change-dscp chain=postrouting comment="DSCP Priority" disabled=yes new-dscp=46 packet-mark=\
    VOIP_Packet passthrough=yes

/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface=\
    Eolo-pppoe

/queue
add name=Queue1 parent=global queue=default
add name=Priority1-VoIP packet-mark=VOIP_Packet parent=Queue1 priority=1 queue=default
add name=Priority7-Other packet-mark=no-mark parent=Queue1 priority=7

    
   
 
seriquiti
just joined
Posts: 19
Joined: Wed May 11, 2022 12:55 pm

Re: Performance issue and QoS question

Mon Sep 19, 2022 11:02 am

Disabling Fasttrack will stop traffic from being handled in HW and thus will be processed by CPU. The RB750GL only has a single core 400mhz CPU so it can't do much.

Instead of disabling fasttrack globally you can add a firewall rule to bypass fasttrack only for traffic going to the internet. In regards to QOS, with that CPU you probably won't see more than 40mb's reliably over a queue.

If you need more speed you will have to replace that router with something a bit more powerfull.
 
luca773
just joined
Topic Author
Posts: 6
Joined: Fri Jun 09, 2017 3:12 pm

Re: Performance issue and QoS question

Mon Sep 19, 2022 10:31 pm

Instead of disabling fasttrack globally you can add a firewall rule to bypass fasttrack only for traffic going to the internet. In regards to QOS, with that CPU you probably won't see more than 40mb's reliably over a queue.
Good suggestion, didn't think about.
BTW just ordered a RB750gr3 since my internet connection will be upgraded to 200Mbit soon. It's an entry level device but I hope will be enough.
thanks

Who is online

Users browsing this forum: holvoetn, InfraErik, K0NCTANT1N, loloski and 57 guests