Community discussions

MikroTik App
 
jb7
just joined
Topic Author
Posts: 1
Joined: Sat Nov 05, 2022 6:50 pm

Unbound container setup

Sat Nov 05, 2022 6:53 pm

I have followed the instructions as per the wiki on setting up Pi and it works great!

Now I would like to setup Unbound as a container for a DNS solution but can't find any information on how to do this on the Mikrotik.

Any help would be appreciated!
 
elico
Member Candidate
Member Candidate
Posts: 143
Joined: Mon Nov 07, 2016 3:23 am

Re: Unbound container setup

Fri Nov 18, 2022 6:24 pm

I have followed the instructions as per the wiki on setting up Pi and it works great!

Now I would like to setup Unbound as a container for a DNS solution but can't find any information on how to do this on the Mikrotik.

Any help would be appreciated!
Just a recursive caching DNS server?

A simple unbound container can be found at:
https://github.com/elico/unbound-container

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
Last edited by elico on Fri Nov 18, 2022 7:00 pm, edited 1 time in total.
 
User avatar
mozerd
Forum Veteran
Forum Veteran
Posts: 871
Joined: Thu Oct 05, 2017 3:39 pm
Location: Canada
Contact:

Re: Unbound container setup

Fri Nov 18, 2022 6:47 pm

You should install Pi and unbound into one container … a much better approach.

https://github.com/chriscrowe/docker-pi ... -container
 
User avatar
sunakashi
just joined
Posts: 17
Joined: Wed Nov 23, 2022 1:55 pm
Location: CZ

Re: Unbound container setup

Thu Nov 24, 2022 1:24 pm

You should install Pi and unbound into one container … a much better approach.

https://github.com/chriscrowe/docker-pi ... -container
Please, could you write how to deploy this container on RouterOS? I would like to have exactly this directly on my hAP ac3. I'm running just pi-hole for now. Thanks.

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
Is it right IP addresses if I already have docker with pi-hole on 172.17.0.0 network?
Last edited by sunakashi on Fri Nov 25, 2022 12:39 am, edited 1 time in total.
 
elico
Member Candidate
Member Candidate
Posts: 143
Joined: Mon Nov 07, 2016 3:23 am

Re: Unbound container setup

Sun Dec 04, 2022 10:42 pm

Then change the network to .17 compared to .20 and it should work.
I am using the 172.20 since I have local machines with docker which the default network of choice is 172.17 so... I am using another network on the MT device so these containers can reach the DNS or another service.
You should install Pi and unbound into one container … a much better approach.

https://github.com/chriscrowe/docker-pi ... -container
Please, could you write how to deploy this container on RouterOS? I would like to have exactly this directly on my hAP ac3. I'm running just pi-hole for now. Thanks.

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
Is it right IP addresses if I already have docker with pi-hole on 172.17.0.0 network?
 
jimint
just joined
Posts: 18
Joined: Fri Aug 11, 2017 12:58 am

Re: Unbound container setup

Fri Jan 06, 2023 9:05 am

I have followed the instructions as per the wiki on setting up Pi and it works great!

Now I would like to setup Unbound as a container for a DNS solution but can't find any information on how to do this on the Mikrotik.

Any help would be appreciated!
Just a recursive caching DNS server?

A simple unbound container can be found at:
https://github.com/elico/unbound-container

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
I already run pihole in my router (veth1 interface) my ip 10.8.8.2.
So i have to remove container before install yours?
 
elico
Member Candidate
Member Candidate
Posts: 143
Joined: Mon Nov 07, 2016 3:23 am

Re: Unbound container setup

Tue Jan 10, 2023 4:33 am

No,
Just adjust the ip addresses to your containers network subnet.


Just a recursive caching DNS server?

A simple unbound container can be found at:
https://github.com/elico/unbound-container

Example on how to deploy it:
/interface/bridge/add name=dockers
/ip/address/add address=172.20.0.254/24 interface=dockers

/interface/veth/add name=veth53 address=172.20.0.53/24 gateway=172.20.0.254
/interface/bridge/port add bridge=dockers interface=veth53

/container/config/set registry-url=https://registry-1.docker.io tmpdir=disk1/pull

/container/envs/add name=unbound_envs key=TZ value="Asia/Jerusalem"

/container/add dns=172.20.0.254 remote-image=elicro/unbound:latest interface=veth53 root-dir=disk1/unbound envlist=unbound_envs start-on-boot=yes
Works like a charm.
I already run pihole in my router (veth1 interface) my ip 10.8.8.2.
So i have to remove container before install yours?

Who is online

Users browsing this forum: vic3apex and 3 guests