Community discussions

MikroTik App
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

IPv6 MPLS JunOS

Thu Dec 01, 2022 1:10 am

We are working on setting up MPLS between a CCR2216 and a Juniper MX204. Mikrotik to Mikrotik will show an AFI of ip and ipv6. The Mikrotik to MX204 only shows an AFI of ip. Anyone have any idea on what do we need to do to get MPLS to start using ipv6 between Mikrotik and JunOS?

All OSPF and OSPFv3 links are up and working

Mikrotik CCR2216 7.6
/mpls interface
add disabled=no input=yes interface=ether1 mpls-mtu=2000
/mpls ldp
add afi=ip,ipv6 disabled=no distribute-for-default=yes lsr-id=100.78.0.7 transport-addresses=100.78.0.7
/mpls ldp interface
add accept-dynamic-neighbors=yes afi=ip,ipv6 disabled=no interface=ether1 transport-addresses=100.78.0.7
MX204
interfaces {
   xe-0/1/7 {
        mtu 2000;
        unit 0 {
            family inet {
                address 100.77.0.69/30;
            }
            family inet6 {
                address XXXX:XXXX::77:17:1/112;
            }
            family mpls;
        }
}
protocols {
    ldp {
        interface xe-0/1/7.0;
    }
    mpls {
        traffic-engineering {           
            mpls-forwarding;
        }
        interface xe-0/1/7.0;
    }
}
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 7038
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: IPv6 MPLS JunOS

Fri Dec 02, 2022 10:31 am

It could mean that ROS do not see IPv6 hello packets, most likely because Juniper LDP iv6 is by default disabled.
Maybe this helps:
https://www.juniper.net/documentation/u ... v6-support
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Re: IPv6 MPLS JunOS

Fri Dec 02, 2022 7:46 pm

We have set the following options in the Juniper. Running ldp,debug, we can see the hello packets from the Juniper and the log stating that ipv6 is preferred. I ran a packet capture and I see hello packets on both IPv4 and IPv6 from both the Juniper and Mikrotik

100.78.0.4:0 KC Hello, transport 100.78.0.4, HoldTime 15, preferred AF IP6
ldp {
        interface xe-0/1/0.0;
        interface xe-0/1/6.903;
        interface lo0.0;
        family {
            inet;                       
            inet6;
        }
    }
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Re: IPv6 MPLS JunOS

Fri Dec 02, 2022 8:05 pm

Turns out, I had to manually set the LDP neighbor also. For some reason dynamic neighbors do not work correctly with Juniper.

Update, while this appeared to have fixed the issue and IPv6 connectivity works great now, it has broken IPv4. I am not sure why Dynamic is not working correctly. Looking at the packet capture, both hello messages from the Juniper and Mikrotik have Dual-Stack capability. Everything looks to be advertised correctly.
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Re: IPv6 MPLS JunOS

Thu Dec 08, 2022 1:37 pm

While hard coding the neighbors between the Mikrotik and Juniper did work, we have noticed another issue.

R1 <-> R2 <-> R3
R1 is the Juniper, connected to the world
R2 - CCR2216
R3 - CCR2004

R1 is advertising a default route through OSPF and OSPFv3

With dual stack and MPLS connected, R2 can ping everything and works great
R3 on the other hand, can ping R1 and R2 but as long as MPLS is active, it cannot ping anything through the default route
Ipv6 works fine on R3, no issues

I checked and MPLS does show a default route in the forwarding table, no firewall rules are currently added for troubleshooting purposes
0 L    16  main  0.0.0.0/0               { label=16; nh=100.76.0.86; interface=vlan3121 }                              
1 L   430  main  ::/0                    { label=429; nh=fe80::1afd:74ff:fec1:4a82%vlan3121; interface=vlan3121 }      
                                         { label=429; nh=fe80::1afd:74ff:fec1:4a82%vlan3121; interface=vlan3121 } 
                                         
R2
[admin@Core1] > /export
# jan/02/1970 05:15:10 by RouterOS 7.6
# software id = ZFSH-B6PD
#
# model = CCR2216-1G-12XS-2XQ
# serial number = HD8089JE5RM
/interface bridge
add name=LoopBack protocol-mode=none
/interface ethernet
set [ find default-name=qsfp28-1-1 ] l2mtu=2024 mtu=2000
set [ find default-name=qsfp28-2-1 ] l2mtu=2024 mtu=2000
/interface vlan
add comment="MX204" interface=qsfp28-1-1 mtu=2000 name=vlan903 vlan-id=903
add comment=AAA interface=qsfp28-1-1 mtu=2000 name=vlan3121 vlan-id=3121
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/port
set 0 name=serial0
/routing ospf instance
add disabled=no name=ospf-v2 router-id=100.78.0.7
add disabled=no name=ospf-v3 router-id=100.78.0.7 version=3
/routing ospf area
add disabled=no instance=ospf-v2 name=ospfv2
add disabled=no instance=ospf-v3 name=ospfv3
/ip address
add address=100.76.0.70/30 interface=vlan903 network=100.76.0.68
add address=100.78.0.7 interface=LoopBack network=100.78.0.7
add address=100.76.0.86/30 interface=vlan3121 network=100.76.0.84
/ipv6 address
add address=XXXX::76:17:2/112 advertise=no interface=vlan903
add address=XXXX::78:0:7/128 advertise=no interface=LoopBack
add address=XXXX::76:21:1/112 advertise=no interface=vlan3121
/mpls interface
add disabled=no input=yes interface=vlan903 mpls-mtu=2000
add disabled=no input=yes interface=vlan3121 mpls-mtu=2000
/mpls ldp
add afi=ip,ipv6 disabled=no distribute-for-default=yes lsr-id=100.78.0.7 transport-addresses=100.78.0.7,XXXX::78:0:7 vrf=main
/mpls ldp interface
add accept-dynamic-neighbors=no afi=ip,ipv6 disabled=no interface=vlan903 transport-addresses=""
add accept-dynamic-neighbors=yes afi=ip,ipv6 disabled=no interface=vlan3121 transport-addresses=""
/mpls ldp neighbor
add disabled=no send-targeted=yes transport=XXXX::78:0:4
/routing ospf interface-template
add area=ospfv2 disabled=no interfaces=LoopBack networks=100.78.0.7/32 passive
add area=ospfv3 disabled=no interfaces=LoopBack networks=XXXX::78:0:7/128 passive
add area=ospfv2 disabled=no interfaces=vlan903 networks=100.76.0.68/30 type=ptp
add area=ospfv3 disabled=no interfaces=vlan903 networks=XXXX::76:17:0/112 type=ptp
add area=ospfv2 disabled=no interfaces=vlan3121 networks=100.76.0.84/30 type=ptp
add area=ospfv3 disabled=no interfaces=vlan3121 networks=XXXX::76:21:0/112 type=ptp
/system identity
set name=Core1
/system logging
add topics=ldp,debug
/tool romon
set enabled=yes
[admin@Core1] > 

R3
AAA[admin@AAA] > /export
# jan/02/1970 05:17:35 by RouterOS 7.6
# software id = GCWV-CMZC
#
# model = CCR2004-16G-2S+
# serial number = HD0083M7KBW
/interface bridge
add name=LoopBack protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] l2mtu=2024 mtu=2000
/interface vlan
add interface=ether1 mtu=2000 name=vlan3121 vlan-id=3121
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/port
set 0 name=serial0
set 1 name=serial1
/routing ospf instance
add disabled=no name=ospfv2 router-id=100.78.0.16
add disabled=no name=ospfv3 router-id=100.78.0.16 version=3
/routing ospf area
add disabled=no instance=ospfv2 name=ospf-v2
add disabled=no instance=ospfv3 name=ospf-v3
/ip address
add address=100.76.0.85/30 interface=vlan3121 network=100.76.0.84
add address=100.78.0.16 interface=LoopBack network=100.78.0.16
/ipv6 address
add address=XXXX::76:21:2/112 advertise=no interface=vlan3121
add address=XXXX::78:0:16/128 advertise=no interface=LoopBack
/mpls interface
add disabled=no input=yes interface=vlan3121 mpls-mtu=2000
/mpls ldp
add afi=ip,ipv6 disabled=no distribute-for-default=no lsr-id=100.78.0.16 transport-addresses=100.78.0.16,XXXX::78:0:16 vrf=main
/mpls ldp interface
add accept-dynamic-neighbors=yes afi=ip,ipv6 disabled=no interface=vlan3121 transport-addresses=""
/routing ospf interface-template
add area=ospf-v2 disabled=no interfaces=LoopBack networks=100.78.0.16/32 passive
add area=ospf-v3 disabled=no interfaces=LoopBack networks=XXXX::78:0:16/128 passive
add area=ospf-v2 disabled=no interfaces=vlan3121 networks=100.76.0.84/30 type=ptp
add area=ospf-v3 disabled=no interfaces=vlan3121 networks=XXXX::76:21:0/112 type=ptp
/system identity
set name=AAA
/tool romon
set enabled=yes
 
User avatar
Wolfraider
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 88
Joined: Wed Jul 15, 2015 8:06 pm

Re: IPv6 MPLS JunOS

Thu Dec 08, 2022 1:39 pm

@mrz ticket SUP-99989

Who is online

Users browsing this forum: No registered users and 17 guests