Community discussions

MikroTik App
 
drebes
just joined
Topic Author
Posts: 1
Joined: Sat Jan 21, 2023 3:49 am

Hardware acceleration disabled on bridge when enabling vlan filtering for hEX PoE

Sun Jan 22, 2023 4:42 pm

Hi there,

I'm trying to configure my hEX PoE in a way that the five ethernet ports are switched together, and the ports handle VLAN 9 as an untagged port, and ports 10, 11, 12 and 128 as tagged ports. Each of the VLANs should have an address attached. VLANs 9, 10, 11 and 12 should additionally have an DHCP server configured. I think I managed to setup the router as desired, using the config below:
# jan/22/2023 15:36:43 by RouterOS 7.7
# software id = UI01-BXS6
#
# model = RB960PGS
# serial number = CB540C9C5AB6
/interface bridge add name=bridge1 vlan-filtering=yes
/interface vlan add interface=bridge1 name=vlan9 vlan-id=9
/interface vlan add interface=bridge1 name=vlan10 vlan-id=10
/interface vlan add interface=bridge1 name=vlan11 vlan-id=11
/interface vlan add interface=bridge1 name=vlan12 vlan-id=12
/interface vlan add interface=bridge1 name=vlan128 vlan-id=128
/ip pool add name=dhcp_vlan9 ranges=192.168.8.2-192.168.8.254
/ip pool add name=dhcp_vlan10 ranges=192.168.9.2-192.168.9.254
/ip pool add name=dhcp_vlan11 ranges=192.168.10.2-192.168.10.254
/ip pool add name=dhcp_vlan12 ranges=192.168.11.2-192.168.11.254
/ip dhcp-server add address-pool=dhcp_vlan9 interface=vlan9 name=dhcp_vlan9
/ip dhcp-server add address-pool=dhcp_vlan10 interface=vlan10 name=dhcp_vlan10
/ip dhcp-server add address-pool=dhcp_vlan11 interface=vlan11 name=dhcp_vlan11
/ip dhcp-server add address-pool=dhcp_vlan12 interface=vlan12 name=dhcp_vlan12
/interface bridge port add bridge=bridge1 interface=ether1 pvid=9
/interface bridge port add bridge=bridge1 interface=ether2 pvid=9
/interface bridge port add bridge=bridge1 interface=ether3 pvid=9
/interface bridge port add bridge=bridge1 interface=ether4 pvid=9
/interface bridge port add bridge=bridge1 interface=ether5 pvid=9
/interface bridge vlan add bridge=bridge1 tagged=bridge1 untagged=ether2,ether3,ether4,ether5 vlan-ids=9
/interface bridge vlan add bridge=bridge1 tagged=bridge1,ether2,ether3,ether4,ether5 vlan-ids=10
/interface bridge vlan add bridge=bridge1 tagged=bridge1,ether2,ether3,ether4,ether5 vlan-ids=11
/interface bridge vlan add bridge=bridge1 tagged=bridge1,ether2,ether3,ether4,ether5 vlan-ids=12
/interface bridge vlan add bridge=bridge1 tagged=bridge1,ether1,ether2,ether3,ether4,ether5 vlan-ids=128
/ip address add address=192.168.127.9/25 interface=vlan128 network=192.168.127.0
/ip address add address=192.168.9.1/24 interface=vlan10 network=192.168.9.0
/ip address add address=192.168.10.1/24 interface=vlan11 network=192.168.10.0
/ip address add address=192.168.11.1/24 interface=vlan12 network=192.168.11.0
/ip address add address=192.168.8.1/24 interface=vlan9 network=192.168.8.0
/ip dhcp-server network add address=192.168.8.0/24 gateway=192.168.8.1
/ip dhcp-server network add address=192.168.9.0/24 gateway=192.168.9.1
/ip dhcp-server network add address=192.168.10.0/24 gateway=192.168.10.1
/ip dhcp-server network add address=192.168.11.0/24 gateway=192.168.11.1
/ip dns set allow-remote-requests=yes servers=192.168.127.1
/ip route add disabled=no dst-address=0.0.0.0/0 gateway=192.168.127.1
This setup only works if I enable vlan-filtering=yes on the bridge interface. But if I do that, the router does not show anymore that the bridge has its ports enabled for hardware acceleration.

How can I achieve this setup and still have hardware acceleration for switching between ports?
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 3005
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: Hardware acceleration disabled on bridge when enabling vlan filtering for hEX PoE

Sun Jan 22, 2023 11:36 pm

that device do not supports it

Bridge Hardware Offloading
https://help.mikrotik.com/docs/display/ ... Offloading

Who is online

Users browsing this forum: Ahrefs [Bot], holvoetn, KBW, ldyte1, merkkg, mkx, panayi and 67 guests