Community discussions

MikroTik App
 
WojtusW5
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 94
Joined: Mon Oct 02, 2017 1:25 pm

CRS3xx selective VLAN stacking

Tue Mar 14, 2023 10:42 am

Hello, I have a problem with the configuration of the vlan stack with CRS3xx, below is the example I am aiming for.

All vlans are 0x8100.

On ether1 port I assume vlan 100 and 3000
Vlan 100 is a standard "single" vlan that I want to release on the appropriate ports as a tag or untag - I have no problems with that.

On the other hand, vlan 3000 is a vlan in which there are other vlans (vlan 3000 and vlans in it are 0x8100) I want to release only specific cvlans from the center of vlan 3000 on another switch port (e.g. ether2) - they can be in tag mode.
And here is where I have difficulty how to configure it so that there is hardware support.

Thank you in advance for your help.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 2096
Joined: Mon Jan 14, 2008 1:53 pm
Location: Over the Rainbow
Contact:

Re: CRS3xx selective VLAN stacking

Tue Mar 14, 2023 12:07 pm

The hardware supports it, however Mikrotik's software implementation does not.

I tried communicating this to them early in the CRS3xx development lifecycle, but I don't think they understood the problem.
 
NaquinSonariyg
just joined
Posts: 3
Joined: Wed Feb 15, 2023 11:55 am

Re: CRS3xx selective VLAN stacking

Wed Mar 15, 2023 8:29 am

Based on the information provided, it seems like you are trying to configure a VLAN stack on a MikroTik CRS3xx switch, where VLAN 3000 is a parent VLAN and VLANs within it (including VLAN 3000) are child VLANs. You want to allow specific child VLANs to pass through a specific switch port in tagged mode, while allowing VLAN 100 to pass through other switch ports in either tagged or untagged mode.

To achieve this configuration, you can use the following steps:

Create VLAN interfaces for VLAN 100 and VLAN 3000 on ether1 port:
kotlin
Copy code
/interface vlan
add interface=ether1 name=vlan100 vlan-id=100
add interface=ether1 name=vlan3000 vlan-id=3000
Configure ether1 to allow VLAN 100 and VLAN 3000 to pass through:
python
Copy code
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether1 vlan-id=100
add tagged-ports=ether1 vlan-id=3000
Configure ether2 to allow specific child VLANs within VLAN 3000 to pass through in tagged mode:
java
Copy code
/interface ethernet switch egress-vlan-tag
add tagged-ports=ether2 vlan-id=3100,3200,3300
Note that in the above configuration, VLAN 100 will be allowed to pass through other switch ports (besides ether2) in either tagged or untagged mode, while VLANs within VLAN 3000 will only be allowed to pass through ether2 in tagged mode. Also, make sure to adjust the VLAN IDs and port names as per your actual configuration.

I hope this helps you to configure the VLAN stack on your CRS3xx switch as per your requirements.

Who is online

Users browsing this forum: Bing [Bot], gigabyte091, onnyloh, RobertsN, TheCat12 and 82 guests