Community discussions

MikroTik App
 
chrismal
newbie
Topic Author
Posts: 36
Joined: Fri Nov 30, 2018 8:40 pm

ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 7:03 pm

I asked them both to create a config for dual WAN both using DHCP also use Google for monitoring WAN, did anyone do it better or get it right?

ChatGPT

/ip dhcp-client
add interface=ether1 disabled=no

/ip dhcp-client
add interface=ether2 disabled=no

/ip route
add dst-address=0.0.0.0/0 gateway=ether1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=ether2 distance=2 check-gateway=ping

/ip firewall mangle
add action=mark-connection chain=input connection-state=new in-interface=ether1 new-connection-mark=wan1_conn
add action=mark-connection chain=input connection-state=new in-interface=ether2 new-connection-mark=wan2_conn
add action=mark-routing chain=output connection-mark=wan1_conn new-routing-mark=to_wan1
add action=mark-routing chain=output connection-mark=wan2_conn new-routing-mark=to_wan2

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2

/ip dns
set servers=8.8.8.8,8.8.4.4

/ip dns monitoring
add address=8.8.8.8 disabled=no interval=10s probe-count=2 timeout=2s

/ip route rule
add action=lookup-only-in-table dst-address=8.8.8.8/32 lookup-table=wan1_check
add action=lookup-only-in-table dst-address=8.8.8.8/32 lookup-table=wan2_check

/ip route rule
add action=lookup table=wan1_check
add action=lookup table=wan2_check

/ip route
add distance=1 gateway=ether1 routing-mark=to_wan1
add distance=2 gateway=ether2 routing-mark=to_wan2

bing

# Create routing tables for each WAN
/routing table add name=to_WAN1 fib
/routing table add name=to_WAN2 fib

# Mark connections and routes for each WAN
/ip firewall mangle
add chain=output connection-state=new connection-mark=no-mark action=mark-connection new-connection-mark=WAN1_conn out-interface=ether1
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1 out-interface=ether1
add chain=output connection-state=new connection-mark=no-mark action=mark-connection new-connection-mark=WAN2_conn out-interface=ether2
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2 out-interface=ether2

# Masquerade traffic from each WAN
/ip firewall nat
add chain=srcnat action=masquerade out-interface=ether1
add chain=srcnat action=masquerade out-interface=ether2

# Add Google DNS servers as destination addresses with scope 10
/ip route
add dst-address=8.8.8.8 scope=10 gateway=ether1
add dst-address=8.8.4.4 scope=10 gateway=ether2

# Add recursive routes for each WAN with check-gateway ping and target-scope 11
/ip route
add distance=1 gateway=8.8.8.8 routing-table=to_WAN1 target-scope=11 check-gateway=ping
add distance=2 gateway=8.8.4.4 routing-table=to_WAN1 target-scope=11 check-gateway=ping
add distance=1 gateway=8.8.4.4 routing-table=to_WAN2 target-scope=11 check-gateway=
Last edited by chrismal on Tue May 30, 2023 9:53 pm, edited 1 time in total.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11968
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 9:44 pm

did anyone do it better are get it right?
Ask ChatGPT, why are you asking us?
Go have a chat with the bot...
Last edited by rextended on Tue May 30, 2023 9:52 pm, edited 3 times in total.
 
chrismal
newbie
Topic Author
Posts: 36
Joined: Fri Nov 30, 2018 8:40 pm

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 9:49 pm

did anyone do it better are get it right?
Ask ChatGPT, what are you asking it to do here?
Go have a chat with the bot...
?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11968
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 9:50 pm

Translation error: why are you asking us?


Already the first lines are full of bullshit, without checking the rest...
[…]
/ip dns monitoring => not exist
add address=8.8.8.8 disabled=no interval=10s probe-count=2 timeout=2s => not exist

/ip route rule
[…] lookup-table=wan1_check => not exist
[…] lookup-table=wan2_check => not exist

But didn't you understand that ChatGPT & Co. are just bullshit that SHAMELESSLY LIE just to give you a sop?
Last edited by rextended on Tue May 30, 2023 10:01 pm, edited 1 time in total.
 
chrismal
newbie
Topic Author
Posts: 36
Joined: Fri Nov 30, 2018 8:40 pm

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 9:59 pm

Translation error: why are you asking us?


Already the first lines are full of bullshit, without checking the rest...
[…]
/ip dns monitoring => not exist
add address=8.8.8.8 disabled=no interval=10s probe-count=2 timeout=2s => not exist

/ip route rule
[…] lookup-table=wan1_check => not exist
[…] lookup-table=wan2_check => not exist

But didn't you understand that ChatGPT & Co. are just bullshit that SHAMELESSLY LIE just to give you a sop?
Thanks for your info.
Apologies, if anyone was offended, was not my intention.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11968
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 10:02 pm

If you search are present dozen of topics with dual wan failover, already working, without involving ChatSOP...
 
chrismal
newbie
Topic Author
Posts: 36
Joined: Fri Nov 30, 2018 8:40 pm

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 10:08 pm

If you search are present dozen of topics with dual wan failover, already working, without involving ChatSOP...
Thanks will look for it :D
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 18958
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 10:37 pm

You do realize that the cat is an AI bot programmed to show varying degrees of consternation with any post purporting to concern chat gpt.
Its rather clever, almost human like.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 11968
Joined: Tue Feb 25, 2014 12:49 pm
Location: Italy
Contact:

Re: ChatGPT and bing WAN Failover did anyone do it right?

Tue May 30, 2023 10:39 pm

CatGPT: @anav detected

Who is online

Users browsing this forum: Bing [Bot], ItchyAnkle, JDF, RobertsN and 84 guests