Community discussions

MUM Europe 2020
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

How To choose The Best Channel ??

Wed Nov 14, 2007 6:14 pm

Hi Every one
I have written a script to choose the channel which noise-floor is lower, but it seems it doesn,t work well
Look at My script what parameter can I choose to have the Best channel ??
:foreach i in=[/interface wireless find mode=ap-bridge] do={/interface wireless monitor $i once do={:if ($noise-floor > -98) do={:local tmpfreq [/interface wireless get $i frequency ];
:log error $tmpfreq ;
:set tmpfreq ($tmpfreq + 5);
:log warning $tmpfreq;
:if ($tmpfreq < 2472) do={/interface wireless set $i frequency=$tmpfreq} else={/interface wireless set $i frequency=2412 ;}}}}
 
leonj
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Thu Jun 22, 2006 4:23 pm
Location: South Africa
Contact:

Re: How To choose The Best Channel ??

Tue Nov 27, 2007 10:56 am

is this in client side or in AP side?

Regards
Leon
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: How To choose The Best Channel ??

Tue Nov 27, 2007 12:52 pm

Of course on Access Point's Side
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5950
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: How To choose The Best Channel ??

Tue Nov 27, 2007 2:49 pm

Is it on 2.9 or 3.0 ?
 
User avatar
karo84
Member Candidate
Member Candidate
Topic Author
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: How To choose The Best Channel ??

Tue Nov 27, 2007 3:05 pm

It is on 2.9.49
 
User avatar
sten
Forum Veteran
Forum Veteran
Posts: 920
Joined: Tue Jun 01, 2004 12:10 pm

Re: How To choose The Best Channel ??

Tue Dec 25, 2007 6:24 am

notice how noise-floor changes between each time you reset/reconfigure a wireless interface.
Move along. Nothing to see here.

Who is online

Users browsing this forum: No registered users and 12 guests