Community discussions

MikroTik App
 
User avatar
hilton
Long time Member
Long time Member
Topic Author
Posts: 635
Joined: Thu Sep 07, 2006 5:12 pm
Location: Jozi (aka Johannesburg), South Africa

telnet to localhost just times out

Thu Nov 29, 2007 5:01 pm

Hi guys

I have installed 2.9.49 and trying out a few things but one issue is starting to get annoying. Whenever I try to telnet 0.0.0.0 or even the IP of the ether1 the telnet screen just says 'Trying 192.168.50.2...'.

If I reset the system, then it works. What could I be possibley doing wrong that would cause this?

BTW , New Terminal works fine and telnet from my PC also works.

Thanks
Regards
Hilton
 
User avatar
roadrunner
Frequent Visitor
Frequent Visitor
Posts: 86
Joined: Thu May 18, 2006 11:22 pm
Location: US

Re: telnet to localhost just times out

Thu Nov 29, 2007 9:29 pm

Don't use 0.0.0.0, that isn't the IP address of localhost; try 127.0.0.1 instead. As for telneting to the IP address of ether1, you might have a firewall filter rule blocking the traffic. Try adding an 'allow' rule in the input chain for a source address of your ether1 IP.

There might be something else that is causing your trouble, but give that a try.
 
User avatar
ashish
Long time Member
Long time Member
Posts: 550
Joined: Mon Feb 12, 2007 5:50 am
Location: Virginia, USA.

Re: telnet to localhost just times out

Fri Nov 30, 2007 6:46 am

make sure that /ip service telnet is Enabled.

or as roadrunner said theie should be some firewall rules
- AP - ASHISH PATEL - 757 309 0236 -
 
User avatar
hilton
Long time Member
Long time Member
Topic Author
Posts: 635
Joined: Thu Sep 07, 2006 5:12 pm
Location: Jozi (aka Johannesburg), South Africa

Re: telnet to localhost just times out

Fri Nov 30, 2007 10:34 am

make sure that /ip service telnet is Enabled.

or as roadrunner said theie should be some firewall rules
Ok I added this line to the filter;
chain=input action=accept dst-address=192.168.50.2 dst-port=23 protocol=tcp

But I thought that this original line would have accepted it;
chain=input action=accept in-interface=bridge1 src-address=192.168.50.0/24

Thanks to roadrunner and ashish.
Regards
Hilton

Who is online

Users browsing this forum: Baidu [Spider], robor and 20 guests