Community discussions

MikroTik App
 
MrAndersonDE
just joined
Topic Author
Posts: 2
Joined: Wed Dec 27, 2023 5:32 pm

cap AC regularly crashing - how to debug?

Fri Feb 16, 2024 7:30 pm

Hey folks,

I do have 3 cap AC in my home wifi, recently updated to 7.13/7.14RC1 with new wifi-qcom-ac to have roaming working. Before this update I has no stability issues on the 7.x with the old wirelesss package, but ofc roaming experience was quite poor.

Now I do struggle with sporadic CAP ac freezes, randomly after some hours up to some days up to almost never on the less frequent used device.
As this was only very randomly happening, also for the Mikrotik support except giving hints to disable watchdog and create a supout after next crash is very hard to help, what I totally understand.

As of today - by accident - it looks like I found out how to easily crash my CAP AC with 100% reproducible rate. But I have no clue what happens and if my config is wrong (hope not, optimized it after hours of reading in the forum what to set up best for roaming :)). I am familiar with IT in general, but "low level" debugging/sniffing on network traffic layer I never dealt with.

I am using a Macbook Air M1, connected to 5Ghz with latest update.
I am connected to my companies VPN - if thats relevant
I am connecting via "Azure Data Studio" to a Azure MSSQL managed database and doing a SELECT query on a database which returns ~130k result rows. According to the results appearing, Azure is providing them not at once but one by one or in small bulks.
After around 60k results being displayed, the CAP AC i am currently connected to stops working (wifis disappear, device not reachable anymore via Web nor via winbox.
I have the feeling that the new wifi-qcom-ac has still some memory leaking issues or something else which in normal mode brings the AP based on usage to crash after some days but within this scenario alsmost instantly). Maybe lucky if this helps finding out the problems.

But as I said - I have no clue where to start and debug this. analyzing wifi traffic? And if yes how? Maybe if you have good hints where to start. I am willing to read manuals and work me into tools, but with no clue starting from the scratch I struggle a bit.

If you need my config, should be quite basic. On the device an DHCPv4 + capsman is running. Thats it. Do not wondr about the daily reboot - this was my "workaround" to mitigate the random reboots with small effort in daily work to almost zero :)
# 2024-02-16 18:24:00 by RouterOS 7.14rc1
# software id = EDCN-8BK9
#
# model = RBcAPGi-5acD2nD
# serial number = xxx
/interface bridge
add name=bridgeLocal
/interface ethernet
set [ find default-name=ether2 ] poe-out=off
/interface wifi channel
add band=2ghz-n disabled=no frequency=2412,2437,2462 name=2.4-6 width=20mhz
add band=5ghz-ac disabled=no frequency=5180 name=5-36 width=20/40/80mhz
/interface wifi datapath
add bridge=bridgeLocal disabled=no name=capdp
/interface wifi security
add authentication-types=wpa2-psk connect-priority=0 disabled=no encryption=ccmp,gcmp,ccmp-256,gcmp-256 ft=yes ft-over-ds=yes group-key-update=23h59m59s name=sec1
/interface wifi steering
add disabled=no name=steering1 rrm=yes wnm=no
/interface wifi configuration
add channel=5-36 country=Germany datapath=capdp disabled=no mode=ap name=5 security=sec1 security.connect-priority=0 ssid="Hello World! 5Ghz" steering=steering1
add channel=2.4-6 country=Germany datapath=capdp disabled=no mode=ap name=24 security=sec1 security.connect-priority=0 ssid="Hello World!" steering=steering1
/interface wifi
set [ find default-name=wifi1 ] configuration=24 configuration.mode=ap disabled=no name="Access Point KG - 2.4"
set [ find default-name=wifi2 ] configuration=5 configuration.mode=ap disabled=no name="Access Point KG - 5"
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip pool
add name=dhcp_pool0 ranges=192.168.2.50-192.168.2.199
/ip dhcp-server
add address-pool=dhcp_pool0 interface=bridgeLocal lease-time=1w name=dhcp1
/ip smb users
set [ find default=yes ] disabled=yes read-only=yes
/interface bridge port
add bridge=bridgeLocal interface=ether1
add bridge=bridgeLocal interface=ether2
/ip firewall connection tracking
set udp-timeout=10s
/interface sstp-server server
set ciphers=aes256-sha
/interface wifi capsman
set enabled=yes interfaces=bridgeLocal package-path="" require-peer-certificate=no upgrade-policy=suggest-same-version
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no master-configuration=24 name-format="%I - 2.4" supported-bands=2ghz-n
add action=create-dynamic-enabled disabled=no master-configuration=5 name-format="%I - 5" supported-bands=5ghz-ac
/ip address
add address=192.168.2.2/24 interface=ether1 network=192.168.2.0
/ip dhcp-server lease
add address=192.168.2.x comment="" mac-address=x server=dhcp1
add address=192.168.2.x comment=" mac-address=x server=dhcp1
add address=192.168.2.x comment= mac-address=x server=dhcp1
add address=192.168.2.x comment="" mac-address=x server=dhcp1
add address=192.168.2.x comment= mac-addressx server=dhcp1
add address=192.168.2.x comment="" mac-address=x server=dhcp1
add address=192.168.2.x comment= mac-address=x server=dhcp1
add address=192.168.2.x comment="" mac-address=x server=dhcp1
add address=192.168.2.x comment= mac-address=x server=dhcp1
/ip dhcp-server network
add address=192.168.2.0/24 dns-server=1.1.1.1,8.8.8.8 gateway=192.168.2.1
/ip dns
set servers=1.1.1.1,8.8.8.8
/ip route
add gateway=192.168.2.1
/ip smb shares
set [ find default=yes ] directory=/flash/pub
/ipv6 nd
set [ find default=yes ] advertise-dns=no hop-limit=64 interface=bridgeLocal other-configuration=yes
/system clock
set time-zone-name=Europe/Berlin
/system identity
set name="Access Point KG"
/system logging
add topics=caps,debug
add topics=wireless
/system note
set show-at-login=no
/system package update
set channel=development
/system scheduler
add comment="Daily reboot" interval=1d name=reboot on-event="system reboot" policy=reboot start-date=2024-01-07 start-time=04:00:00
/system watchdog
set watchdog-timer=no
 
MrAndersonDE
just joined
Topic Author
Posts: 2
Joined: Wed Dec 27, 2023 5:32 pm

Re: cap AC regularly crashing - how to debug?  [SOLVED]

Wed Feb 21, 2024 8:59 pm

Heads up:

continued playing around with the mikrotik config after reading more forum posts. For better roaming experience I turned off WPA2/WPA3 mixed mode and reduced to WPA2 only (some devices in my wifi do not support WPA3, therefore I cannot go to WPA3 only) and only allow CCMP cipher and out of a sudden the random crahs stopped and my CAP ACs are back stable since several days.

Maybe it was because I turned on GCMP/GCMP256 with WPA2-PSK / WPA3-PSK only. After reading some more about the cipher standards for WPA2 and WPA3 the internet tends to say for WPA2/3 personal only CCMP is supported. The Macbook definitely connected with WPA3, but I did not check with cipher was used as I thought it automatically chooses the correct one.

Nevertheless I would not expect the whole CAP AC to crash, but as it is now working again for me, just to write it down here if someone else bumps over instabilities on CAP AC also. Try disabling all ciphers except CCMP when using WPA2-PSK/WPA3-PSK. Maybe it helps.

Who is online

Users browsing this forum: Airiasas, broderick, Fogga, Google [Bot], jvanhambelgium, Pilo2710 and 12 guests