Community discussions

MikroTik App
 
mattlach
newbie
Topic Author
Posts: 35
Joined: Tue May 19, 2020 7:40 pm

Intermittent 4OGbit Link on CRS326-24S+2Q+

Thu Feb 22, 2024 7:32 pm

Hi Everyone,

Just picked up a new CRS326-24S+2Q+ and I am struggling a little bit.

I'm using it as a layer2 switch + VLAN's with no routing, so I opted to boot and use it in SwOS mode.

I am using 3M Molex DAC cables to connect the Fortville (Intel XL710-QDA2) NIC's in my servers to the switch. I went with Molex cables as - at least the 10gbit SFP+ varieties have always worked in Mikrotik switches for me, and I needed them quickly, and could not find Mikrotik branded cables locally.

These immediately establish a link when connected directly, NIC to NIC, suggesting the cables are fine, but when plugging into the switch, there is no link light.

Last night, after repeatedly unplugging and re-plugging the cable, and waiting, eventually a link light appeared, and once it did, the connection was solid, and worked perfectly, until the server rebooted, at which point there was - again - no link light and no connection.

I have now been trying for 20-30 minutes, and have been unable to get another link light on the QSFP+ port. I have no idea what finally got it to link last night, but I cannot seem to replicate it again today.

It's notable that the switch detects that the DAC cable is connected, and displays the information on the Link page as follows:
QSFP+2.1	Molex 	1002971301 		215021347 	22-05-30	3m copper	
...it just doesn't result in a link.

Does anyone have any suggestions here?

1.) Do I potentially have a bad switch?

2.) Was I just silly to try to use a Molex DAC cable instead of the Mikrotik branded one?

3.) I have read that in some cases disabling auto-negotiation helps with the 40Gbit ports on Mikrotik hardware. Is this something I should try? If so, how do I do it? I clicked around the settings menu but if I disable auto-negotiation, I don't get a 40Gbit option, only 10M, 100M and 1G.

4.) Anything else I can try?


I appreciate any suggestions!
 
User avatar
ahmdzaki18
just joined
Posts: 12
Joined: Fri Oct 06, 2023 7:52 pm
Location: Jakarta, Indonesia
Contact:

Re: Intermittent 4OGbit Link on CRS326-24S+2Q+

Sat Feb 24, 2024 11:22 pm

Swos is very obsolete in my opinion, never got any updates. Try ROS latest and try disable negotiation. Im using molex, aoc, sr and lr without problem to XL710.

Dont forget for latest ROS, enable all 4 ports (its needed for auto negotiation).
 
erlinden
Forum Guru
Forum Guru
Posts: 2043
Joined: Wed Jun 12, 2013 1:59 pm
Location: Netherlands

Re: Intermittent 4OGbit Link on CRS326-24S+2Q+

Sat Feb 24, 2024 11:31 pm

Swos is very obsolete in my opinion, never got any updates.
You missed this?
viewtopic.php?t=204932
 
User avatar
ahmdzaki18
just joined
Posts: 12
Joined: Fri Oct 06, 2023 7:52 pm
Location: Jakarta, Indonesia
Contact:

Re: Intermittent 4OGbit Link on CRS326-24S+2Q+

Sun Feb 25, 2024 10:59 pm

You missed this?
viewtopic.php?t=204932
Wow thanks!
Too busy checking RoS, thought Swos will never got update for hundred years.

Who is online

Users browsing this forum: No registered users and 6 guests