Community discussions

MikroTik App
 
dandrzejewski
newbie
Topic Author
Posts: 41
Joined: Fri Oct 09, 2015 5:39 am

Mesh Networking with Dynamic Routing

Sat Mar 09, 2024 11:54 pm

I'm trying to create a decentralized wireless mesh network using
/interface mesh
and wds.

The end goal is to be able to temporarily stand up any portion of this wireless network in the field and have those portions talk to each other.

Here's a basic diagram of what I have right now -
Screenshot 2024-03-09 162643.png
Here's a config from one of the wireless devices.
# mar/09/2024 16:23:23 by RouterOS 6.49.10
# software id = XXX
#
# model = RBSXTsqG-5acD
# serial number = XXX
/interface mesh
add name=mesh1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-n/ac country="united states3" disabled=no frequency=5805 mode=wds-slave radio-name=sq1 skip-dfs-channels=all ssid=mesh wds-default-bridge=mesh1 wds-mode=dynamic-mesh
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys supplicant-identity=MikroTik wpa2-pre-shared-key=XXX
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface mesh port
add interface=wlan1 mesh=mesh1
add interface=ether1 mesh=mesh1
/ip dhcp-client
add disabled=no interface=mesh1
/system clock
set time-zone-name=America/New_York
/system identity
set name=sq1
/system routerboard settings
set cpu-frequency=auto
/tool romon
set enabled=yes
Note that I also have a routerboard router in the mix, connected to one of the wireless devices, and it has a DHCP server on it. That ethernet port is in the mesh as well:
/interface mesh
add name=mesh1
/interface mesh port
add interface=ether2 mesh=mesh1
And the DHCP server is running on mesh1.

So far, so good. All the devices mesh with each other, get addresses from the DHCP server, and they can talk over IP.

Currently, I have the ether1 interface as a port in the mesh in each wireless device, so when I connect something to said port, it can talk to the rest of the mesh and gets an IP on the same subnet:
Screenshot 2024-03-09 163611.png

So far, this is alright, but it's still a bit centralized. If the router at 192.168.88.254 (or the wireless device it's physically conncted to) falls off the network, nobody will be able to talk because nobody will get an IP address.

I'd like to decentralize this, so for example I could take these two "sub-networks" and only connect them, but have them talk:
Screenshot 2024-03-09 163802.png
I'm having trouble conceptualizing this.

My initial thought is that each of the wireless devices' ethernet ports would be taken out of the mesh, and they'd have their own unique subnet (and DHCP server, etc). That takes care of each of the individual networks.

The next question is - how would the wireless devices get their addresses assigned? They'd probably have to be assigned unique static addresses on that 192.168.88.x subnet. That's doable.

Finally.... routing. Let's say the network now looks like this:
Screenshot 2024-03-09 164532.png

I'd like to not require a bunch of static routes on every device... so I assume I'd need to use some sort of dynamic routing protocol. If that's the case, what protocol would work over a wireless mesh and are there any special considerations?

If you made it this far - thanks for reading, and thanks in advance for the assistance!
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: 4l4R1, kkeyser and 9 guests