Tue Feb 04, 2025 12:02 am
Should be, many things you utilize I am not going to be helpful on, veth, dockers etc...
1. Please set to NONE as this function has been known to cause issues.
/interface detect-internet
set detect-interface-list=WAN
2. This line shows an issue as the interface is undefined
add allowed-address=192.168.216.3/32 comment="Home (iPhone 13 Pro)" \
interface=*19 name=peer10 public-key=\
"*****"
Okay it would seem as though for some reason you have both normal wireguard setup and BTH, which is very confusing.............
In any case you dont manually enter in a wireguard peer for BTH, its done dynamically by the router, check your wireguard peers on the device!!!
3. One thing is that BTH allows user to the LAN interface list and its not changeable, so suggesting stick to some defaults.
4. Your firewall rules need work.
Also glad you have the youtube stuff disabled, its really not effective and should be removed.
Also slight cleanup on dstnat rules for pihole,
5. Recommend a sourcenat rule for nordvpn, cannot hurt but may help.
add action=change-mss chain=forward comment="Clamp MSS to PMTU for Outgoing packets" new-mss=clamp-to-pmtu out-interface=NordVPN passthrough=yes protocol=tcp tcp-flags=syn
++++++++++++++++++++++++++++++++++++++++++
Keep it simple and clear! ( trusted reflects those subnet containing admin IPs )
/interface list
add name=WAN
add name=LAN
add name=TRUSTED
/interface list member
add interface="Port 8 - WAN" list=WAN
add interface="Local Bridge" list=LAN
add interface=dockers list=LAN
add interface=wireguard1 list=LAN
add interface="Local Bridge" list=TRUSTED
add interface="wireguard1 list=TRUSTED
/ip neighbor discovery-settings
set discover-interface-list=TRUSTED
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=TRUSTED
/ip firewall address-list
add address=10.160.100.X list=Authorized comment="admin local desktop"
add address=10.160.100.Y list=Authorized comment="admin local laptop wifi"
add address=10.160.100.Z list=Authorized comment="admin local smartphone/ipad wifi"
add address=192.168.10.2 list=Authorized comment="remote admin iphone"
add address=192.168.10.4 list=Authorized comment="remote admin laptop"
ETC>
/ip firewall filter
NOTE DYNAMIC FORWARD RULE FOR BTH WILL BE AT THE TOP ( cannot move/delete/modify and has no effect in this case )
add action=drop chain=forward src-address-list=back-to-home-lan-restricted-peers out-interface-list=LAN
{ default rules to keep }
add action=accept chain=input connection-state=established,related,untracked
add action=drop chain=input comment="Drop invalid" connection-state=invalid
add action=accept chain=input comment="accept ICMP" protocol=icmp
add action=accept chain=input comment=dst-address=127.0.0.1
(admin rules)
add action=accept chain=input comment="wireguard traffic" dst-port=13231 protocol=udp
add action=accept chain=input comment="admin access" in-interface-list=TRUSTED src-address-list=Authorized
add action=accept chain=input comment="Allow DNS request for Container - UDP" \
dst-port=53 in-interface=dockers protocol=udp
add action=accept chain=input comment="Allow DNS request for Container - TCP" \
dst-port=53 in-interface=dockers protocol=tcp
add action=drop chain=input comment="block everything else"
++++++++++++++++++++
add action=fasttrack-connection chain=forward comment=\
"Fasttrack, but not ipsec" connection-mark=!ipsec connection-state=\
established,related hw-offload=yes
add action=accept chain=forward connection-state=established,related,untracked
add action=drop chain=forward comment="Drop Invalid" connection-state=invalid
add action=accept chain=forward comment="internet traffic" in-interface-list=LAN out-interface-list=WAN { note covers bridge, wireguard1 and dockers }
add action=accept chain=forward comment="bridge and wireguard to dockers" in-interface-list=LAN out-interface=dockers
add action=accept chain=forward comment="WG to subnet" in-interface=wireguard1 dst-address=10.160.100.0/24
add action=accept chain=forward comment="BTH to Subnet" in-interface=back-to-home-vpn src-address=192.168.216.0/24 dst-address=10.160.100.0/24
add action=accept chain=forward comment="port forwarding" connection-nat-state=dstnat
add action=drop chain=forward comment="Drop all Else"
/ip firewall nat
add action=masquerade chain=srcnat ipsec-policy=out,none out-interface-list=WAN
add action=change-mss chain=forward comment="Clamp MSS to PMTU for Outgoing packets" new-mss=clamp-to-pmtu out-interface=NordVPN passthrough=yes protocol=tcp tcp-flags=syn
add action=dst-nat chain=dstnat comment="Plex TCP" dst-port=32400 \
in-interface="Port 8 - WAN" log=yes log-prefix=PlexNAT protocol=tcp \
to-addresses=10.160.100.30 to-ports=32400
add action=dst-nat chain=dstnat comment=PiHole dst-address=10.160.100.1 \
dst-port=888 in-interface-list=LAN protocol=tcp to-addresses=172.17.0.2 to-ports=80
add action=dst-nat chain=dstnat comment="users to pihole" in-interface-list=LAN dst-port=53 protocol=udp src-address=!172.17.0.2 to-addresses=172.17.0.2
add action=dst-nat chain=dstnat comment="users to pihole" in-interface-list=LAN dst-port=53 protocol=tcp src-address=!172.17.0.2 to-addresses=172.17.0.2