Community discussions

MikroTik App
 
Ihstewart
just joined
Topic Author
Posts: 2
Joined: Tue Mar 11, 2025 7:29 pm

Newbie. Need help with PTPv2/VLAN configuration on CRS326

Tue Mar 11, 2025 7:37 pm

Hi. Getting a CRS326. Need to know if I can do this and some configuration assistance.

Background. I will be setting up the CRS326 as a switch (no routing). There will be two VLANs.

One of them will be 100% isolated. Meaning no communication to other vlans or the internet.

Let’s call these VLANs

Vlan 100 - general
Vlan 200 - radio

Vlan 100 will have internet and access to rest of building.

Vlan 200 is an isolated network for aoip only.

Here is the kicker. I need Vlan 200 to have a PTPv2 master on it provided by the CRS326. The clock should only be “seen” by Vlan 200.

This doable? Any tips?

Thanks
 
elbob2002
Member Candidate
Member Candidate
Posts: 296
Joined: Tue May 15, 2018 8:15 pm
Location: Ireland

Re: Newbie. Need help with PTPv2/VLAN configuration on CRS326

Wed Mar 12, 2025 1:12 am

 
User avatar
loloski
Member
Member
Posts: 467
Joined: Mon Mar 15, 2021 9:10 pm
Location: Philippines

Re: Newbie. Need help with PTPv2/VLAN configuration on CRS326

Wed Mar 12, 2025 1:18 am

# Create Bridge
/interface/bridge/add name=bridge1

# Add port on the bridge assign ether1 as vlan 100 and ether2 as vlan 200

/interface/bridge/port/add pvid=100 interface=ether1 frame-types=admit-only-untagged-and-priority-tagged
/interface/bridge/port/add pvid=200 interface=ether2 frame-types=admit-only-untagged-and-priority-tagged

# Define vlan id = 100 and 200

/interface/bridge/vlan add vlan-ids=100 tagged=br1,untagged=ether1 bridge=bridge1


## from MT documentation

/system ptp add name=ptp1 profile=802.1as
/system ptp port add interface=ether2 ptp=ptp1

/interface bridge vlan add bridge=bridge1 vlan-ids=200 untagged=bridge1,ether2

# Activate Bridge Vlan Filtering
/interface/bridge/set vlan-filtering=yes

 
Ihstewart
just joined
Topic Author
Posts: 2
Joined: Tue Mar 11, 2025 7:29 pm

Re: Newbie. Need help with PTPv2/VLAN configuration on CRS326

Wed Mar 12, 2025 2:05 am

Thank you. I will get that tested.