Community discussions

MUM Europe 2020
 
User avatar
marieL
just joined
Topic Author
Posts: 18
Joined: Mon Sep 22, 2008 10:58 am

cannot open sites if change-tcp-mss=No

Thu Sep 25, 2008 6:05 pm

Hi all.
I have a pppoe connection inside an EoIp tunnel.
I cannot open some sites (like support.microsoft.com) if the pppoe server have change-tcp-mss=no.
If I set this value to ON I can browse this sites BUT i cannot ping them.
Someone could answer: "set change-tcp-mss=Yes".

My question is: why this ?

thanks
 
Nuke
newbie
Posts: 42
Joined: Mon Jul 31, 2006 7:35 pm
Location: South Africa
Contact:

Re: cannot open sites if change-tcp-mss=No

Thu Sep 25, 2008 8:06 pm

It seems like its a 'problem' with IIS sending packets far bigger than the mtu of you connection. I found some packets that was upto 55000 bytes long, split over multiple packets from IIS based webservers. Thus I'm guessing without the change MSS option it just doesn't reconstruct the packet correctly again. It already comes fragemnted into your router from your internet line, but that fragments are bigger than your MTU on the PPPoE. Try setting your PPPoE Mtu to 1492, then it should work without the change MSS option.(read in another thread you use a smaller MTU)

Edit//
Its anyway not possible to ping support.microsoft.com
 
User avatar
marieL
just joined
Topic Author
Posts: 18
Joined: Mon Sep 22, 2008 10:58 am

Re: cannot open sites if change-tcp-mss=No

Fri Sep 26, 2008 11:19 am

The Mtu of my pppoe server is 1480.
I have this problem only with sites I cannot ping!
Could it be an ICMP problem ?
How can I check this?

thanks

Who is online

Users browsing this forum: eworm, glat, Google [Bot], mscarpitti and 152 guests