Community discussions

MUM Europe 2020
 
maksima4net
just joined
Topic Author
Posts: 1
Joined: Thu Nov 20, 2008 5:45 am

Youtube limit queue

Thu Nov 20, 2008 6:01 am

Please help howe to limit youtube bandwith in my mikrotik !!

have tried with the script

/ system scheduler
\n:if \e="youtobe" on-event=":foreach i in=\[/ip dns cache find\] do={
\n:log \find \[/ip dns cache get \$i name\] \"youtube\"\] > 0) do={
info (\"youtube: \" . \[/ip dns cache get \$i name\] . \" (ip address \" . \
\n/ip firewall address-list add \ss\] . \")\")
address=\[/ip dns cache get \$i address\] list=youtube \
\n}" start-date=sep/12/2007 start-time=21:00:00 \
interval=1m comment="" disabled=no

and

/ ip firewall mangle
add chain=prerouting action=mark-connection new-connection-mark=youtube \
passthrough=yes src-address-list=youtube comment="" disabled=no

add chain=prerouting action=mark-packet new-packet-mark=youtube passthrough=no \
connection-mark=youtube comment="" disabled=no

and

/ queue simple
add name="youtube" dst-address=0.0.0.0/0 interface=all parent=none \
packet-marks=youtube direction=both priority=8 \
queue=PCQ_download/PCQ_download limit-at=0/0 max-limit=20000/20000 \
total-queue=default-small time=0s-1d,sun,mon,tue,wed,thu,fri,sat \
disabled=no

but

this is error

Please Help me !!
You do not have the required permissions to view the files attached to this post.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5972
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: Youtube limit queue

Thu Nov 20, 2008 8:39 am

Scheduler:
add on-event=" is missing after / system scheduler and probably even beginning of script.

Queue error:
Try putting youtube in quotes, example,
packet-marks="youtube"
 
joysolutions
just joined
Posts: 1
Joined: Sun Nov 02, 2008 6:11 pm

Re: Youtube limit queue

Thu Nov 20, 2008 6:44 pm

/ system scheduler
\n:if \e="youtobe" on-event=":foreach i in=\[/ip dns cache find\] do={

try to recorrect that i had bold.

youtube or youtobe ?
 
User avatar
bellis
newbie
Posts: 49
Joined: Wed Nov 05, 2008 1:15 am
Location: Woodland, WA
Contact:

Re: Youtube limit queue

Thu Nov 20, 2008 9:15 pm

lol... i've often wished the winbox had a spellcheck :)
"If it ain't broke, you're not tryin"
 
pokeman
Member Candidate
Member Candidate
Posts: 136
Joined: Fri Jun 05, 2009 10:52 pm

Re: Youtube limit queue

Sun Jan 11, 2009 4:11 pm

can anyone find out the error

youtube.JPG
You do not have the required permissions to view the files attached to this post.

Who is online

Users browsing this forum: No registered users and 14 guests