Community discussions

MikroTik App
 
johnRBB
just joined
Topic Author
Posts: 11
Joined: Tue Dec 02, 2008 2:42 pm

dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Fri Feb 13, 2009 4:31 am

I tried to install Dude-3.1 under wine-1.1.5. It installs ok, but when I run it (selecting the language), I get a continuous scrolling message "LocalMedium: postpone read". Anyone know what this means? Is it a wine error or a Dude error? Dude-3.0 ran without any such problem.

I am working on updating wine to see if that will fix the problem...
 
johnRBB
just joined
Topic Author
Posts: 11
Joined: Tue Dec 02, 2008 2:42 pm

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Wed Feb 18, 2009 6:16 pm

I upgraded to wine-1.1.12, same results...
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Sat Feb 21, 2009 4:51 am

same results here with wine-1.1.14... I'd love to use Mikrotik software in a linux environment.
Doug
 
jbirch
just joined
Posts: 1
Joined: Mon Feb 23, 2009 4:44 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Mon Feb 23, 2009 4:55 am

I'm able to get 3.0beta8 to run under wine-0.9.47 on a Fedora Core 8, 2.6.23.15-137.fc8. Dude 3.1 is a no go.
 
Josiv
just joined
Posts: 6
Joined: Fri Jun 01, 2007 11:32 pm

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Mon Feb 23, 2009 2:14 pm

Same here, same versions, MikroTick pls provide some support.
 
xvalentinex
just joined
Posts: 7
Joined: Tue Feb 17, 2009 12:09 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Wed Feb 25, 2009 8:30 am

Same result here. Wine 1.1.18.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Thu Feb 26, 2009 7:48 pm

FIXED! When I install fresh Dude 3.1 in wine and start it just hangs. This is what I did:

-- I installed it on WinXP, configured it to look at a remote server instead of local. (either secure or remote)
-- Then install Dude under wine but DO NOT launch after install.
-- Copied c:\dude.conf and everything in C:\ProgramFiles\Dude from XP over to my ~\.wine\drive_c dir in appropriate folders.
-- Launch Dude from wine
wine "C:\\Program Files\\Dude\\dude.exe"


It seems to when it's looking at a remote dude server but not local.

Also when I hit "Local Server" and started it from wine it crashed again.

Anyway really hope this helps. Again thanks Mikrotik for suck a great piece of software!

I just got it up so I"ll post more specifics as I find them.
Doug
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Fri Mar 06, 2009 2:05 am

update: i've been using the dude client under wine 1.1.14 that points to a Mikrotik with dude-3.1-npk installed. So far it's been running great. the little icon ever sits in the task tray on linux and updates according to overall dude status. So far no crashes on either the server end or client end. email notifications work good; even running an execute notification under wine works as expected. agents connect ok too.

still not able to get a native dude server on wine though.

anyway, again hope this helps,


Doug
Doug
 
xvalentinex
just joined
Posts: 7
Joined: Tue Feb 17, 2009 12:09 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Sat Mar 07, 2009 8:17 am

dssmiktik, thank you, that solution works for me.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Sun Mar 08, 2009 12:01 am

your welcome :D
Doug
 
omelendres
just joined
Posts: 10
Joined: Tue Mar 10, 2009 11:06 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Tue Mar 10, 2009 11:32 am

The windows workaround for Dude 3.1 worked for me as well, thanks

Noticed that during the linux install, the dude.conf file under drive_c doesn't get copied.
 
User avatar
interlink
newbie
Posts: 47
Joined: Wed Apr 26, 2006 5:18 am
Location: Ar Ros

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Wed Mar 11, 2009 3:07 pm

I just get server dude server running on linux, but now the thing is that I can´t get the dude server listen on port 80 or any other port that give me web access (no apache running or any other web server). Just access the server with dude client. Anyone else with this issue too?.
Is there any parameter to add to this line that makes dude listen on port 80 or enable web access by default.

/usr/bin/wine /home/jkgf/.wine/drive_c/Program\ Files/Dude/dude.exe --server
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Thu Mar 12, 2009 9:40 pm

thanks interlink. this worked for me. for me i could connect using remote or secure to 127.0.0.1 but not local. i also can't get the web access working.

thanks again


Doug
Doug
 
Anonymo
just joined
Posts: 2
Joined: Fri Mar 20, 2009 11:47 pm

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Sat Mar 21, 2009 12:03 am

When I view network maps in thedude, I try to scroll through some of the lists and they scroll really slow, I also cannot copy ping results from the terminal program to paste somewhere.
 
ivodeblasi
just joined
Posts: 1
Joined: Mon Mar 23, 2009 1:58 pm

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Mon Mar 23, 2009 2:05 pm

Thanks dssmiktik.
Your solution worked for me, with Ubuntu 8.10, wine and wine-doors.
Now I want to understand why it works!!
Thanks again.
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Thu Mar 26, 2009 4:40 am

Glad that it worked. I also found that it's only one file that you need to copy over. I modified a wiki page with this info.here:

http://wiki.mikrotik.com/wiki/Talk:Dude ... stallation
Doug
 
dssmiktik
Forum Veteran
Forum Veteran
Posts: 732
Joined: Fri Aug 17, 2007 8:42 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Tue Apr 07, 2009 11:06 pm

Good news! Downloaded dude 3.2-exe and installed it under wine. The Local Server is green and enabled; and I can connect to it using either Secure or Remote to 127.0.0.1.


Thank you Mikrotik!


Doug
Doug
 
jamescray
just joined
Posts: 1
Joined: Fri Sep 18, 2009 12:02 pm

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Fri Sep 18, 2009 12:07 pm

I just get server dude server running on linux, but now the thing is that I can´t get the dude server listen on port 80 or any other port that give me web access (no apache running or any other web server). Just access the server with dude client. Anyone else with https://donkeybets.com/my-zcode-system-review this zcode issue too?.
Is there any parameter to add to this line that makes dude listen on port 80 or enable web access by default.

/usr/bin/wine /home/jkgf/.wine/drive_c/Program\ Files/Dude/dude.exe --server
I'm using a later version but I'm getting this error message too "LocalMedium: postpone read".

I'm just trying to figure out why. Will go through the options below but just thought I'd register
because there's lots of good info on here.
Last edited by jamescray on Sat Aug 06, 2016 9:35 pm, edited 12 times in total.
 
alteriunhun
just joined
Posts: 1
Joined: Sun Apr 18, 2010 10:26 am

Re: dude-3.1 under wine-1.1.5 = LocalMedium: postpone read

Sun Apr 18, 2010 10:30 am

I'm using a later version but I'm getting this error message too "LocalMedium: postpone read".

I'm just trying to figure out why. Will go through the options below but just thought I'd register
because there's lots of good info on here.

James

Hi all,

Thanks for the suggestion you give that's very helpful for me and to other,thanks for that!!!!!



Thanks and regards

Who is online

Users browsing this forum: No registered users and 11 guests