Community discussions

MikroTik App
 
keefe007
Member Candidate
Member Candidate
Topic Author
Posts: 125
Joined: Sun Jun 25, 2006 3:01 am

High Availability Routing

Wed Jul 15, 2009 3:05 am

Currently I have one Mikrotik router connected to two ISPs via BGP. Ideally I'd like to have two routers in an active-active state. All of the devices on the LAN side of my current router have public IP addresses. There is no NAT. Is there a way to implement an active-active setup with the LAN devices using a single IP as a gateway?

Keefe
 
User avatar
Eising
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Oct 27, 2008 10:21 am
Location: Copenhagen, Denmark

Re: High Availability Routing

Wed Jul 15, 2009 10:47 am

Active-passive setups can be achieved with VRRP, which is also first-hop redundancy. It is configured like this:
Router1
/ip address add interface=ether1 address=192.168.1.2/24 disabled=no
/interface vrrp add interface=ether1 vrid=10 priority=50 preemption-mode=no disabled=no name=ether1.vip
/ip address add interface=ether1.vip address=192.168.1.1/32 disabled=no
Router2
/ip address add interface=ether1 address=192.168.1.3/24 disabled=no
/interface vrrp add interface=ether1 vrid=10 priority=30 preemption-mode=no disabled=no name=ether1.vip
/ip address add interface=ether1.vip address=192.168.1.1/32 disabled=no
If you want an active-active setup, the only way is to run a dynamic routing protocol on your hosts, such as ospf, rip or bgp.

Who is online

Users browsing this forum: No registered users and 65 guests