Community discussions

MikroTik App
 
Frothingdog
just joined
Topic Author
Posts: 18
Joined: Wed Jun 17, 2009 4:47 pm

OID Active Connections

Mon Nov 16, 2009 6:23 pm

Does anyone happen to know the OID for Active Connections?
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Mon Nov 16, 2009 8:02 pm

Hotspot ones? Either way, use "print oid" in the correct sub-context:
/ip hotspot active print oid
 
Frothingdog
just joined
Topic Author
Posts: 18
Joined: Wed Jun 17, 2009 4:47 pm

Re: OID Active Connections

Mon Nov 16, 2009 9:38 pm

Yeah that doesn't do the job for me. Looking for the OID for ALL active connections.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Mon Nov 16, 2009 10:00 pm

What does that mean? You want a count of how many active connections there are? AFAIK there's no such counter. If you find a solution I'd be very interested.
 
Frothingdog
just joined
Topic Author
Posts: 18
Joined: Wed Jun 17, 2009 4:47 pm

Re: OID Active Connections

Mon Nov 16, 2009 11:45 pm

ok..that's what I wanted to know.

I thought since the OS tracks it in the firewall that there might be an OID to that number.

If there really isn't a counter, there should be!
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Mon Nov 16, 2009 11:56 pm

I am currently working around that by using a script every five minutes to log Hotspot utilization by Hotspot server. Via syslog that gets passed to an external server that then graphs the numbers:
# summarize hotspot total users via syslog

# prep string to write to log
:local message "Hotspot usage summary: ";
# step through all available hotspot servers
:foreach hotspotServer in=[/ip hotspot find] do={
# get the name of the one we're currently looking at
    :local serverName [/ip hotspot get $hotspotServer name];
    # append log string with hotspot server name and the total number of acti e users
    :set message ($message . $serverName . "=" . [/ip hotspot active print count-only where server=$serverName] . ", ");
}
# trim away the trailing comma and space
:set message [:pick $message 0 ([:len $message] - 2)];
# log it
:log info $message
Dirty, but it works.

Again, if you or anyone else knows a way to do this purely by SNMP that'd be very nice.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8465
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: OID Active Connections

Tue Nov 17, 2009 12:58 am

hmmm... I don't remember where I have found it, but for ppp active session count there's OID '1.3.6.1.4.1.9.9.150.1.1.1.0'

I think, there sould be something for Hotspot somewhere around...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Tue Nov 17, 2009 1:10 am

Strange. That's a Cisco MIB - CISCO-AAA-SESSION-MIB:casnActiveTableEntries.

Edit: it would be very helpful if Mikrotik published a current MIB file.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Tue Nov 17, 2009 1:38 am

http://forum.mikrotik.com/viewtopic.php?f=6&t=6325 indicates at some point support for this was added.

http://forum.mikrotik.com/viewtopic.php?f=2&t=18486 claims it's the Cisco MIB Chupaka posted, but I cannot get that to work on 4.2 (Solarwind's Orion Custom MIB Poller reports "Device does not support this OID" when I try to query it.

I've emailed support asking if this is still supported, and what the OID is.
 
Frothingdog
just joined
Topic Author
Posts: 18
Joined: Wed Jun 17, 2009 4:47 pm

Re: OID Active Connections

Tue Nov 17, 2009 4:10 am

I tried the OID that Chupaka. didn't work.

I see everyone is posting about Active Hotspot connections, this isn't really what I was looking for.

I'm talking about the Active data Connections passing through the Firewall.
(ie...IP....Firewall....Connections) Just to clear up the confusion.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Tue Nov 17, 2009 4:15 am

Oh. My bad. If/when I hear back from support I'll amend the request to that OID as well. FWIW, I did a fairly thorough SNMP walk and couldn't find a counter for either, but I'll check again tomorrow at work to see if I can find a firewall connection one.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Tue Nov 17, 2009 8:04 pm

Support confirmed that there is no OID for the number of firewall connections tracked. It also appears that there is no OID for the number of Hotspot users active, though you can query each individual active Hotspot user.
 
Frothingdog
just joined
Topic Author
Posts: 18
Joined: Wed Jun 17, 2009 4:47 pm

Re: OID Active Connections

Wed Nov 18, 2009 2:42 am

Thanks for the heads-up, all-be-it disappointing and a bit shocking.

Granted that Active connection # bounces around alot, so trying to graph it would only reveal a rough average at best. But still that average would be nice to know. Specially when your peaking at over 500,000 active connections.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: OID Active Connections

Thu Nov 19, 2009 6:29 pm

Just in case someone finds this thread via the search, support has also confirmed that there is no OID for the number of active Hotspot connections.
 
kitkat
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Sun Jun 12, 2011 7:32 pm

OID Active Connections

Wed Dec 07, 2011 3:00 am

I feel that mt lacks snmp oid's. I hope they work on this.


---
I am here: http://maps.google.com/maps?ll=45.505455,-75.649082
Sent from my iPhone4 using Tapatalk
 
jarda
Forum Guru
Forum Guru
Posts: 7763
Joined: Mon Oct 22, 2012 4:46 pm

Re: OID Active Connections

Fri Jan 09, 2015 12:26 pm

And to be confirmed as of version 6.24, there is still not oid for total-entries value of /ip firewall connection tracking.

Thats shame.
 
anuser
Member
Member
Posts: 473
Joined: Sat Nov 29, 2014 7:27 pm

Re: OID Active Connections

Wed Nov 22, 2017 9:10 am

As I am currently looking for that OID, is there anything available?

Who is online

Users browsing this forum: klaus007 and 63 guests