Community discussions

MikroTik App
 
rodolfo
Long time Member
Long time Member
Topic Author
Posts: 552
Joined: Sat Jul 05, 2008 11:50 am

problem with dhcp options on a APC ups

Tue Aug 17, 2010 9:19 pm

Hi all.
I try to give an ip address to a snmp board APC 9630.
I used:

/ip dhcp-server option
add code=43 name=ups_apc value=010431415043

but the dhcp debug log is the following:

20:15:42 dhcp,debug,packet dhcp_ups received discover with id 17541 from 0.0.0.0
20:15:42 dhcp,debug,packet secs = 64
20:15:42 dhcp,debug,packet ciaddr = 0.0.0.0
20:15:42 dhcp,debug,packet chaddr = 00:C0:B7:D7:EF:C8
20:15:42 dhcp,debug,packet Msg-Type = discover
20:15:42 dhcp,debug,packet Client-Id = 00-00-C0-B7-D7-EF-C8-00-00-00
20:15:42 dhcp,debug,packet Parameter-List = Domain-Server,Router,Subnet-Mask,Domain-Name,Unknown(66),Unknown(67),Unknown(1
3),NETBIOS-Name-Server,Vendor-Specific,Renewal-Time,Unknown(59),NTP-Server,Unknown(2),Host-Name
20:15:42 dhcp,debug,packet Class-Id = "APC"
20:15:42 dhcp,debug,packet Client-Id = 01-00-C0-B7-D7-EF-C8
20:15:42 dhcp,debug,packet Unknown(77) = 53-55-4D-58

20:15:42 dhcp,debug,packet dhcp_ups sending offer with id 17541 to 10.11.216.101
20:15:42 dhcp,debug,packet ciaddr = 0.0.0.0
20:15:42 dhcp,debug,packet yiaddr = 10.11.216.101
20:15:42 dhcp,debug,packet siaddr = 10.11.216.6
20:15:42 dhcp,debug,packet chaddr = 00:C0:B7:D7:EF:C8
20:15:42 dhcp,debug,packet Msg-Type = offer
20:15:42 dhcp,debug,packet Server-Id = 10.11.216.6
20:15:42 dhcp,debug,packet Address-Time = 259200
20:15:42 dhcp,debug,packet Subnet-Mask = 255.255.255.0
20:15:42 dhcp,debug,packet Vendor-Specific = 30-31-30-34-33-31-34-31-35-30-34-33

And the apc does not configure and this messages are repeated.

Have someone an hint ?

thanks


Rodolfo
rodolfo
IZ0UQV
 
DaLemon
just joined
Posts: 3
Joined: Mon Sep 04, 2006 10:02 pm

Re: problem with dhcp options on a APC ups

Mon Feb 14, 2011 8:10 am

Hi

I know this is almost 3 years later, but I just ran into the same issue.

you were 2 characters off getting this to work :)

/ip dhcp-server option
add code=43 name=APC value=0x010431415043
[/b]

From APC's web site: Option 43 = 0x01 0x04 0x31 0x41 0x50 0x43
 
silversword
newbie
Posts: 44
Joined: Tue Jul 23, 2013 3:36 pm

Re: problem with dhcp options on a APC ups

Mon Jul 01, 2019 7:05 pm

...and if you had already created a static entry before adding that option to the server you'll need to modify the static lease reservation to include the option as well :)

Who is online

Users browsing this forum: swheeler, Xmqorebbjqjnxv, Znevna and 36 guests