Community discussions

 
Jamesy
Member Candidate
Member Candidate
Topic Author
Posts: 206
Joined: Fri Dec 18, 2009 7:04 pm

what is a hidden node?

Sat Oct 30, 2010 3:22 am

I've been reading up on cts rts etc after having an issue with clients disconnecting earlier today.

I am unsure what is meant when someone talks about a hidden node. ( I find people talking about hidden nodes and using rts cts to fix it)

I have my aps setup to not allow forwarding. ( I don't want one client seeing another clients shared printer in a bridge network for example)

Is this what is meant by hidden node? If so how does this work in a routed network.

I guess I am simply looking for a good explanation of a hidden node.

Many thanks in advance for helping a new guy learn.
 
fewi
Forum Guru
Forum Guru
Posts: 7734
Joined: Tue Aug 11, 2009 3:19 am

Re: what is a hidden node?

Sat Oct 30, 2010 4:00 am

http://en.wikipedia.org/wiki/Hidden_node_problem

That is a good explanation. Make sure you follow the CSMA/CA link in the first proper paragraph to understand that concept before reading about the hidden node problem itself.
 
n21roadie
Forum Guru
Forum Guru
Posts: 1887
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: what is a hidden node?

Sat Oct 30, 2010 4:42 pm

I've been reading up on cts rts etc after having an issue with clients disconnecting earlier today.
Before assuming it's a hidden node (which it maybe?), I understanding is hidden node would affect network performance and not sure if hidden node can cause clients to disconnect?

For clients disconnecting i would check;
Have you good ccq for each cpe, datarates reduced to improve ccq, manual ack timeouts, Interference, fresnel zone,etc

rts/cts & hidden nodes read these posts;

http://forum.mikrotik.com/viewtopic.php ... +rts%2Fcts

http://forum.mikrotik.com/viewtopic.php ... =rts%2Fcts

keep us posted on this.
N21roadie,
Network 100% MT for Now?
 
Jamesy
Member Candidate
Member Candidate
Topic Author
Posts: 206
Joined: Fri Dec 18, 2009 7:04 pm

Re: what is a hidden node?

Mon Nov 01, 2010 6:52 pm

I turned on rts/cts on the clients (ten in total on this particular sector) and the problem went away.

CSMA is also disabled on the ap at this point. (It wasn't when the problem existed)

For background info the sector has n streme and the ccq is above 80% on all nodes. All nodes except for the latest one had default signaling rates. The latest one I have locked at 9mb right now and it's ccq remains at 100%.

Turing on cts to self on the ap did not fix the problem and killed throughput. Leaving rts/cts with size 32 on and disabling cts to self on the ap stabilized the environment.

Who is online

Users browsing this forum: No registered users and 17 guests