Community discussions

 
supergeek
just joined
Topic Author
Posts: 11
Joined: Thu May 19, 2011 2:34 am

PPPOE problems

Thu May 26, 2011 3:04 am

Hi forum.

Im having problems with connect my RB750 to my ISP.

I have a draytek vigor 120 with pppoe pass-through on.

It works fine if i create a pppoe connection on my windows computer but will not work on the RB750

Here is my pppoe config
/interface pppoe-client
add ac-name="" add-default-route=yes allow=pap dial-on-demand=no disabled=yes interface=ether1-gateway max-mru=1480 max-mtu=1480 mrru=disabled name=\
    pppoe-user-joseph password=**** profile=default service-name=internet use-peer-dns=yes user=****
Here is the connection log
23:52:49 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:49 pppoe,debug,packet     session-id=0x0000 
23:52:49 pppoe,debug,packet     host-uniq=0x0 
23:52:49 pppoe,debug,packet     service-name=internet 
23:52:50 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:50 pppoe,debug,packet     session-id=0x0000 
23:52:50 pppoe,debug,packet     host-uniq=0x0 
23:52:50 pppoe,debug,packet     service-name=internet 
23:52:51 pppoe,ppp,info pppoe-user-joseph: terminating... - disconnected 
23:52:51 pppoe,ppp,debug pppoe-user-joseph: LCP lowerdown 
23:52:51 pppoe,ppp,debug pppoe-user-joseph: LCP down event in initial state 
23:52:51 pppoe,ppp,info pppoe-user-joseph: disconnected 
23:52:51 pppoe,ppp,info pppoe-user-joseph: initializing... 
23:52:51 pppoe,ppp,info pppoe-user-joseph: dialing... 
23:52:51 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:51 pppoe,debug,packet     session-id=0x0000 
23:52:51 pppoe,debug,packet     host-uniq=0x1 
23:52:51 pppoe,debug,packet     service-name=internet 
23:52:52 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:52 pppoe,debug,packet     session-id=0x0000 
23:52:52 pppoe,debug,packet     host-uniq=0x1 
23:52:52 pppoe,debug,packet     service-name=internet 
23:52:53 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:53 pppoe,debug,packet     session-id=0x0000 
23:52:53 pppoe,debug,packet     host-uniq=0x1 
23:52:53 pppoe,debug,packet     service-name=internet 
23:52:54 pppoe,ppp,info pppoe-user-joseph: terminating... - disconnected 
23:52:54 pppoe,ppp,debug pppoe-user-joseph: LCP lowerdown 
23:52:54 pppoe,ppp,debug pppoe-user-joseph: LCP down event in initial state 
23:52:54 pppoe,ppp,info pppoe-user-joseph: disconnected 
23:52:54 pppoe,ppp,info pppoe-user-joseph: initializing... 
23:52:54 pppoe,ppp,info pppoe-user-joseph: dialing... 
23:52:54 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:54 pppoe,debug,packet     session-id=0x0000 
23:52:54 pppoe,debug,packet     host-uniq=0x2 
23:52:54 pppoe,debug,packet     service-name=internet 
23:52:55 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:55 pppoe,debug,packet     session-id=0x0000 
23:52:55 pppoe,debug,packet     host-uniq=0x2 
23:52:55 pppoe,debug,packet     service-name=internet 
23:52:56 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:56 pppoe,debug,packet     session-id=0x0000 
23:52:56 pppoe,debug,packet     host-uniq=0x2 
23:52:56 pppoe,debug,packet     service-name=internet 
23:52:57 pppoe,ppp,info pppoe-user-joseph: terminating... - disconnected 
23:52:57 pppoe,ppp,debug pppoe-user-joseph: LCP lowerdown 
23:52:57 pppoe,ppp,debug pppoe-user-joseph: LCP down event in initial state 
23:52:57 pppoe,ppp,info pppoe-user-joseph: disconnected 
23:52:58 pppoe,ppp,info pppoe-user-joseph: initializing... 
23:52:58 pppoe,ppp,info pppoe-user-joseph: dialing... 
23:52:58 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:58 pppoe,debug,packet     session-id=0x0000 
23:52:58 pppoe,debug,packet     host-uniq=0x3 
23:52:58 pppoe,debug,packet     service-name=internet 
23:52:59 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:52:59 pppoe,debug,packet     session-id=0x0000 
23:52:59 pppoe,debug,packet     host-uniq=0x3 
23:52:59 pppoe,debug,packet     service-name=internet 
23:53:00 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:53:00 pppoe,debug,packet     session-id=0x0000 
23:53:00 pppoe,debug,packet     host-uniq=0x3 
23:53:00 pppoe,debug,packet     service-name=internet 
23:53:01 pppoe,ppp,info pppoe-user-joseph: terminating... - disconnected 
23:53:01 pppoe,ppp,debug pppoe-user-joseph: LCP lowerdown 
23:53:01 pppoe,ppp,debug pppoe-user-joseph: LCP down event in initial state 
23:53:01 pppoe,ppp,info pppoe-user-joseph: disconnected 
23:53:02 pppoe,ppp,info pppoe-user-joseph: initializing... 
23:53:02 pppoe,ppp,info pppoe-user-joseph: dialing... 
23:53:02 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:53:02 pppoe,debug,packet     session-id=0x0000 
23:53:02 pppoe,debug,packet     host-uniq=0x4 
23:53:02 pppoe,debug,packet     service-name=internet 
23:53:04 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:53:04 pppoe,debug,packet     session-id=0x0000 
23:53:04 pppoe,debug,packet     host-uniq=0x4 
23:53:04 pppoe,debug,packet     service-name=internet 
23:53:04 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:53:04 pppoe,debug,packet     session-id=0x0000 
23:53:04 pppoe,debug,packet     host-uniq=0x4 
23:53:04 pppoe,debug,packet     service-name=internet 
23:53:05 pppoe,ppp,info pppoe-user-joseph: terminating... - disconnected 
23:53:05 pppoe,ppp,debug pppoe-user-joseph: LCP lowerdown 
23:53:05 pppoe,ppp,debug pppoe-user-joseph: LCP down event in initial state 
23:53:05 pppoe,ppp,info pppoe-user-joseph: disconnected 
23:53:09 pppoe,ppp,info pppoe-user-joseph: initializing... 
23:53:09 pppoe,ppp,info pppoe-user-joseph: dialing... 
23:53:09 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:53:09 pppoe,debug,packet     session-id=0x0000 
23:53:09 pppoe,debug,packet     host-uniq=0x5 
23:53:09 pppoe,debug,packet     service-name=internet 
23:53:10 pppoe,debug,packet ether1-gateway: sent PADI to FF:FF:FF:FF:FF:FF 
23:53:10 pppoe,debug,packet     session-id=0x0000 
23:53:10 pppoe,debug,packet     host-uniq=0x5 
23:53:10 pppoe,debug,packet     service-name=internet 
23:53:10 pppoe,ppp,info pppoe-user-joseph: terminating... 
23:53:10 pppoe,ppp,debug pppoe-user-joseph: LCP lowerdown 
23:53:10 pppoe,ppp,debug pppoe-user-joseph: LCP down event in initial state
Any help would be great.

Thanks

Joseph
 
petrn
Member Candidate
Member Candidate
Posts: 179
Joined: Thu Jul 29, 2010 3:56 am

Re: PPPOE problems

Thu May 26, 2011 10:27 am

Hi,

looks like service name
service-name=internet
doesn't match ISP service name, try
service-name=""
normally this parameter is not necessary.
Petr
 
supergeek
just joined
Topic Author
Posts: 11
Joined: Thu May 19, 2011 2:34 am

Re: PPPOE problems

Thu May 26, 2011 11:55 pm

I have tried that but still the same issue.
 
User avatar
chris6671980309
just joined
Posts: 20
Joined: Wed Feb 23, 2011 7:06 am
Location: Singapore

Re: PPPOE problems

Fri May 27, 2011 5:27 am

For reference, mine look like this.

To solve issue, post the output of "/ip address print detail", "/ip route print detail", "/interface print", "/ip firewall export". So that others can help u.
/interface pppoe-client
add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=\
    "" dial-on-demand=no disabled=no interface=ether1-gateway max-mru=1492 \
    max-mtu=1492 mrru=disabled name=pppoe-out1 password=XXXXXXXX profile=\
    default service-name="" use-peer-dns=yes user=username@singnet
 
supergeek
just joined
Topic Author
Posts: 11
Joined: Thu May 19, 2011 2:34 am

Re: PPPOE problems

Fri May 27, 2011 8:25 am

Thanks chris6671980309 but that still didnt help.

Below is the things you asked for.


/ip address print detail
 0   ;;; default configuration
     address=192.168.88.1/24 network=192.168.88.0 
     interface=ether2-local-master actual-interface=ether2-local-master 

 1   address=10.1.1.254/32 network=10.1.1.254 interface=ether1-gateway 
     actual-interface=ether1-gateway 

/ip route print detail

0 DS dst-address=0.0.0.0/0 gateway=192.168.2.1
gateway-status=192.168.2.1 unreachable distance=0 scope=30
target-scope=10 vrf-interface=ether1-gateway

1 ADC dst-address=10.1.1.254/32 pref-src=10.1.1.254 gateway=ether1-gateway
gateway-status=ether1-gateway reachable distance=0 scope=10

2 ADC dst-address=192.168.88.0/24 pref-src=192.168.88.1
gateway=ether2-local-master
gateway-status=ether2-local-master reachable distance=0 scope=10

/interface print
0 R ether1-gateway ether 1500 1526
1 R ether2-local-master ether 1500 1524 1524
2 ether3-local-slave ether 1500 1524 1524
3 ether4-local-slave ether 1500 1524 1524
4 ether5-local-slave ether 1500 1524 1524
5 X Inspire pppoe-out
6 X pppoe-out1 pppoe-out

/ip firewall export
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=input comment="default configuration" disabled=yes \
protocol=icmp
add action=accept chain=input comment="default configuration" \
connection-state=established disabled=yes in-interface=ether1-gateway
add action=accept chain=input comment="default configuration" \
connection-state=related disabled=yes in-interface=ether1-gateway
add action=drop chain=input comment="default configuration" disabled=yes \
in-interface=ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=\
no out-interface=ether1-gateway
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no
 
petrn
Member Candidate
Member Candidate
Posts: 179
Joined: Thu Jul 29, 2010 3:56 am

Re: PPPOE problems

Fri May 27, 2011 12:35 pm

One more observation - no response packets from PPPoE PAD in your debug log, here is mine log:
May 27 13:29:03 PPP0: bridge-ftth1: sent PADI to FF:FF:FF:FF:FF:FF
May 27 13:29:03 PPP0:     session-id=0x0000
May 27 13:29:03 PPP0:     host-uniq=0x5b
May 27 13:29:03 PPP0:     service-name=
May 27 13:29:04 PPP0: bridge-ftth1: rcvd PADO from 00:00:5E:00:01:07
May 27 13:29:04 PPP0:     session-id=0x0000
May 27 13:29:04 PPP0:     host-uniq=0x5b
May 27 13:29:04 PPP0:     service-name=
May 27 13:29:04 PPP0:     ac-name=GHS04-ME60S01
so either discovery packets not reaching PAD or response back your router ..
Petr
 
User avatar
chris6671980309
just joined
Posts: 20
Joined: Wed Feb 23, 2011 7:06 am
Location: Singapore

Re: PPPOE problems

Fri May 27, 2011 5:43 pm

Backup yr current setup and try this.

1 ) Use Winbox to access the RB750G.
2 ) New Terminal
3 ) Issue this to reset to factory setting
/system reset-configuration no-defaults=yes
4 ) Remove the DHCP-Client setting.
5 ) After reboot, use Winbox to access the RB750G and paste the below setting.
/ip address
add address=192.168.88.1/24 comment="default configuration" disabled=no \
    interface=ether2-local-master network=192.168.88.0

/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server
add address-pool=default-dhcp authoritative=after-2sec-delay bootp-support=static disabled=no interface=ether2-local-master lease-time=3d name=default

/ip dhcp-server network
add address=192.168.88.0/24 comment="default configuration" dns-server=\
    192.168.88.1 gateway=192.168.88.1

/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB max-udp-packet-size=512 \
    servers=208.67.222.222,208.67.220.220

/ip dns static
add address=192.168.88.1 comment="" disabled=no name=router ttl=1d

/interface pppoe-client
add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=\
    "" dial-on-demand=no disabled=no interface=ether1-gateway max-mru=1492 \
    max-mtu=1492 mrru=disabled name=pppoe-out1 password=password profile=\
    default service-name="" use-peer-dns=yes user=username

/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" disabled=\
    no out-interface=pppoe-out1

/ip firewall filter
add action=accept chain=input comment="" disabled=no protocol=\
    icmp
add action=accept chain=input comment="" connection-state=\
    established disabled=no in-interface=pppoe-out1
add action=accept chain=forward comment="" connection-state=\
    related disabled=no in-interface=pppoe-out1
add action=drop chain=input comment="" disabled=no \
    in-interface=pppoe-out1
 
petrn
Member Candidate
Member Candidate
Posts: 179
Joined: Thu Jul 29, 2010 3:56 am

Re: PPPOE problems

Fri May 27, 2011 11:30 pm

run this:
/interface pppoe-client scan ether1-gateway
this is service discovery without making connection
here is my output:
[admin@MikroTik] > /interface pppoe-client scan ether1-gateway
SERVICE                             MAC-ADDRESS       AC-NAME            
                                    00:00:5E:00:01:07 GHS04-ME60S01      
-- [Q quit|D dump|C-z pause]
if ether1-gateway is member of bridge, you have to remove it or run scan on bridge itself and use bridge for pppoe-client setup
Petr
 
supergeek
just joined
Topic Author
Posts: 11
Joined: Thu May 19, 2011 2:34 am

Re: PPPOE problems

Mon May 30, 2011 4:19 am

Thanks chris6671980309 none of that worked sorry.

petrn. When i did the
/interface pppoe-client scan ether1-gateway
i get
[admin@MikroTik] > /interface pppoe-client scan ether1-gateway
SERVICE                             MAC-ADDRESS       AC-NAME 
-- [Q quit|D dump|C-z pause]
even after doing chris6671980309 info.
 
bijoo75
just joined
Posts: 11
Joined: Wed Sep 07, 2011 11:52 am

Re: PPPOE problems

Wed Sep 07, 2011 4:13 pm

HI,

i am also facing the same problem.

anybody got it working ?

Regards,

biju
 
User avatar
Alfabi
newbie
Posts: 31
Joined: Fri Apr 09, 2010 9:52 am
Location: Ukraine
Contact:

Re: PPPOE problems

Thu Sep 08, 2011 4:54 pm

hi, guys, we had something the same, try leave only chap and encryption=no
http://www.bios-computer.com - Fastest WISP in UA
 
Rowan
just joined
Posts: 20
Joined: Sat Dec 15, 2012 11:23 am

Re: PPPOE problems

Sat Dec 29, 2012 2:48 pm

Hi all,

I have been struggling for two days to get my RB2011LN ping out with Vigor 120 attached.

Like initial post I could get Vigor 120 alive via windows PPPoE.

Went through every thing with a fine comb, everything seemed to check out, PPPoE client shows connected, I even tried my RB450 set up to emulate my ISP settings from home (I use a draytec there but as a static IP on O2). Took it to my clients place and put it in fully expectant to work...No joy!

I cannot believe my solution was so simple.

Remove the DHCP Client from ether1- my PPPoE Interface. Then BOOM in the room.
 
soamz
Member
Member
Posts: 429
Joined: Thu Mar 19, 2015 7:19 am

Re: PPPOE problems

Sun Jun 05, 2016 10:40 am


Remove the DHCP Client from ether1- my PPPoE Interface. Then BOOM in the room.

Remove DHCP client fom PPPOE interface ?

Means, where ?
 
surumadurum
just joined
Posts: 11
Joined: Wed Sep 17, 2014 3:22 pm

Re: PPPOE problems

Sat Jul 09, 2016 3:42 pm

Rowan! That's it!
I was stuck for hours, sometimes it conntected for a second and then told me "terminating... hung up".
The thing was it was working like that for the last year, and now, after a reboot, I couldn't get it working again.
Completely forgot there was a DHCP client on my PPOE port.
Puh, now I'm happy.

Who is online

Users browsing this forum: No registered users and 26 guests