Sorry for the long delay.. Summer has almost closed out now, and I can get back to this finally!!
OK, here is the text from the export I did today. I have obviously tried a few different things, and nothing has worked. I have read through the wiki's, and don't quite understand what it is that I should be doing, I guess. between Mangle and NAT, I thought I should have had it. Please take a look and correct any errors you may see, and / or tell me what I did wrong so I can learn from my current disaster!!
By the way, what I want is the following:
port 5900 (VNC) to be forwarded to my internal address of 192.168.1.115
Ports 2074-2093 (IRLP-1) to be forwarded to my internal address of 192.168.1.55
Ports 15425-15427 (IRLP-2) to be forwarded to my internal address of 192.168.1.55
Port 22 (SSH) to be forwarded to my internal address of 192.168.1.55
Port 3389 (RDP) to be forwarded to my internal address of 192.168.1.51
Also, I would be happy having to 192.168.1.55 address in the DMZ, rather than the middle 3 rules, if that is an easy task as well!
Thanks in advance for any and all help!!
/ip firewall connection tracking
set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
tcp-close-wait-timeout=10s tcp-established-timeout=1d \
tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
/ip firewall filter
add action=accept chain=forward disabled=no dst-port=8291 protocol=tcp
add action=accept chain=input disabled=no dst-port=8291 protocol=tcp
add action=accept chain=forward disabled=no dst-address=192.168.1.115 \
dst-port=5900 in-interface=ether1 protocol=tcp src-port=5900
add action=accept chain=forward disabled=no dst-address=192.168.1.55 \
dst-port=80 in-interface=ether1 protocol=tcp src-port=81
add action=accept chain=forward disabled=no dst-address=192.168.1.115 port=\
5900 protocol=udp
/ip firewall mangle
add action=change-mss chain=forward comment="Cable Internet" disabled=no \
new-mss=clamp-to-pmtu protocol=tcp tcp-flags=syn
/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=ether1
add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.89.153 \
dst-port=5900 protocol=tcp to-addresses=192.168.1.115 to-ports=5900
add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.89.153 \
dst-port=5900 protocol=udp to-addresses=192.168.1.115 to-ports=5900
add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.89.153 \
dst-port=22 protocol=tcp to-addresses=192.168.1.55 to-ports=22
add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.89.153 \
dst-port=2074-2093 protocol=udp to-addresses=192.168.1.55 to-ports=\
2074-2093
add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.89.153 \
dst-port=15425-15427 protocol=tcp to-addresses=192.168.1.55 to-ports=\
15425-15427
add action=dst-nat chain=dstnat disabled=no dst-address=xxx.xxx.89.153 \
to-addresses=192.168.1.115
add action=src-nat chain=srcnat disabled=no src-address=192.168.1.115 \
to-addresses=xxx.xxx.89.153
add action=dst-nat chain=dstnat disabled=no dst-port=5900 protocol=tcp \
to-addresses=192.168.1.115 to-ports=5900
add action=dst-nat chain=dstnat disabled=no dst-port=3389 protocol=tcp \
to-addresses=192.168.1.51 to-ports=3389
/ip firewall service-port
set ftp disabled=no ports=21
set tftp disabled=no ports=69
set irc disabled=no ports=6667
set h323 disabled=no
set sip disabled=no ports=5060,5061
set pptp disabled=no